aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-08-22 23:34:34 +0800
committermarino <marino@FreeBSD.org>2015-08-22 23:34:34 +0800
commit5fe2b99994fc6bc463051057285b35eeaea28d4b (patch)
treef32e68c9255c34146e0c16ed22cc56262edd21a7 /devel
parentccd5bf979ad307a1938c0f5788dde0300b801dd2 (diff)
downloadfreebsd-ports-gnome-5fe2b99994fc6bc463051057285b35eeaea28d4b.tar.gz
freebsd-ports-gnome-5fe2b99994fc6bc463051057285b35eeaea28d4b.tar.zst
freebsd-ports-gnome-5fe2b99994fc6bc463051057285b35eeaea28d4b.zip
devel/tclmxl: Alter configure to allow building on DragonFly
This change to the unmaintained port has been in dports for a few months now, so I'm moving the fix over to ports. While here, do some minor fixes to compound commands.
Diffstat (limited to 'devel')
-rw-r--r--devel/tclxml/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/devel/tclxml/Makefile b/devel/tclxml/Makefile
index 337bfb67d334..d8c1152a23a1 100644
--- a/devel/tclxml/Makefile
+++ b/devel/tclxml/Makefile
@@ -32,14 +32,16 @@ MAKE_ENV+= TCLLIBPATH=${STAGEDIR}/usr/local/lib
post-patch:
@${REINPLACE_CMD} -e '/^TCLSH_ENV[[:blank:]]*=/,/[^\]$$/d' \
- ${WRKSRC}/Makefile.in
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's/FreeBSD-\*/FreeBSD-*|DragonFly-*/g' \
+ ${WRKSRC}/configure
post-install:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} doc
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} doc)
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
check test: install
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test)
.include <bsd.port.mk>