aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgrembo <grembo@FreeBSD.org>2015-08-10 00:33:31 +0800
committergrembo <grembo@FreeBSD.org>2015-08-10 00:33:31 +0800
commit6aa589407b5d0e64b53bbb9ab782a26473bf0b40 (patch)
treee83fcc60dcf3e978d202662bddfe5f265c4eb9a8 /devel
parent0e19df1f5a8c52c5e3c0db225a4098e863e7f8c2 (diff)
downloadfreebsd-ports-gnome-6aa589407b5d0e64b53bbb9ab782a26473bf0b40.tar.gz
freebsd-ports-gnome-6aa589407b5d0e64b53bbb9ab782a26473bf0b40.tar.zst
freebsd-ports-gnome-6aa589407b5d0e64b53bbb9ab782a26473bf0b40.zip
Use dos2unix, so patches apply cleanly after commit.
Differential Revision: https://reviews.freebsd.org/D3310 Approved by: mentors (implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/cdash/Makefile4
-rw-r--r--devel/cdash/files/patch-CMakeLists.txt30
2 files changed, 18 insertions, 16 deletions
diff --git a/devel/cdash/Makefile b/devel/cdash/Makefile
index 106d3c84cab0..8ee2972fb4e9 100644
--- a/devel/cdash/Makefile
+++ b/devel/cdash/Makefile
@@ -16,7 +16,9 @@ OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL
OPTIONS_DEFAULT=MYSQL
-USES= cmake:outsource zip
+USES= dos2unix cmake:outsource zip
+DOS2UNIX_GLOB= *.php *.xml *.xsl *.txt
+
CMAKE_ARGS+= -DCDASH_DB_NAME:STRING=cdash \
-DCDASH_DB_LOGIN:STRING=cdash \
-DCDASH_DB_TYPE:STRING=${DB_TYPE}
diff --git a/devel/cdash/files/patch-CMakeLists.txt b/devel/cdash/files/patch-CMakeLists.txt
index d40c7756b331..6fd676961f4c 100644
--- a/devel/cdash/files/patch-CMakeLists.txt
+++ b/devel/cdash/files/patch-CMakeLists.txt
@@ -1,19 +1,19 @@
--- CMakeLists.txt.orig 2012-03-02 11:38:07.000000000 +0100
+++ CMakeLists.txt 2012-03-02 11:38:47.000000000 +0100
@@ -11,6 +11,7 @@
- set(CDASH_DB_PORT "" CACHE STRING "Port to connect to the database")
- set(CDASH_DB_HOST "localhost" CACHE STRING "Hostname of the database server")
- set(CDASH_DB_TYPE "mysql" CACHE STRING "Database type")
-+set(CDASH_DB_NAME "cdash4simpletest" CACHE STRING "Database name")
- option(CDASH_USE_SELENIUM "Should CDash use Selenium to test ajax functionality?" OFF)
- option(CDASH_PRO "Are we testing CDashPro?" OFF)
- set(CMake_SOURCE_DIR CACHE FILEPATH "Path to CMake source dir. Set this to import tests from CMake")
+ set(CDASH_DB_PORT "" CACHE STRING "Port to connect to the database")
+ set(CDASH_DB_HOST "localhost" CACHE STRING "Hostname of the database server")
+ set(CDASH_DB_TYPE "mysql" CACHE STRING "Database type")
++set(CDASH_DB_NAME "cdash4simpletest" CACHE STRING "Database name")
+ option(CDASH_USE_SELENIUM "Should CDash use Selenium to test ajax functionality?" OFF)
+ option(CDASH_PRO "Are we testing CDashPro?" OFF)
+ set(CMake_SOURCE_DIR CACHE FILEPATH "Path to CMake source dir. Set this to import tests from CMake")
@@ -87,7 +88,7 @@
- //
- // Some of the CDash tests also inject config settings below as tests run...
- //
--$CDASH_DB_NAME = 'cdash4simpletest';
-+$CDASH_DB_NAME = '${CDASH_DB_NAME}';
- $CDASH_TESTING_MODE = true;
- $CDASH_REGISTRATION_EMAIL_VERIFY = false;
- $CDASH_TESTING_RENAME_LOGS = ${rename_logs};
+ //
+ // Some of the CDash tests also inject config settings below as tests run...
+ //
+-$CDASH_DB_NAME = 'cdash4simpletest';
++$CDASH_DB_NAME = '${CDASH_DB_NAME}';
+ $CDASH_TESTING_MODE = true;
+ $CDASH_REGISTRATION_EMAIL_VERIFY = false;
+ $CDASH_TESTING_RENAME_LOGS = ${rename_logs};