aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-06-26 21:55:00 +0800
committerpi <pi@FreeBSD.org>2016-06-26 21:55:00 +0800
commitea2e1952b788e222f4c2bc80635d4d3394e10ad6 (patch)
tree41d061c11dbdf82c420afbd3eded964f76fc360a /devel
parent8d91fd25479a7c4e809ef3362b259bb683830dc7 (diff)
downloadfreebsd-ports-gnome-ea2e1952b788e222f4c2bc80635d4d3394e10ad6.tar.gz
freebsd-ports-gnome-ea2e1952b788e222f4c2bc80635d4d3394e10ad6.tar.zst
freebsd-ports-gnome-ea2e1952b788e222f4c2bc80635d4d3394e10ad6.zip
New port: devel/py-calendar
calendar is a python library for parsing and generating iCalendar data. See RFC 5545 and 6350. http://svn.calendarserver.org/repository/calendarserver/PyCalendar/trunk WWW: http://trac.calendarserver.org/wiki/twext PR: 210262 Submitted by: Axel Rau <Axel.Rau@Chaos1.DE>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-calendar/Makefile38
-rw-r--r--devel/py-calendar/distinfo3
-rw-r--r--devel/py-calendar/pkg-descr5
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 23c9bf2a1600..537517bb226c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4001,6 +4001,7 @@
SUBDIR += py-bluelet
SUBDIR += py-boto
SUBDIR += py-botocore
+ SUBDIR += py-calendar
SUBDIR += py-canonicaljson
SUBDIR += py-capstone
SUBDIR += py-cclib
diff --git a/devel/py-calendar/Makefile b/devel/py-calendar/Makefile
new file mode 100644
index 000000000000..857bc2e380cb
--- /dev/null
+++ b/devel/py-calendar/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= calendar
+PORTVERSION= 0.15423
+CATEGORIES= devel python
+MASTER_SITES= http://www.lechner-rau.de/downloads/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pycalendar-${PORTVERSION}
+
+MAINTAINER= axel.rau@chaos1.de
+COMMENT= Library for iCalendar/vCard data
+
+LICENSE= APACHE20
+
+FETCH_DEPENDS= svn:devel/subversion
+
+USES= python:2.7
+USE_PYTHON= distutils autoplist
+NO_ARCH=yes
+
+SVN_REPOSITORY_URL= http://svn.calendarserver.org/repository/calendarserver
+SVN_TAG2= PyCalendar/trunk
+SVN_CMD2= svn export -r15423
+
+maint-gen-distfile:
+ @if [ ! -f "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}" ] ; then \
+ ${MKDIR} ${WRKDIR} ; cd ${WRKDIR} ; ${RM} -Rf ${WRKDIR}/${DISTNAME} ; \
+ ${ECHO_MSG} "=> Checking out PyCalendar from svn.calendarserver.org/..."; \
+ ${SVN_CMD2} ${SVN_REPOSITORY_URL}/${SVN_TAG2} > /dev/null ; \
+ ${MV} trunk ${DISTNAME} ; \
+ ${ECHO_MSG} "=> Creating tar archive ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}"; \
+ cd ${WRKDIR} ; tar -czf ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${DISTNAME} ; \
+ ${RM} -Rf ${WRKDIR}/${DISTNAME} ; \
+ else \
+ ${ECHO_MSG} "===> ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} found." ; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/devel/py-calendar/distinfo b/devel/py-calendar/distinfo
new file mode 100644
index 000000000000..eb0b20a8e52e
--- /dev/null
+++ b/devel/py-calendar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1464107977
+SHA256 (pycalendar-0.15423.tar.gz) = 1002682bc4d617c063b596103d8918068bc3eb3a1ac47b5d8f59bb881c61bd6f
+SIZE (pycalendar-0.15423.tar.gz) = 128963
diff --git a/devel/py-calendar/pkg-descr b/devel/py-calendar/pkg-descr
new file mode 100644
index 000000000000..2526fa814b67
--- /dev/null
+++ b/devel/py-calendar/pkg-descr
@@ -0,0 +1,5 @@
+calendar is a python library for parsing and generating iCalendar data.
+See RFC 5545 and 6350.
+http://svn.calendarserver.org/repository/calendarserver/PyCalendar/trunk
+
+WWW: http://trac.calendarserver.org/wiki/twext