aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2007-02-09 08:13:47 +0800
committerlofi <lofi@FreeBSD.org>2007-02-09 08:13:47 +0800
commitf628f3ac249bf1bf8c5eac7a6cf626539050eb45 (patch)
tree97b908022454f21817f2729763beb8265b708346 /devel
parent12ad7b39ad151be70993d95ddeccc4fd2e4d3e0f (diff)
downloadfreebsd-ports-gnome-f628f3ac249bf1bf8c5eac7a6cf626539050eb45.tar.gz
freebsd-ports-gnome-f628f3ac249bf1bf8c5eac7a6cf626539050eb45.tar.zst
freebsd-ports-gnome-f628f3ac249bf1bf8c5eac7a6cf626539050eb45.zip
Install pkgconfig data into the correct location.
Diffstat (limited to 'devel')
-rw-r--r--devel/dbus-qt4/Makefile6
-rw-r--r--devel/dbus-qt4/pkg-plist2
-rw-r--r--devel/qt4-corelib/Makefile4
-rw-r--r--devel/qt4-corelib/pkg-plist2
-rw-r--r--devel/qt4-qtestlib/Makefile5
-rw-r--r--devel/qt4-qtestlib/pkg-plist2
6 files changed, 11 insertions, 10 deletions
diff --git a/devel/dbus-qt4/Makefile b/devel/dbus-qt4/Makefile
index f5a52a72d521..a1ca16acd9dd 100644
--- a/devel/dbus-qt4/Makefile
+++ b/devel/dbus-qt4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dbus
PORTVERSION= 4.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMESUFFIX= -qt4
@@ -69,7 +69,7 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
post-configure:
- ${REINPLACE_CMD} -e 's|local/lib/QtDBus.pc|local/libdata/QtDBus.pc|g' \
- ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtDBus.pc|${PREFIX}/libdata/pkgconfig/QtDBus.pc|g' \
+ ${WRKSRC}/src/Makefile
.include <bsd.port.post.mk>
diff --git a/devel/dbus-qt4/pkg-plist b/devel/dbus-qt4/pkg-plist
index 397a0a235721..7dd82f8512d4 100644
--- a/devel/dbus-qt4/pkg-plist
+++ b/devel/dbus-qt4/pkg-plist
@@ -32,7 +32,7 @@ include/QtDBus/qdbusmessage.h
include/QtDBus/qdbusmetatype.h
include/QtDBus/qdbusreply.h
include/QtDBus/qdbusserver.h
-lib/QtDBus.pc
+libdata/pkgconfig/QtDBus.pc
lib/libQtDBus.la
lib/libQtDBus.prl
lib/libQtDBus.so
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index c21e4460452f..5a69dc86bedb 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= corelib
PORTVERSION= 4.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -75,7 +75,7 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
post-configure:
- ${REINPLACE_CMD} -e 's|local/lib/QtCore.pc|local/libdata/QtCore.pc|g' \
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtCore.pc|${PREFIX}/libdata/pkgconfig/QtCore.pc|g' \
${WRKSRC}/Makefile
.if !defined(PKGNAMESUFFIX)
diff --git a/devel/qt4-corelib/pkg-plist b/devel/qt4-corelib/pkg-plist
index ca1d9e65ca7f..0c22090f0250 100644
--- a/devel/qt4-corelib/pkg-plist
+++ b/devel/qt4-corelib/pkg-plist
@@ -409,7 +409,7 @@ lib/libQtCore.so.4.2
lib/libQtCore.so.4.2.2
lib/libQtCore.so.4.2.2.debug
lib/plugins/.keep_me
-libdata/QtCore.pc
+libdata/pkgconfig/QtCore.pc
@dirrm lib/plugins
@dirrm include/QtCore
@dirrm include/Qt
diff --git a/devel/qt4-qtestlib/Makefile b/devel/qt4-qtestlib/Makefile
index 4bd1937da463..8d4b6d1eaa87 100644
--- a/devel/qt4-qtestlib/Makefile
+++ b/devel/qt4-qtestlib/Makefile
@@ -8,6 +8,7 @@
PORTNAME= qtestlib
PORTVERSION= 4.2.2
+PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -65,7 +66,7 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../bin/qmake
${LN} -sf ${LOCALBASE}/bin/moc4 ${WRKSRC}/../../bin/moc
post-configure:
- ${REINPLACE_CMD} -e 's|local/lib/QtTest.pc|local/libdata/QtTest.pc|g' \
- ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtTest.pc|${PREFIX}/libdata/pkgconfig/QtTest.pc|g' \
+ ${WRKSRC}/src/Makefile
.include <bsd.port.post.mk>
diff --git a/devel/qt4-qtestlib/pkg-plist b/devel/qt4-qtestlib/pkg-plist
index c9c446f3e2f1..c2d55bf78241 100644
--- a/devel/qt4-qtestlib/pkg-plist
+++ b/devel/qt4-qtestlib/pkg-plist
@@ -27,7 +27,7 @@ include/QtTest/qtestkeyboard.h
include/QtTest/qtestmouse.h
include/QtTest/qtestspontaneevent.h
include/QtTest/qtestsystem.h
-lib/QtTest.pc
+libdata/pkgconfig/QtTest.pc
lib/libQtTest.la
lib/libQtTest.prl
lib/libQtTest.so