aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-08-10 00:02:01 +0800
committerpav <pav@FreeBSD.org>2005-08-10 00:02:01 +0800
commit09209c6532feb61475ab9cf07c134e9f9f0ec42f (patch)
tree0d74946482964ea3226f452e09fe73332ce01f2c /devel
parent0088d356dc204a851cbbd34b2f42e6332b0b47fc (diff)
downloadfreebsd-ports-gnome-09209c6532feb61475ab9cf07c134e9f9f0ec42f.tar.gz
freebsd-ports-gnome-09209c6532feb61475ab9cf07c134e9f9f0ec42f.tar.zst
freebsd-ports-gnome-09209c6532feb61475ab9cf07c134e9f9f0ec42f.zip
- Fix build on 5.X and newer
Approved by: portmgr (linimon)
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-intl/Makefile8
-rw-r--r--devel/ruby-intl/files/patch-extconf.rb10
2 files changed, 11 insertions, 7 deletions
diff --git a/devel/ruby-intl/Makefile b/devel/ruby-intl/Makefile
index 3677a1d31255..4cbb45a80d82 100644
--- a/devel/ruby-intl/Makefile
+++ b/devel/ruby-intl/Makefile
@@ -24,12 +24,6 @@ USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALL_TARGET= site-install
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not build on FreeBSD >= 5.x"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}/po/
@@ -40,4 +34,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.jp ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ruby-intl/files/patch-extconf.rb b/devel/ruby-intl/files/patch-extconf.rb
new file mode 100644
index 000000000000..dede2e383696
--- /dev/null
+++ b/devel/ruby-intl/files/patch-extconf.rb
@@ -0,0 +1,10 @@
+--- extconf.rb.orig Wed Aug 25 00:32:00 1999
++++ extconf.rb Tue Aug 9 17:20:04 2005
+@@ -4,6 +4,6 @@
+ $CFLAGS = "-I/usr/local/include";
+ have_library( "xpg4", "setlocale" );
+ have_header( "locale.h" );
+-if ( have_header( "libintl.h" ) and (have_library( "intl", "gettext" ) or have_func( "gettext" )) )
++if ( have_header( "libintl.h" ) and (have_library( "intl", "gettext" , "libintl.h" ) or have_func( "gettext" )) )
+ create_makefile( "intl" );
+ end