aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 10:13:47 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 10:13:47 +0800
commit10756bd8b83f10cbad21542f9fc96d09c92ecf20 (patch)
treeae7a506e091848fdb508f105b16fedba0b2a68ba /devel
parent700998e61bf353222f45dde5bdfd1f57e8bdef1e (diff)
downloadfreebsd-ports-gnome-10756bd8b83f10cbad21542f9fc96d09c92ecf20.tar.gz
freebsd-ports-gnome-10756bd8b83f10cbad21542f9fc96d09c92ecf20.tar.zst
freebsd-ports-gnome-10756bd8b83f10cbad21542f9fc96d09c92ecf20.zip
A configuration management library for programs and daemons.
Features include: * Automatic, dynamic reloading in response to modifications to configuration files. * A simple, but flexible, configuration language, supporting several of the most commonly needed types of data, along with interpolation of strings from the configuration or the system environment (e.g. $(HOME)). * Subscription-based notification of changes to configuration properties. * An import directive allows the configuration of a complex application to be split across several smaller files, or common configuration data to be shared across several applications. WWW: http://github.com/mailrank/configurator Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel')
-rw-r--r--devel/hs-configurator/Makefile21
-rw-r--r--devel/hs-configurator/distinfo2
-rw-r--r--devel/hs-configurator/pkg-descr19
3 files changed, 42 insertions, 0 deletions
diff --git a/devel/hs-configurator/Makefile b/devel/hs-configurator/Makefile
new file mode 100644
index 000000000000..87230a539f7e
--- /dev/null
+++ b/devel/hs-configurator/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-configurator
+# Date created: November 19, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= configurator
+PORTVERSION= 0.2.0.0
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Configuration management
+
+LICENSE= BSD
+
+USE_CABAL= attoparsec>=0.10.0.2 hashable text>=0.11.1.0 unix-compat \
+ unordered-containers
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-configurator/distinfo b/devel/hs-configurator/distinfo
new file mode 100644
index 000000000000..f29e855631fa
--- /dev/null
+++ b/devel/hs-configurator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/configurator-0.2.0.0.tar.gz) = 8a0e20e93d8dca612b744a838ad0b5de05d1ba2d51fb7262aa5a60e7e3af6c7e
+SIZE (cabal/configurator-0.2.0.0.tar.gz) = 14193
diff --git a/devel/hs-configurator/pkg-descr b/devel/hs-configurator/pkg-descr
new file mode 100644
index 000000000000..f186a40516a3
--- /dev/null
+++ b/devel/hs-configurator/pkg-descr
@@ -0,0 +1,19 @@
+A configuration management library for programs and daemons.
+
+Features include:
+
+ * Automatic, dynamic reloading in response to modifications to configuration
+ files.
+
+ * A simple, but flexible, configuration language, supporting several of
+ the most commonly needed types of data, along with interpolation of
+ strings from the configuration or the system environment (e.g.
+ $(HOME)).
+
+ * Subscription-based notification of changes to configuration properties.
+
+ * An import directive allows the configuration of a complex application
+ to be split across several smaller files, or common configuration data
+ to be shared across several applications.
+
+WWW: http://github.com/mailrank/configurator