aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2014-03-13 16:07:37 +0800
committertimur <timur@FreeBSD.org>2014-03-13 16:07:37 +0800
commit203c8c6709b9a031f3b2b7b42a78b8d5d891bb51 (patch)
treee43ca3381d68feaea548231e351e3dfcffa79cd7 /devel
parentbd30427ee2cfd3c59e48bcb855c643d64f5c2724 (diff)
downloadfreebsd-ports-gnome-203c8c6709b9a031f3b2b7b42a78b8d5d891bb51.tar.gz
freebsd-ports-gnome-203c8c6709b9a031f3b2b7b42a78b8d5d891bb51.tar.zst
freebsd-ports-gnome-203c8c6709b9a031f3b2b7b42a78b8d5d891bb51.zip
Didn't commit all the changes due wrong command line
Diffstat (limited to 'devel')
-rw-r--r--devel/talloc/distinfo4
-rw-r--r--devel/talloc/files/talloc.348
-rw-r--r--devel/tevent/distinfo4
-rw-r--r--devel/tevent/files/patch-lib__replace__wscript13
4 files changed, 33 insertions, 36 deletions
diff --git a/devel/talloc/distinfo b/devel/talloc/distinfo
index ea3e04c3369f..ebf5363b9c54 100644
--- a/devel/talloc/distinfo
+++ b/devel/talloc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (talloc-2.0.8.tar.gz) = 1ec11e635e0318dbbb014db38ff96e8dba3ce5f614eeb7d993b4a5b71c016783
-SIZE (talloc-2.0.8.tar.gz) = 433489
+SHA256 (talloc-2.1.0.tar.gz) = 0701393882647f823503e3aa075bc67d75c194b376822377dae2d20f9130f08f
+SIZE (talloc-2.1.0.tar.gz) = 416097
diff --git a/devel/talloc/files/talloc.3 b/devel/talloc/files/talloc.3
index abcfd453630b..e1856180807f 100644
--- a/devel/talloc/files/talloc.3
+++ b/devel/talloc/files/talloc.3
@@ -1,13 +1,22 @@
'\" t
.\" Title: talloc
-.\" Author: [FIXME: author] [see http://docbook.sf.net/el/author]
-.\" Generator: DocBook XSL Stylesheets v1.75.2 <http://docbook.sf.net/>
-.\" Date: 10/06/2011
-.\" Manual: [FIXME: manual]
-.\" Source: [FIXME: source]
+.\" Author: [see the "AUTHOR" section]
+.\" Generator: DocBook XSL Stylesheets v1.76.1 <http://docbook.sf.net/>
+.\" Date: 03/13/2014
+.\" Manual: System Administration tools
+.\" Source: Samba 4.0
.\" Language: English
.\"
-.TH "TALLOC" "3" "10/06/2011" "[FIXME: source]" "[FIXME: manual]"
+.TH "TALLOC" "3" "03/13/2014" "Samba 4\&.0" "System Administration tools"
+.\" -----------------------------------------------------------------
+.\" * Define some portability stuff
+.\" -----------------------------------------------------------------
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.\" http://bugs.debian.org/507673
+.\" http://lists.gnu.org/archive/html/groff/2009-02/msg00013.html
+.\" ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+.ie \n(.g .ds Aq \(aq
+.el .ds Aq '
.\" -----------------------------------------------------------------
.\" * set default formatting
.\" -----------------------------------------------------------------
@@ -95,7 +104,7 @@ The
argument to talloc() can be NULL, in which case a new top level context is created\&.
.SS "void *talloc_size(const void *ctx, size_t size);"
.PP
-The function talloc_size() should be used when you don\'t have a convenient type to pass to talloc()\&. Unlike talloc(), it is not type safe (as it returns a void *), so you are on your own for type checking\&.
+The function talloc_size() should be used when you don\*(Aqt have a convenient type to pass to talloc()\&. Unlike talloc(), it is not type safe (as it returns a void *), so you are on your own for type checking\&.
.SS "(typeof(ptr)) talloc_ptrtype(const void *ctx, ptr);"
.PP
The talloc_ptrtype() macro should be used when you have a pointer and want to allocate memory to point at with this pointer\&. When compiling with gcc >= 3 it is typesafe\&. Note this is a wrapper of talloc_size() and talloc_get_name() will return the current location in the source file\&. and not the type\&.
@@ -129,8 +138,8 @@ To help you find problems in your code caused by this behaviour, if you do try a
.\}
.nf
ERROR: talloc_free with references at some_dir/source/foo\&.c:123
- reference at some_dir/source/other\&.c:325
- reference at some_dir/source/third\&.c:121
+ reference at some_dir/source/other\&.c:325
+ reference at some_dir/source/third\&.c:121
.fi
.if n \{\
@@ -177,8 +186,6 @@ you can talloc_free() any parent of the original pointer\&. That will reduce the
.\}
you can talloc_free() the pointer itself\&. That will destroy the most recently established parent to the pointer and leave the pointer as a child of its current parent\&.
.RE
-.sp
-.RE
.PP
For more control on which parent to remove, see
\(lqtalloc_unlink()\(rq\&.
@@ -365,8 +372,8 @@ Note that if you try and call talloc_steal() on a pointer that has more than one
.\}
.nf
WARNING: talloc_steal with references at some_dir/source/foo\&.c:123
- reference at some_dir/source/other\&.c:325
- reference at some_dir/source/third\&.c:121
+ reference at some_dir/source/other\&.c:325
+ reference at some_dir/source/third\&.c:121
.fi
.if n \{\
@@ -426,7 +433,7 @@ This provides a more flexible reports than talloc_report()\&. It will let you sp
.PP
This enables calling of talloc_report(NULL, stderr) when the program exits\&. In Samba4 this is enabled by using the \-\-leak\-report command line option\&.
.PP
-For it to be useful, this function must be called before any other talloc function as it establishes a "null context" that acts as the top of the tree\&. If you don\'t call this function first then passing NULL to talloc_report() or talloc_report_full() won\'t give you the full tree printout\&.
+For it to be useful, this function must be called before any other talloc function as it establishes a "null context" that acts as the top of the tree\&. If you don\*(Aqt call this function first then passing NULL to talloc_report() or talloc_report_full() won\*(Aqt give you the full tree printout\&.
.PP
Here is a typical talloc report:
.sp
@@ -434,7 +441,7 @@ Here is a typical talloc report:
.RS 4
.\}
.nf
-talloc report on \'null_context\' (total 267 bytes in 15 blocks)
+talloc report on \*(Aqnull_context\*(Aq (total 267 bytes in 15 blocks)
libcli/auth/spnego_parse\&.c:55 contains 31 bytes in 2 blocks
libcli/auth/spnego_parse\&.c:55 contains 31 bytes in 2 blocks
iconv(UTF8,CP850) contains 42 bytes in 2 blocks
@@ -451,7 +458,7 @@ iconv(UTF\-16LE,UTF8) contains 45 bytes in 2 blocks
.PP
This enables calling of talloc_report_full(NULL, stderr) when the program exits\&. In Samba4 this is enabled by using the \-\-leak\-report\-full command line option\&.
.PP
-For it to be useful, this function must be called before any other talloc function as it establishes a "null context" that acts as the top of the tree\&. If you don\'t call this function first then passing NULL to talloc_report() or talloc_report_full() won\'t give you the full tree printout\&.
+For it to be useful, this function must be called before any other talloc function as it establishes a "null context" that acts as the top of the tree\&. If you don\*(Aqt call this function first then passing NULL to talloc_report() or talloc_report_full() won\*(Aqt give you the full tree printout\&.
.PP
Here is a typical full report:
.sp
@@ -459,7 +466,7 @@ Here is a typical full report:
.RS 4
.\}
.nf
-full talloc report on \'root\' (total 18 bytes in 8 blocks)
+full talloc report on \*(Aqroot\*(Aq (total 18 bytes in 8 blocks)
p1 contains 18 bytes in 7 blocks (ref 0)
r1 contains 13 bytes in 2 blocks (ref 0)
reference to: p2
@@ -488,7 +495,7 @@ if (ptr) memset(ptr, 0, sizeof(type));
.\}
.SS "void *talloc_zero_size(const void *\fIctx\fR, size_t \fIsize\fR)"
.PP
-The talloc_zero_size() function is useful when you don\'t have a known type\&.
+The talloc_zero_size() function is useful when you don\*(Aqt have a known type\&.
.SS "void *talloc_memdup(const void *\fIctx\fR, const void *\fIp\fR, size_t size);"
.PP
The talloc_memdup() function is equivalent to:
@@ -619,7 +626,7 @@ This is a handy utility function that returns a talloc context which will be aut
.SS "void *talloc_check_name(const void *ptr, const char *name);"
.PP
This function checks if a pointer has the specified
-\fIname\fR\&. If it does then the pointer is returned\&. It it doesn\'t then NULL is returned\&.
+\fIname\fR\&. If it does then the pointer is returned\&. It it doesn\*(Aqt then NULL is returned\&.
.SS "(type *)talloc_get_type(const void *ptr, type);"
.PP
This macro allows you to do type checking on talloc pointers\&. It is particularly useful for void* private pointers\&. It is equivalent to this:
@@ -662,6 +669,9 @@ All the additional features of talloc(3) over malloc(3) do come at a price\&. We
.PP
malloc(3), strndup(3), vasprintf(3), asprintf(3),
\m[blue]\fB\%http://talloc.samba.org/\fR\m[]
+.SH "AUTHOR"
+.PP
+The original Samba software and related utilities were created by Andrew Tridgell\&. Samba is now developed by the Samba Team as an Open Source project similar to the way the Linux kernel is developed\&.
.SH "COPYRIGHT/LICENSE"
.PP
Copyright (C) Andrew Tridgell 2004
diff --git a/devel/tevent/distinfo b/devel/tevent/distinfo
index 1774a748aa36..e7109ab433da 100644
--- a/devel/tevent/distinfo
+++ b/devel/tevent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tevent-0.9.18.tar.gz) = 5c636a0c55a7b59745bae0d8ae3900b5ea8c09bfff6001dcd95f1db9cd06ea4f
-SIZE (tevent-0.9.18.tar.gz) = 505276
+SHA256 (tevent-0.9.21.tar.gz) = f2be7463573dab2d8210cb57fe7e7e2aeb323274cbdc865a6e29ddcfb977f0f4
+SIZE (tevent-0.9.21.tar.gz) = 550606
diff --git a/devel/tevent/files/patch-lib__replace__wscript b/devel/tevent/files/patch-lib__replace__wscript
deleted file mode 100644
index cb54e73c05dc..000000000000
--- a/devel/tevent/files/patch-lib__replace__wscript
+++ /dev/null
@@ -1,13 +0,0 @@
---- lib/replace/wscript.orig 2013-06-30 21:48:11.959883882 +0000
-+++ lib/replace/wscript 2013-06-30 21:48:25.639903597 +0000
-@@ -53,8 +53,9 @@
- conf.ADD_CFLAGS(f)
- break
-
-- if conf.CHECK_CFLAGS(['-fstack-protector']):
-+ if conf.CHECK_CFLAGS(['-fstack-protector']) and conf.CHECK_LDFLAGS(['-fstack-protector']):
- conf.ADD_CFLAGS('-fstack-protector')
-+ conf.ADD_LDFLAGS('-fstack-protector')
-
- # Try to find the right extra flags for -Werror behaviour
- for f in ["-Werror", # GCC