aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-04-13 02:45:52 +0800
committermakc <makc@FreeBSD.org>2009-04-13 02:45:52 +0800
commit372d4e02dfbf0f92794502ec08a87fb7c138fb39 (patch)
tree3932c8addcc760ac0fd31865c3adcf165ad8a13d /devel
parent89ce215efd6ef82d3ef7792c98e8466ecf21fe27 (diff)
downloadfreebsd-ports-gnome-372d4e02dfbf0f92794502ec08a87fb7c138fb39.tar.gz
freebsd-ports-gnome-372d4e02dfbf0f92794502ec08a87fb7c138fb39.tar.zst
freebsd-ports-gnome-372d4e02dfbf0f92794502ec08a87fb7c138fb39.zip
Fix build with subversion-1.6
Mark MAKE_JOBS_SAFE
Diffstat (limited to 'devel')
-rw-r--r--devel/qsvn/Makefile1
-rw-r--r--devel/qsvn/files/patch-svnqt__commititem.cpp10
2 files changed, 11 insertions, 0 deletions
diff --git a/devel/qsvn/Makefile b/devel/qsvn/Makefile
index 7bb429f50aa0..3a60a0e478d5 100644
--- a/devel/qsvn/Makefile
+++ b/devel/qsvn/Makefile
@@ -21,6 +21,7 @@ USE_QT_VER= 4
QT_COMPONENTS= gui sql moc_build uic_build rcc_build qmake_build
USE_LDCONFIG= yes
USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
diff --git a/devel/qsvn/files/patch-svnqt__commititem.cpp b/devel/qsvn/files/patch-svnqt__commititem.cpp
new file mode 100644
index 000000000000..53aa781763da
--- /dev/null
+++ b/devel/qsvn/files/patch-svnqt__commititem.cpp
@@ -0,0 +1,10 @@
+--- ./svnqt/commititem.cpp.orig 2008-05-25 12:01:46.000000000 +0400
++++ ./svnqt/commititem.cpp 2009-04-12 19:26:59.000000000 +0400
+@@ -20,6 +20,7 @@
+ #include "commititem.hpp"
+
+ #include <svn_client.h>
++#include <svn_props.h>
+
+ namespace svn {
+