aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-06-29 13:32:38 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-06-29 13:32:38 +0800
commit4307cb7a95407a01712517ec53d9b6902feef64f (patch)
tree2305a2809ebca4983b08edb4ab8c8f08ad254179 /devel
parent1f735d380bfe9b2807278d8837f8834d84958205 (diff)
downloadfreebsd-ports-gnome-4307cb7a95407a01712517ec53d9b6902feef64f.tar.gz
freebsd-ports-gnome-4307cb7a95407a01712517ec53d9b6902feef64f.tar.zst
freebsd-ports-gnome-4307cb7a95407a01712517ec53d9b6902feef64f.zip
tkcon, a replacement for the standard console that comes with Tk.
It provides many more features than the standard console and is meant primarily to aid one when working with the little details inside tcl and tk. PR: 12441 Submitted by: Jerry Hicks <wghicks@bellsouth.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/tkcon/Makefile32
-rw-r--r--devel/tkcon/distinfo1
-rw-r--r--devel/tkcon/files/patch-aa19
-rw-r--r--devel/tkcon/pkg-comment1
-rw-r--r--devel/tkcon/pkg-descr5
-rw-r--r--devel/tkcon/pkg-plist20
6 files changed, 78 insertions, 0 deletions
diff --git a/devel/tkcon/Makefile b/devel/tkcon/Makefile
new file mode 100644
index 000000000000..f24eb77f9ff8
--- /dev/null
+++ b/devel/tkcon/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: tkcon
+# Version required: 1.6
+# Date created: 28 Jun 1999
+# Whom: wghicks@bellsouth.net
+#
+# $Id$
+#
+
+DISTNAME= tkcon-1.6
+CATEGORIES= devel tk80
+MASTER_SITES= ftp://ftp.neosoft.com/languages/tcl/sorted/devel/
+
+MAINTAINER= wghicks@bellsouth.net
+
+RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
+
+NO_BUILD= yes
+
+post-patch:
+ @${PERL} -pi -e 's:/usr/local:${PREFIX}:' ${WRKSRC}/tkcon.tcl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tkcon.tcl ${PREFIX}/bin/tkcon
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/tkcon
+ ${INSTALL_DATA} ${WRKSRC}/README.txt $(PREFIX)/share/doc/tkcon/README.tkcon
+ ${INSTALL_DATA} ${WRKSRC}/docs/* $(PREFIX)/share/doc/tkcon
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/tkcon/distinfo b/devel/tkcon/distinfo
new file mode 100644
index 000000000000..10c8c742906a
--- /dev/null
+++ b/devel/tkcon/distinfo
@@ -0,0 +1 @@
+MD5 (tkcon-1.6.tar.gz) = 3fe992642ddd27f3ea21548b1b26ab61
diff --git a/devel/tkcon/files/patch-aa b/devel/tkcon/files/patch-aa
new file mode 100644
index 000000000000..d81f4c46e0d9
--- /dev/null
+++ b/devel/tkcon/files/patch-aa
@@ -0,0 +1,19 @@
+--- tkcon.tcl.orig Thu Apr 1 05:49:22 1999
++++ tkcon.tcl Mon Jun 28 21:35:52 1999
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # \
+-exec wish "$0" ${1+"$@"}
++if [ X$WISH != X ]; then exec $WISH "$0" -- "$@"; else exec wish8.0 "$0" -- "$@"; fi;
+
+ #
+ ## tkcon.tcl
+@@ -133,7 +133,7 @@
+ }
+ version 1.6
+ release {31 March 1999}
+- docs "http://www.purl.org/net/hobbs/tcl/script/tkcon/\nhttp://www.hobbs.wservice.com/tcl/script/tkcon/"
++ docs "file:/usr/local/share/doc/tkcon/\nhttp://www.hobbs.wservice.com/tcl/script/tkcon/"
+ email {jeff.hobbs@acm.org}
+ root .
+ }
diff --git a/devel/tkcon/pkg-comment b/devel/tkcon/pkg-comment
new file mode 100644
index 000000000000..c0e75187590e
--- /dev/null
+++ b/devel/tkcon/pkg-comment
@@ -0,0 +1 @@
+Tk console for Tcl
diff --git a/devel/tkcon/pkg-descr b/devel/tkcon/pkg-descr
new file mode 100644
index 000000000000..2a189612c751
--- /dev/null
+++ b/devel/tkcon/pkg-descr
@@ -0,0 +1,5 @@
+TkCon is a replacement for the standard console that comes with Tk.
+
+The console itself provides many more features than the standard console.
+It is meant primarily to aid one when working with the little details
+inside tcl and tk.
diff --git a/devel/tkcon/pkg-plist b/devel/tkcon/pkg-plist
new file mode 100644
index 000000000000..7a287a637113
--- /dev/null
+++ b/devel/tkcon/pkg-plist
@@ -0,0 +1,20 @@
+bin/tkcon
+share/doc/tkcon/README.tkcon
+share/doc/tkcon/bindings.html
+share/doc/tkcon/changes.txt
+share/doc/tkcon/demopic.gif
+share/doc/tkcon/dump.html
+share/doc/tkcon/idebug.html
+share/doc/tkcon/index.html
+share/doc/tkcon/license.terms
+share/doc/tkcon/limits.html
+share/doc/tkcon/nontcl.html
+share/doc/tkcon/observe.html
+share/doc/tkcon/perl.txt
+share/doc/tkcon/plugin.html
+share/doc/tkcon/procs.html
+share/doc/tkcon/purpose.html
+share/doc/tkcon/start.html
+share/doc/tkcon/tkcon.html
+share/doc/tkcon/todo.html
+@dirrm share/doc/tkcon