aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2001-04-04 23:13:28 +0800
committernbm <nbm@FreeBSD.org>2001-04-04 23:13:28 +0800
commit4c81fbe53b08f333648cc5b548176062e101a760 (patch)
tree3bcc344849efe3e3742f64107007d7ea1a1d7a59 /devel
parent4fe6feb5d6000665da8feff79306f57f81afd320 (diff)
downloadfreebsd-ports-gnome-4c81fbe53b08f333648cc5b548176062e101a760.tar.gz
freebsd-ports-gnome-4c81fbe53b08f333648cc5b548176062e101a760.tar.zst
freebsd-ports-gnome-4c81fbe53b08f333648cc5b548176062e101a760.zip
Add py-orbit, python bindings for ORBit, a CORBA 2.2-compliant ORB.
PR: 26346 Submitted by: Johann Visagie <johann@egenetics.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-orbit/Makefile25
-rw-r--r--devel/py-orbit/distinfo1
-rw-r--r--devel/py-orbit/pkg-comment1
-rw-r--r--devel/py-orbit/pkg-descr23
-rw-r--r--devel/py-orbit/pkg-plist4
-rw-r--r--devel/py-orbit2/Makefile25
-rw-r--r--devel/py-orbit2/distinfo1
-rw-r--r--devel/py-orbit2/pkg-comment1
-rw-r--r--devel/py-orbit2/pkg-descr23
-rw-r--r--devel/py-orbit2/pkg-plist4
11 files changed, 109 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4a0b1536c77d..00ab9d7a7fd7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -368,6 +368,7 @@
SUBDIR += py-ncurses
SUBDIR += qtarch
SUBDIR += py-omniorb
+ SUBDIR += py-orbit
SUBDIR += qt-designer
SUBDIR += qtez
SUBDIR += qtk
diff --git a/devel/py-orbit/Makefile b/devel/py-orbit/Makefile
new file mode 100644
index 000000000000..d31e019185d5
--- /dev/null
+++ b/devel/py-orbit/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-orbit
+# Date created: 4 April 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= orbit
+PORTVERSION= 0.2.0
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= orbit-python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= orbit-python-${PORTVERSION}
+
+MAINTAINER= johann@egenetics.com
+
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
+
+USE_GMAKE= yes
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-orbit/distinfo b/devel/py-orbit/distinfo
new file mode 100644
index 000000000000..bde22e7d5a2c
--- /dev/null
+++ b/devel/py-orbit/distinfo
@@ -0,0 +1 @@
+MD5 (orbit-python-0.2.0.tar.gz) = 56ebe0f2c9194e338c48b7f931003722
diff --git a/devel/py-orbit/pkg-comment b/devel/py-orbit/pkg-comment
new file mode 100644
index 000000000000..ad53b5fe81f8
--- /dev/null
+++ b/devel/py-orbit/pkg-comment
@@ -0,0 +1 @@
+Python bindings for ORBit, a CORBA 2.2-compliant ORB
diff --git a/devel/py-orbit/pkg-descr b/devel/py-orbit/pkg-descr
new file mode 100644
index 000000000000..7133834bcf7b
--- /dev/null
+++ b/devel/py-orbit/pkg-descr
@@ -0,0 +1,23 @@
+ORBit-Python provides Python bindings for ORBit, an open source CORBA
+2.2-compliant Object Request Broker.
+
+To paraphrase the README:
+
+ ORBit-Python makes full use of the fact that Python is a dynamically typed
+ language. It not only does away with the need for an IDL compiler, but
+ takes the dynamic approach one step further by automatically discovering
+ available IDL modules and transparently loading them when the corresponding
+ modules get imported. When the IDL files are loaded, the appropriate
+ objects and classes are created dynamically.
+
+ Most of the ORBit types are implemented, with the exception of the fixed
+ and long double types. (Wide types are partially supported and currently
+ experimental.) Also, only a fairly small subset of the POA is implemented.
+
+ Considerable effort has been taken to adhere to the Python Language Mapping
+ Specification and remain compatible with other Python ORBs.
+
+Author: Jason Tackaberry <tack@linux.com>
+WWW: http://orbit-python.sault.org/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/devel/py-orbit/pkg-plist b/devel/py-orbit/pkg-plist
new file mode 100644
index 000000000000..6a2e82909421
--- /dev/null
+++ b/devel/py-orbit/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/CORBAmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/PortableServermodule.so
+include/orbit-python/orbit-python.h
+@dirrm include/orbit-python
diff --git a/devel/py-orbit2/Makefile b/devel/py-orbit2/Makefile
new file mode 100644
index 000000000000..d31e019185d5
--- /dev/null
+++ b/devel/py-orbit2/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: py-orbit
+# Date created: 4 April 2001
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= orbit
+PORTVERSION= 0.2.0
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= orbit-python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= orbit-python-${PORTVERSION}
+
+MAINTAINER= johann@egenetics.com
+
+LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
+
+USE_GMAKE= yes
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-orbit2/distinfo b/devel/py-orbit2/distinfo
new file mode 100644
index 000000000000..bde22e7d5a2c
--- /dev/null
+++ b/devel/py-orbit2/distinfo
@@ -0,0 +1 @@
+MD5 (orbit-python-0.2.0.tar.gz) = 56ebe0f2c9194e338c48b7f931003722
diff --git a/devel/py-orbit2/pkg-comment b/devel/py-orbit2/pkg-comment
new file mode 100644
index 000000000000..ad53b5fe81f8
--- /dev/null
+++ b/devel/py-orbit2/pkg-comment
@@ -0,0 +1 @@
+Python bindings for ORBit, a CORBA 2.2-compliant ORB
diff --git a/devel/py-orbit2/pkg-descr b/devel/py-orbit2/pkg-descr
new file mode 100644
index 000000000000..7133834bcf7b
--- /dev/null
+++ b/devel/py-orbit2/pkg-descr
@@ -0,0 +1,23 @@
+ORBit-Python provides Python bindings for ORBit, an open source CORBA
+2.2-compliant Object Request Broker.
+
+To paraphrase the README:
+
+ ORBit-Python makes full use of the fact that Python is a dynamically typed
+ language. It not only does away with the need for an IDL compiler, but
+ takes the dynamic approach one step further by automatically discovering
+ available IDL modules and transparently loading them when the corresponding
+ modules get imported. When the IDL files are loaded, the appropriate
+ objects and classes are created dynamically.
+
+ Most of the ORBit types are implemented, with the exception of the fixed
+ and long double types. (Wide types are partially supported and currently
+ experimental.) Also, only a fairly small subset of the POA is implemented.
+
+ Considerable effort has been taken to adhere to the Python Language Mapping
+ Specification and remain compatible with other Python ORBs.
+
+Author: Jason Tackaberry <tack@linux.com>
+WWW: http://orbit-python.sault.org/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/devel/py-orbit2/pkg-plist b/devel/py-orbit2/pkg-plist
new file mode 100644
index 000000000000..6a2e82909421
--- /dev/null
+++ b/devel/py-orbit2/pkg-plist
@@ -0,0 +1,4 @@
+lib/%%PYTHON_VERSION%%/site-packages/CORBAmodule.so
+lib/%%PYTHON_VERSION%%/site-packages/PortableServermodule.so
+include/orbit-python/orbit-python.h
+@dirrm include/orbit-python