aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-08-31 12:35:57 +0800
committerswills <swills@FreeBSD.org>2014-08-31 12:35:57 +0800
commit5f59b471768e175ca2b8b9f4401c010ca2415d14 (patch)
tree09381739f760e1db4a64bf9e17b3900c40009739 /devel
parenta4f3193c21d6e6c5de017004ed06345bcf038ae0 (diff)
downloadfreebsd-ports-gnome-5f59b471768e175ca2b8b9f4401c010ca2415d14.tar.gz
freebsd-ports-gnome-5f59b471768e175ca2b8b9f4401c010ca2415d14.tar.zst
freebsd-ports-gnome-5f59b471768e175ca2b8b9f4401c010ca2415d14.zip
devel/rubygem-rugged: add port for rubygem-rugged
Rugged is a Ruby bindings to the libgit2 linkable C Git library. WWW: https://github.com/libgit2/rugged
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile2
-rw-r--r--devel/rubygem-rugged/Makefile22
-rw-r--r--devel/rubygem-rugged/distinfo2
-rw-r--r--devel/rubygem-rugged/pkg-descr3
4 files changed, 28 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 5fb664396226..c288e4ccb63f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4254,7 +4254,6 @@
SUBDIR += rubygem-bugspots
SUBDIR += rubygem-builder
SUBDIR += rubygem-builder31
- SUBDIR += rubygem-builder32
SUBDIR += rubygem-byebug
SUBDIR += rubygem-caesars
SUBDIR += rubygem-cairo-gobject
@@ -4488,6 +4487,7 @@
SUBDIR += rubygem-rubyinlineaccel
SUBDIR += rubygem-rubytree
SUBDIR += rubygem-rufus-scheduler
+ SUBDIR += rubygem-rugged
SUBDIR += rubygem-runt
SUBDIR += rubygem-ruport
SUBDIR += rubygem-safe_yaml
diff --git a/devel/rubygem-rugged/Makefile b/devel/rubygem-rugged/Makefile
new file mode 100644
index 000000000000..3cb02947597e
--- /dev/null
+++ b/devel/rubygem-rugged/Makefile
@@ -0,0 +1,22 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rugged
+PORTVERSION= 0.21.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Rugged is a Ruby binding to the libgit2 linkable library
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+LIB_DEPENDS= libgit2.so.${PORTVERSION}:${PORTSDIR}/devel/libgit2
+
+USE_RUBY= yes
+USES= pkgconfig
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST=yes
+
+CONFIGURE_ARGS+= --use-system-libraries
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rugged/distinfo b/devel/rubygem-rugged/distinfo
new file mode 100644
index 000000000000..77899613edb7
--- /dev/null
+++ b/devel/rubygem-rugged/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rugged-0.21.0.gem) = e536ec53d7f08109960e159e5401e682dd03f6ab386f84f93ef71e1968817529
+SIZE (rubygem/rugged-0.21.0.gem) = 918528
diff --git a/devel/rubygem-rugged/pkg-descr b/devel/rubygem-rugged/pkg-descr
new file mode 100644
index 000000000000..6257ddb80717
--- /dev/null
+++ b/devel/rubygem-rugged/pkg-descr
@@ -0,0 +1,3 @@
+Rugged is a Ruby bindings to the libgit2 linkable C Git library.
+
+WWW: https://github.com/libgit2/rugged