aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlth <lth@FreeBSD.org>2007-04-16 20:30:40 +0800
committerlth <lth@FreeBSD.org>2007-04-16 20:30:40 +0800
commit6188d9e1283d6053f0f54984765ed28bbf8506a1 (patch)
tree6ba00f85911a97080601c37196224d5d2fb1cafb /devel
parentcc056ae9584a9d82031a61e15ada9e656100fc7d (diff)
downloadfreebsd-ports-gnome-6188d9e1283d6053f0f54984765ed28bbf8506a1.tar.gz
freebsd-ports-gnome-6188d9e1283d6053f0f54984765ed28bbf8506a1.tar.zst
freebsd-ports-gnome-6188d9e1283d6053f0f54984765ed28bbf8506a1.zip
Fix problem with optional dependecy
Noted by: pointyhat via kris
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Test-YAML-Valid/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/devel/p5-Test-YAML-Valid/Makefile b/devel/p5-Test-YAML-Valid/Makefile
index 90f2a9bb03f5..41a738816c4f 100644
--- a/devel/p5-Test-YAML-Valid/Makefile
+++ b/devel/p5-Test-YAML-Valid/Makefile
@@ -19,10 +19,18 @@ RUN_DEPENDS= p5-YAML>=0.60:${PORTSDIR}/textproc/p5-YAML \
p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple
BUILD_DEPENDS= ${RUN_DEPENDS}
-IGNORE= is missing a dependency
-
PERL_CONFIGURE= yes
MAN3= Test::YAML::Valid.3
-.include <bsd.port.mk>
+OPTIONS= YAMLSYCK "Use YAML::Syck for testing" OFF
+
+post-configure:
+ ${PERL} -pi -e '$$_="" if /auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+.if defined(WITH_YAMLSYCK)
+RUN_DEPENDS+= p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
+BUILD_DEPENDS+= p5-YAML-Syck>0:${PORTSDIR}/textproc/p5-YAML-Syck
+.endif
+.include <bsd.port.post.mk>