aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-26 03:58:56 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-26 03:58:56 +0800
commit735e2b77c8fe97ab091434e75e337c850ecad16d (patch)
treeeeaa3cc332d565719e27d1e89a767b8bc649b43b /devel
parent86a749e12ff1d2ccdd2d785d724da59127b4f727 (diff)
downloadfreebsd-ports-gnome-735e2b77c8fe97ab091434e75e337c850ecad16d.tar.gz
freebsd-ports-gnome-735e2b77c8fe97ab091434e75e337c850ecad16d.tar.zst
freebsd-ports-gnome-735e2b77c8fe97ab091434e75e337c850ecad16d.zip
- Add LICENSE
- Remove outdated RUBY_VER check - Support STAGEDIR - While I'm here, silence post-extract: message and unsilence installation message PR: ports/184212 Submitted by: Vladimir Kondratiev <wulf@cicgroup.ru> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/rubygem-debugger/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/devel/rubygem-debugger/Makefile b/devel/rubygem-debugger/Makefile
index 81ab0c35102a..7813a4e2cefb 100644
--- a/devel/rubygem-debugger/Makefile
+++ b/devel/rubygem-debugger/Makefile
@@ -9,31 +9,23 @@ MASTER_SITES= RG
MAINTAINER= wulf@cicgroup.ru
COMMENT= Fast implementation of the standard Ruby debugger
+LICENSE= BSD
+
+FETCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/${RUBY_PORT}:patch
RUN_DEPENDS= rubygem-columnize>=0.3.1:${PORTSDIR}/devel/rubygem-columnize \
rubygem-debugger-linecache>=1.2.0:${PORTSDIR}/devel/rubygem-debugger-linecache
USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-PLIST_FILES= bin/rdebug
-MAN1= rdebug.1
+PLIST_FILES= bin/rdebug man/man1/rdebug.1.gz
CONFIGURE_ARGS= --with-ruby-include=${WRKDIR}/ruby
post-extract:
- ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; make -V WRKSRC` ${WRKDIR}/ruby
+ @${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; make -V WRKSRC` ${WRKDIR}/ruby
post-install:
- @${INSTALL_MAN} ${WRKSRC}/man/rdebug.1 ${PREFIX}/man/man1
-
-NO_STAGE= yes
-
-.include <bsd.port.pre.mk>
-
-BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/${RUBY_PORT}:patch
-
-.if ${RUBY_VER} == 1.8
-BROKEN= does not work with ruby 1.8
-.endif
+ ${INSTALL_MAN} ${WRKSRC}/man/rdebug.1 ${STAGEDIR}${PREFIX}/man/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>