aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-18 13:41:51 +0800
committermarino <marino@FreeBSD.org>2016-08-18 13:41:51 +0800
commit8355d180929f6f4b7d25b962a22cdd289ed89125 (patch)
treeba46ae646794bc7d7d31603e1f33a0bfe6cf5b33 /devel
parent6c04525f839b1bc141aae56e2aaf09dcc0c95781 (diff)
downloadfreebsd-ports-gnome-8355d180929f6f4b7d25b962a22cdd289ed89125.tar.gz
freebsd-ports-gnome-8355d180929f6f4b7d25b962a22cdd289ed89125.tar.zst
freebsd-ports-gnome-8355d180929f6f4b7d25b962a22cdd289ed89125.zip
devel/py-cffi: Use OPSYS with OSVERSION, USES+= localbase
r419747 introduced OSVERSION with a ">" comparison without using coupling with OPSYS, fix. It also removed CFLAGS and LDFLAGS as "unnecessary", but the fact is they are still required for non-standard localbases and compilers that don't search /usr/local/include by default. Restore these flags with the equivalent USES+=localbase Approved by: OPVERSION/OPSYS blanket, just-fix-it
Diffstat (limited to 'devel')
-rw-r--r--devel/py-cffi/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/py-cffi/Makefile b/devel/py-cffi/Makefile
index 069db019c39c..525ef204d548 100644
--- a/devel/py-cffi/Makefile
+++ b/devel/py-cffi/Makefile
@@ -18,12 +18,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycparser>=2.10:devel/py-pycparser
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest
# Actually 2.6-2.7,3.2-3.5
-USES= python
+USES= localbase python
USE_PYTHON= autoplist distutils
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 1100000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100000
CFLAGS+= -Wno-shift-negative-value
.endif