aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-05-31 09:37:28 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-05-31 09:37:28 +0800
commit8b04de7bd22d718d439766127bb34b78077ba45b (patch)
treeffbbdc21193ffcbba0ecc5ddd98bbceaad3a0380 /devel
parentd4e9d185f50c0076de83506bdd89099f63f7599b (diff)
downloadfreebsd-ports-gnome-8b04de7bd22d718d439766127bb34b78077ba45b.tar.gz
freebsd-ports-gnome-8b04de7bd22d718d439766127bb34b78077ba45b.tar.zst
freebsd-ports-gnome-8b04de7bd22d718d439766127bb34b78077ba45b.zip
- Fix build with Perl 5.14
- While I'm here, sort MAN3 PR: ports/157223 Submitted by: Alexander <freebsd@nagilum.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-ExtUtils-MakeMaker/Makefile29
1 files changed, 15 insertions, 14 deletions
diff --git a/devel/p5-ExtUtils-MakeMaker/Makefile b/devel/p5-ExtUtils-MakeMaker/Makefile
index 0b5f68bbff0b..f27a3df6e6ff 100644
--- a/devel/p5-ExtUtils-MakeMaker/Makefile
+++ b/devel/p5-ExtUtils-MakeMaker/Makefile
@@ -14,23 +14,24 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Designed to write a Makefile for an extension module
-PERL_CONFIGURE= YES
+PERL_CONFIGURE= yes
-MAN3= ExtUtils::Installed.3 ExtUtils::MM_OS2.3 ExtUtils::MakeMaker.3 \
- ExtUtils::Install.3 ExtUtils::Manifest.3 \
- ExtUtils::MM_Unix.3 ExtUtils::Mksymlists.3 ExtUtils::MM.3 \
- ExtUtils::MM_Win32.3 ExtUtils::MM_UWIN.3 ExtUtils::testlib.3 \
- ExtUtils::MY.3 ExtUtils::MM_DOS.3 \
- ExtUtils::MM_Cygwin.3 ExtUtils::MM_MacOS.3 ExtUtils::MM_Win95.3 \
- ExtUtils::MM_VMS.3 ExtUtils::MM_BeOS.3 ExtUtils::Liblist.3 \
- ExtUtils::MakeMaker::Tutorial.3 ExtUtils::Packlist.3 \
- ExtUtils::Mkbootstrap.3 ExtUtils::MakeMaker::FAQ.3 \
- ExtUtils::Command::MM.3 \
- ExtUtils::MM_NW5.3 ExtUtils::MM_Any.3 ExtUtils::MM_VOS.3 \
- ExtUtils::MM_QNX.3 ExtUtils::MM_AIX.3 ExtUtils::MakeMaker::Config.3 \
- ExtUtils::Command.3 ExtUtils::MM_Darwin.3
+MAN3= ExtUtils::Command.3 ExtUtils::Command::MM.3 ExtUtils::Install.3 \
+ ExtUtils::Installed.3 ExtUtils::Liblist.3 ExtUtils::MM.3 \
+ ExtUtils::MM_AIX.3 ExtUtils::MM_Any.3 ExtUtils::MM_BeOS.3 \
+ ExtUtils::MM_Cygwin.3 ExtUtils::MM_DOS.3 ExtUtils::MM_Darwin.3 \
+ ExtUtils::MM_MacOS.3 ExtUtils::MM_NW5.3 ExtUtils::MM_OS2.3 \
+ ExtUtils::MM_QNX.3 ExtUtils::MM_UWIN.3 ExtUtils::MM_Unix.3 \
+ ExtUtils::MM_VMS.3 ExtUtils::MM_VOS.3 ExtUtils::MM_Win32.3 \
+ ExtUtils::MM_Win95.3 ExtUtils::MY.3 ExtUtils::MakeMaker.3 \
+ ExtUtils::MakeMaker::Config.3 ExtUtils::MakeMaker::FAQ.3 \
+ ExtUtils::MakeMaker::Tutorial.3 ExtUtils::Manifest.3 \
+ ExtUtils::Mkbootstrap.3 ExtUtils::Mksymlists.3 \
+ ExtUtils::Packlist.3 ExtUtils::testlib.3
post-patch:
@${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
+ @[ -e ${LOCALBASE}/lib/perl5/${PERL_VERSION}/mach/CORE/cc_runtime.h ] || \
+ ${SED} -i '' -e '/cc_runtime.h/d' ${WRKSRC}/lib/ExtUtils/MM_Unix.pm
.include <bsd.port.mk>