aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2005-11-18 03:12:22 +0800
committerknu <knu@FreeBSD.org>2005-11-18 03:12:22 +0800
commit9785329e8fa169d36a3821552241cbbd3abc3c33 (patch)
treec6425d1eccdfdcbcb6bdabd550377e9ea5f045f3 /devel
parent51d8d0939368279e6ac7cf912bbf78ec6102da32 (diff)
downloadfreebsd-ports-gnome-9785329e8fa169d36a3821552241cbbd3abc3c33.tar.gz
freebsd-ports-gnome-9785329e8fa169d36a3821552241cbbd3abc3c33.tar.zst
freebsd-ports-gnome-9785329e8fa169d36a3821552241cbbd3abc3c33.zip
Add ruby-flexmock, a simple mock object for Ruby.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-flexmock/Makefile36
-rw-r--r--devel/ruby-flexmock/distinfo3
-rw-r--r--devel/ruby-flexmock/pkg-descr9
-rw-r--r--devel/ruby-flexmock/pkg-plist10
5 files changed, 59 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3b05dd39eceb..592e7fdf51b3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1469,6 +1469,7 @@
SUBDIR += ruby-fam
SUBDIR += ruby-filelock
SUBDIR += ruby-filemagic
+ SUBDIR += ruby-flexmock
SUBDIR += ruby-gconf2
SUBDIR += ruby-gemfinder
SUBDIR += ruby-gems
diff --git a/devel/ruby-flexmock/Makefile b/devel/ruby-flexmock/Makefile
new file mode 100644
index 000000000000..430f9a7dfef9
--- /dev/null
+++ b/devel/ruby-flexmock/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Ruby/FlexMock
+# Date created: 18 November 2005
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flexmock
+PORTVERSION= 0.1.7
+CATEGORIES= devel ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/7073/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A simple mock object for Ruby
+
+USE_ZIP= yes
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+DOCS= CHANGELOG README
+
+do-install:
+ cd ${WRKSRC}; ${RUBY} install.rb
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/test/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-flexmock/distinfo b/devel/ruby-flexmock/distinfo
new file mode 100644
index 000000000000..101d6c1ca9fc
--- /dev/null
+++ b/devel/ruby-flexmock/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/flexmock-0.1.7.zip) = 5d96cb7554620795dd6ea80173cb03af
+SHA256 (ruby/flexmock-0.1.7.zip) = d18d754b1ebe3b7922517c21f832cab75d370fb8473cb98132b5f6431035708e
+SIZE (ruby/flexmock-0.1.7.zip) = 16546
diff --git a/devel/ruby-flexmock/pkg-descr b/devel/ruby-flexmock/pkg-descr
new file mode 100644
index 000000000000..7cca1fe5102f
--- /dev/null
+++ b/devel/ruby-flexmock/pkg-descr
@@ -0,0 +1,9 @@
+sqlite3-ruby provides an interface for the SQLite DB engine version 3.
+This differs from the DBD::SQLite module in that it is more complete,
+and from the ruby DBI version of SQLite in that it is SQLite specific,
+so you can do things that would otherwise be more difficult via DBI.
+If you want portability between backends, use DBI. If you want ease
+of use with SQLite, use this.
+
+Author: Jamis Buck (minam) <jgb3@email.byu.edu>
+WWW: http://sqlite-ruby.rubyforge.org
diff --git a/devel/ruby-flexmock/pkg-plist b/devel/ruby-flexmock/pkg-plist
new file mode 100644
index 000000000000..7604076558d8
--- /dev/null
+++ b/devel/ruby-flexmock/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITELIBDIR%%/flexmock.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_example.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_mock.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_naming.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_samples.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test_should_receive.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGELOG
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%