aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-04-01 21:32:17 +0800
committerijliao <ijliao@FreeBSD.org>2002-04-01 21:32:17 +0800
commit9959ab16289a0cc739f06038072f12f106f11c20 (patch)
treead8f421bd3aed2629c4624b3cb9138e96ed8c8ba /devel
parentddbca69ff1aff092068713fbe3858fdd9e7da157 (diff)
downloadfreebsd-ports-gnome-9959ab16289a0cc739f06038072f12f106f11c20.tar.gz
freebsd-ports-gnome-9959ab16289a0cc739f06038072f12f106f11c20.tar.zst
freebsd-ports-gnome-9959ab16289a0cc739f06038072f12f106f11c20.zip
fix wrong date display + add syntax highlighting
PR: 35048 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/chora/Makefile23
-rw-r--r--devel/chora/files/patch-cvs.php11
-rw-r--r--devel/chora/files/patch-history.php11
-rw-r--r--devel/chora/files/patch-lib_CVSLib_Log.php11
-rw-r--r--devel/chora/pkg-plist1
-rw-r--r--devel/horde-chora/Makefile23
-rw-r--r--devel/horde-chora/files/patch-cvs.php11
-rw-r--r--devel/horde-chora/files/patch-history.php11
-rw-r--r--devel/horde-chora/files/patch-lib_CVSLib_Log.php11
-rw-r--r--devel/horde-chora/pkg-plist1
10 files changed, 114 insertions, 0 deletions
diff --git a/devel/chora/Makefile b/devel/chora/Makefile
index 8456e3a5c6d1..0c794b65d611 100644
--- a/devel/chora/Makefile
+++ b/devel/chora/Makefile
@@ -7,13 +7,32 @@
PORTNAME= chora
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= ftp://ftp.horde.org/pub/chora/tarballs/ \
ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/chora/tarballs/
MAINTAINER= thierry@pompo.net
+#-----------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_ENSCRIPT : if you do not need syntax highlighting;
+#
+# - A4 or DJ : if you run enscript with this paper size.
+#
+#-----------------------------------------------------------------------
+
RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde-devel
+.if !defined(WITHOUT_ENSCRIPT)
+.if defined(A4)
+RUN_DEPENDS= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-a4
+.elif defined(DJ)
+RUN_DEPENDS= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letterdj
+.else
+RUN_DEPENDS= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letter
+.endif
+.endif
NO_BUILD= yes
@@ -58,6 +77,10 @@ do-install:
${HORDE_INC}/httpd.conf.chora
@${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/registry.php
+.if !defined(WITHOUT_ENSCRIPT)
+ @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ ${HORDEDIR}/config/mime_drivers.php
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
diff --git a/devel/chora/files/patch-cvs.php b/devel/chora/files/patch-cvs.php
new file mode 100644
index 000000000000..cbc547379172
--- /dev/null
+++ b/devel/chora/files/patch-cvs.php
@@ -0,0 +1,11 @@
+--- cvs.php.orig Wed Jan 2 18:05:18 2002
++++ cvs.php Sat Feb 16 20:29:37 2002
+@@ -176,7 +176,7 @@
+ }
+
+ $textURL= Chora::url('co', $where, array('r'=>$rev));
+- $commitDate = gmdate('jS F Y, g:ia', $lg->date);
++ $commitDate = date('jS F Y, g:ia', $lg->date);
+ $readableDate = CVSLib_File::readableTime($lg->date, true);
+
+ $aid = $lg->queryAuthor();
diff --git a/devel/chora/files/patch-history.php b/devel/chora/files/patch-history.php
new file mode 100644
index 000000000000..3a19258f2365
--- /dev/null
+++ b/devel/chora/files/patch-history.php
@@ -0,0 +1,11 @@
+--- history.php.orig Wed Jan 2 18:05:19 2002
++++ history.php Sat Feb 16 19:36:54 2002
+@@ -197,7 +197,7 @@
+ $bg = isset($branchColours[$bgbr]) ? $branchColours[$bgbr] : 'white';
+ $log = $fl->logs[$rev];
+ $author = Chora::showAuthorName($log->queryAuthor());
+- $date = gmdate('jS M Y', $log->queryDate());
++ $date = strftime('%e %b %Y', $log->queryDate());
+ $lines = $log->queryChangedLines();
+ include $registry->getTemplatePath() . '/history/rev.inc';
+
diff --git a/devel/chora/files/patch-lib_CVSLib_Log.php b/devel/chora/files/patch-lib_CVSLib_Log.php
new file mode 100644
index 000000000000..6457e1c4045e
--- /dev/null
+++ b/devel/chora/files/patch-lib_CVSLib_Log.php
@@ -0,0 +1,11 @@
+--- lib/CVSLib/Log.php.orig Sat Aug 11 22:59:31 2001
++++ lib/CVSLib/Log.php Sat Feb 16 19:39:47 2002
+@@ -45,7 +45,7 @@
+ case CVSLIB_LOG_DATE:
+ $line = array_shift($raw);
+ if (preg_match("|^date:\s+(\d+)/(\d+)/(\d+)\s+(\d+):(\d+):(\d+);\s+author:\s+(\S+);\s+state:\s+(\S+);(\s+lines:\s+([0-9\s+-]+))?|", $line, $parts)) {
+- $this->date = mktime($parts[4], $parts[5], $parts[6], $parts[2], $parts[3], $parts[1]);
++ $this->date = gmmktime($parts[4], $parts[5], $parts[6], $parts[2], $parts[3], $parts[1]);
+ $this->author = $parts[7];
+ $this->state = $parts[8];
+ $this->lines = isset($parts[10])?$parts[10]:'';
diff --git a/devel/chora/pkg-plist b/devel/chora/pkg-plist
index 0acf99369106..1372e791b870 100644
--- a/devel/chora/pkg-plist
+++ b/devel/chora/pkg-plist
@@ -40,6 +40,7 @@
%%CHORADIR%%/lib/CVSLib/Error.php
%%CHORADIR%%/lib/CVSLib/File.php
%%CHORADIR%%/lib/CVSLib/Log.php
+%%CHORADIR%%/lib/CVSLib/Log.php.orig
%%CHORADIR%%/lib/CVSLib/Rev.php
%%CHORADIR%%/lib/Chora.php
%%CHORADIR%%/lib/MIME/Viewer/text.php
diff --git a/devel/horde-chora/Makefile b/devel/horde-chora/Makefile
index 8456e3a5c6d1..0c794b65d611 100644
--- a/devel/horde-chora/Makefile
+++ b/devel/horde-chora/Makefile
@@ -7,13 +7,32 @@
PORTNAME= chora
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel www
MASTER_SITES= ftp://ftp.horde.org/pub/chora/tarballs/ \
ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/chora/tarballs/
MAINTAINER= thierry@pompo.net
+#-----------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_ENSCRIPT : if you do not need syntax highlighting;
+#
+# - A4 or DJ : if you run enscript with this paper size.
+#
+#-----------------------------------------------------------------------
+
RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde-devel
+.if !defined(WITHOUT_ENSCRIPT)
+.if defined(A4)
+RUN_DEPENDS= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-a4
+.elif defined(DJ)
+RUN_DEPENDS= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letterdj
+.else
+RUN_DEPENDS= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letter
+.endif
+.endif
NO_BUILD= yes
@@ -58,6 +77,10 @@ do-install:
${HORDE_INC}/httpd.conf.chora
@${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/registry.php
+.if !defined(WITHOUT_ENSCRIPT)
+ @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ ${HORDEDIR}/config/mime_drivers.php
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
diff --git a/devel/horde-chora/files/patch-cvs.php b/devel/horde-chora/files/patch-cvs.php
new file mode 100644
index 000000000000..cbc547379172
--- /dev/null
+++ b/devel/horde-chora/files/patch-cvs.php
@@ -0,0 +1,11 @@
+--- cvs.php.orig Wed Jan 2 18:05:18 2002
++++ cvs.php Sat Feb 16 20:29:37 2002
+@@ -176,7 +176,7 @@
+ }
+
+ $textURL= Chora::url('co', $where, array('r'=>$rev));
+- $commitDate = gmdate('jS F Y, g:ia', $lg->date);
++ $commitDate = date('jS F Y, g:ia', $lg->date);
+ $readableDate = CVSLib_File::readableTime($lg->date, true);
+
+ $aid = $lg->queryAuthor();
diff --git a/devel/horde-chora/files/patch-history.php b/devel/horde-chora/files/patch-history.php
new file mode 100644
index 000000000000..3a19258f2365
--- /dev/null
+++ b/devel/horde-chora/files/patch-history.php
@@ -0,0 +1,11 @@
+--- history.php.orig Wed Jan 2 18:05:19 2002
++++ history.php Sat Feb 16 19:36:54 2002
+@@ -197,7 +197,7 @@
+ $bg = isset($branchColours[$bgbr]) ? $branchColours[$bgbr] : 'white';
+ $log = $fl->logs[$rev];
+ $author = Chora::showAuthorName($log->queryAuthor());
+- $date = gmdate('jS M Y', $log->queryDate());
++ $date = strftime('%e %b %Y', $log->queryDate());
+ $lines = $log->queryChangedLines();
+ include $registry->getTemplatePath() . '/history/rev.inc';
+
diff --git a/devel/horde-chora/files/patch-lib_CVSLib_Log.php b/devel/horde-chora/files/patch-lib_CVSLib_Log.php
new file mode 100644
index 000000000000..6457e1c4045e
--- /dev/null
+++ b/devel/horde-chora/files/patch-lib_CVSLib_Log.php
@@ -0,0 +1,11 @@
+--- lib/CVSLib/Log.php.orig Sat Aug 11 22:59:31 2001
++++ lib/CVSLib/Log.php Sat Feb 16 19:39:47 2002
+@@ -45,7 +45,7 @@
+ case CVSLIB_LOG_DATE:
+ $line = array_shift($raw);
+ if (preg_match("|^date:\s+(\d+)/(\d+)/(\d+)\s+(\d+):(\d+):(\d+);\s+author:\s+(\S+);\s+state:\s+(\S+);(\s+lines:\s+([0-9\s+-]+))?|", $line, $parts)) {
+- $this->date = mktime($parts[4], $parts[5], $parts[6], $parts[2], $parts[3], $parts[1]);
++ $this->date = gmmktime($parts[4], $parts[5], $parts[6], $parts[2], $parts[3], $parts[1]);
+ $this->author = $parts[7];
+ $this->state = $parts[8];
+ $this->lines = isset($parts[10])?$parts[10]:'';
diff --git a/devel/horde-chora/pkg-plist b/devel/horde-chora/pkg-plist
index 0acf99369106..1372e791b870 100644
--- a/devel/horde-chora/pkg-plist
+++ b/devel/horde-chora/pkg-plist
@@ -40,6 +40,7 @@
%%CHORADIR%%/lib/CVSLib/Error.php
%%CHORADIR%%/lib/CVSLib/File.php
%%CHORADIR%%/lib/CVSLib/Log.php
+%%CHORADIR%%/lib/CVSLib/Log.php.orig
%%CHORADIR%%/lib/CVSLib/Rev.php
%%CHORADIR%%/lib/Chora.php
%%CHORADIR%%/lib/MIME/Viewer/text.php