aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2002-11-04 21:27:23 +0800
committernectar <nectar@FreeBSD.org>2002-11-04 21:27:23 +0800
commit999300f50eeec81665fd37164be486face8addb0 (patch)
tree4ad9b8867d59f54b8951dd7ba970d19c9621d605 /devel
parentff80a5307f802e50d58a53d0dd24817355635d58 (diff)
downloadfreebsd-ports-gnome-999300f50eeec81665fd37164be486face8addb0.tar.gz
freebsd-ports-gnome-999300f50eeec81665fd37164be486face8addb0.tar.zst
freebsd-ports-gnome-999300f50eeec81665fd37164be486face8addb0.zip
Let splint process <inttypes.h>. Now it passes its own test suite.
Submitted by: Stacey Son <sson@verio.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/splint/Makefile1
-rw-r--r--devel/splint/files/patch-src::Headers::constants.h11
-rw-r--r--devel/splint/files/patch-src::lcllib.c50
3 files changed, 62 insertions, 0 deletions
diff --git a/devel/splint/Makefile b/devel/splint/Makefile
index 3fea897f08c8..542dc26f77f1 100644
--- a/devel/splint/Makefile
+++ b/devel/splint/Makefile
@@ -7,6 +7,7 @@
PORTNAME= splint
PORTVERSION= 3.0.1.6
+PORTREVISION= 1
CATEGORIES= devel security
MASTER_SITES= http://www.splint.org/downloads/
EXTRACT_SUFX= .src.tgz
diff --git a/devel/splint/files/patch-src::Headers::constants.h b/devel/splint/files/patch-src::Headers::constants.h
new file mode 100644
index 000000000000..90fd210e8abe
--- /dev/null
+++ b/devel/splint/files/patch-src::Headers::constants.h
@@ -0,0 +1,11 @@
+--- src/Headers/constants.h.orig Wed Oct 30 16:08:45 2002
++++ src/Headers/constants.h Wed Oct 30 16:09:42 2002
+@@ -97,7 +97,7 @@
+ # define PPMRCODE "@@MR@@"
+
+ /*@constant observer char *DEFAULT_SYSTEMDIR; @*/
+-# define DEFAULT_SYSTEMDIR "/usr/"
++# define DEFAULT_SYSTEMDIR "/usr/include/:/usr/lib/:/usr/local/include/:/usr/local/lib/"
+
+ /*@constant char DEFAULT_COMMENTCHAR; @*/
+ # define DEFAULT_COMMENTCHAR '@'
diff --git a/devel/splint/files/patch-src::lcllib.c b/devel/splint/files/patch-src::lcllib.c
new file mode 100644
index 000000000000..49893ede0fab
--- /dev/null
+++ b/devel/splint/files/patch-src::lcllib.c
@@ -0,0 +1,50 @@
+--- src/lcllib.c.orig Wed Oct 30 17:51:13 2002
++++ src/lcllib.c Wed Oct 30 22:37:48 2002
+@@ -49,13 +49,7 @@
+ extern /*:open:*/ /*@dependent@*/ FILE *yyin;
+ /*@=incondefs@*/ /*@=redecl@*/
+
+-/*@constant int NUMLIBS; @*/
+-# define NUMLIBS 25
+-
+-/*@constant int NUMPOSIXLIBS; @*/
+-# define NUMPOSIXLIBS 18
+-
+-static ob_mstring posixlibs[NUMPOSIXLIBS] =
++static ob_mstring posixlibs[] =
+ {
+ "dirent",
+ "fcntl",
+@@ -77,7 +71,10 @@
+ "utime"
+ } ;
+
+-static ob_mstring stdlibs[NUMLIBS] =
++/*@constant int NUMPOSIXLIBS; @*/
++# define NUMPOSIXLIBS (sizeof(posixlibs) / sizeof(posixlibs[0]))
++
++static ob_mstring stdlibs[] =
+ {
+ "assert",
+ "complex"
+@@ -85,7 +82,10 @@
+ "errno",
+ "fenv",
+ "float",
++#ifndef __FreeBSD__
++/* inttypes.h needs to be parsed on FreeBSD so some defines are known */
+ "inttypes",
++#endif
+ "iso646",
+ "limits",
+ "locale",
+@@ -105,6 +105,9 @@
+ "wchar",
+ "wctype"
+ } ;
++
++/*@constant int NUMLIBS; @*/
++# define NUMLIBS (sizeof(stdlibs) / sizeof(stdlibs[0]))
+
+ static bool loadLCDFile (FILE * p_f, cstring p_name);
+