aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-09 09:55:41 +0800
committerkris <kris@FreeBSD.org>2004-02-09 09:55:41 +0800
commit9c385e1eb05c618f4819bcca6626ab4f747cf7b6 (patch)
tree700fe5bfd61a90714afd51f98a5fdf6d4e00a725 /devel
parentd73ecb4f49aac4a0990bcb41390c7e4f27ab51ca (diff)
downloadfreebsd-ports-gnome-9c385e1eb05c618f4819bcca6626ab4f747cf7b6.tar.gz
freebsd-ports-gnome-9c385e1eb05c618f4819bcca6626ab4f747cf7b6.tar.zst
freebsd-ports-gnome-9c385e1eb05c618f4819bcca6626ab4f747cf7b6.zip
BROKEN on 5.x: broken pkg-plist
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib-devel/Makefile4
-rw-r--r--devel/tcl-neo/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/devel/clanlib-devel/Makefile b/devel/clanlib-devel/Makefile
index d84c2f903f17..04dc72a727cc 100644
--- a/devel/clanlib-devel/Makefile
+++ b/devel/clanlib-devel/Makefile
@@ -41,6 +41,10 @@ LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
.if ${OSVERSION} < 500032
BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
diff --git a/devel/tcl-neo/Makefile b/devel/tcl-neo/Makefile
index 4b4ca83f80d5..4e5b78a15da6 100644
--- a/devel/tcl-neo/Makefile
+++ b/devel/tcl-neo/Makefile
@@ -37,6 +37,12 @@ post-build:
NEO_LIBRARY= ${PREFIX}/lib/neo8.2
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Broken pkg-plist"
+.endif
+
post-install:
${MKDIR} ${NEO_LIBRARY}
${CP} -Rp ${WRKSRC}/../neolibs/[a-z]* ${NEO_LIBRARY}
@@ -44,4 +50,4 @@ post-install:
-e 's,@NEO_VERSION@,8.2,' < ${WRKSRC}/pkgIndex.tcl.in > \
${NEO_LIBRARY}/pkgIndex.tcl
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>