aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-06-05 10:46:33 +0800
committerpi <pi@FreeBSD.org>2016-06-05 10:46:33 +0800
commitabb18c3f45ae6a4694ee1d09eb6f9b8707ac86e0 (patch)
tree25e19af9a69bef2f1b3e5c86edaa01a0c70f5863 /devel
parent7538d6a5623c394f476126d6843b715554cb7a97 (diff)
downloadfreebsd-ports-gnome-abb18c3f45ae6a4694ee1d09eb6f9b8707ac86e0.tar.gz
freebsd-ports-gnome-abb18c3f45ae6a4694ee1d09eb6f9b8707ac86e0.tar.zst
freebsd-ports-gnome-abb18c3f45ae6a4694ee1d09eb6f9b8707ac86e0.zip
devel/qtcreator: 3.6.1 -> 4.0.0
In conjunction with the QBS update to 1.5.0 the Qt Creator IDE is updated to version 4.0.0. The patch is from kde@FreeBSD.org's area51 repository and includes optional installation of the Qt 5 API documentation and the Qt 5 examples to be used with Qt Creator for Qt development. The port also contains the User Manual of Qt Creator after qt5-qdoc has been fixed to enable the build. PR: 209977 Submitted by: Ralf Nolden <nolden@kde.org> (kde), Tobias C.Berner <tcberner@gmail.com> (kde)
Diffstat (limited to 'devel')
-rw-r--r--devel/qtcreator/Makefile25
-rw-r--r--devel/qtcreator/distinfo4
-rw-r--r--devel/qtcreator/pkg-plist74
3 files changed, 50 insertions, 53 deletions
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index f4ba06772cc9..ad1631f9c281 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qtcreator
-DISTVERSION= 3.6.1
+DISTVERSION= 4.0.0
CATEGORIES= devel
MASTER_SITES= QT/official_releases/qtcreator/${DISTVERSION:R}/${DISTVERSION}
DISTNAME= qt-creator-opensource-src-${DISTVERSION}
@@ -11,19 +11,15 @@ DIST_SUBDIR= KDE/Qt/qtcreator
MAINTAINER= kde@FreeBSD.org
COMMENT= C++ and QML IDE for Qt development
-LICENSE= GPLv3 LGPL21 LGPL3
-LICENSE_COMB= dual
-
# depend on the split out qbs
BUILD_DEPENDS= qbs:devel/qbs
RUN_DEPENDS= qbs:devel/qbs
USE_LDCONFIG= ${LOCALBASE}/lib/${PORTNAME}
USES= qmake compiler:c++11-lib
-INSTALLS_ICONS= yes
-USE_QT5= buildtools concurrent core declarative designer gui linguist network\
- qml quick quickcontrols script script sql svg webkit widgets xml\
- xmlpatterns
+USE_QT5= buildtools concurrent core declarative designer gui linguist \
+ network qdoc qml quick quickcontrols script script sql svg \
+ webkit widgets xml xmlpatterns
# be paranoid and do not extract qbs (devel/qbs) copy from source tree
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/src/shared/qbs'
@@ -41,6 +37,19 @@ QMAKE_ARGS+= DEFINES+=_GLIBCXX_USE_C99
DESKTOP_ENTRIES="Qt Creator" "" "QtProject-qtcreator" \
"${PREFIX}/bin/${PORTNAME}" "Development;Qt;" true
+OPTIONS_DEFINE= DOCS EXAMPLES
+DOCS_DESC= Install the Qt5 api documentation
+DOCS_USE= QT5=doc_run
+EXAMPLES_DESC= Install the Qt5 example projects
+EXAMPLES_USE= QT5=examples_run
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+
+ALL_TARGET= all
+INSTALL_TARGET= install
+
+DOCS_ALL_TARGET= docs
+DOCS_INSTALL_TARGET= install_docs
+
# Fix paths for gnuplot and ant.
post-patch:
${REINPLACE_CMD} -e 's|/usr/bin/gnuplot|${LOCALBASE}/bin/gnuplot|' \
diff --git a/devel/qtcreator/distinfo b/devel/qtcreator/distinfo
index 261e7ee4a597..564d719c9daa 100644
--- a/devel/qtcreator/distinfo
+++ b/devel/qtcreator/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/Qt/qtcreator/qt-creator-opensource-src-3.6.1.tar.gz) = e53611f80332cd1d171a9b91f8467b6182186cbec6b4a9301f32367368f15de2
-SIZE (KDE/Qt/qtcreator/qt-creator-opensource-src-3.6.1.tar.gz) = 23144233
+SHA256 (KDE/Qt/qtcreator/qt-creator-opensource-src-4.0.0.tar.gz) = 0cc21d720bafc72ce67f45a5553c618e8fffec3f2f23b94a2b2a9ba68ed0e2c8
+SIZE (KDE/Qt/qtcreator/qt-creator-opensource-src-4.0.0.tar.gz) = 21613655
diff --git a/devel/qtcreator/pkg-plist b/devel/qtcreator/pkg-plist
index b4c27db9e04f..c7a5025ddc09 100644
--- a/devel/qtcreator/pkg-plist
+++ b/devel/qtcreator/pkg-plist
@@ -55,8 +55,8 @@ lib/qtcreator/libUtils.so
lib/qtcreator/libUtils.so.1
lib/qtcreator/libUtils.so.1.0
lib/qtcreator/libUtils.so.1.0.0
-lib/qtcreator/plugins/libAnalyzerBase.so
lib/qtcreator/plugins/libAndroid.so
+lib/qtcreator/plugins/libAutoTest.so
lib/qtcreator/plugins/libAutotoolsProjectManager.so
lib/qtcreator/plugins/libBareMetal.so
lib/qtcreator/plugins/libBazaar.so
@@ -65,6 +65,7 @@ lib/qtcreator/plugins/libBinEditor.so
lib/qtcreator/plugins/libBookmarks.so
lib/qtcreator/plugins/libCMakeProjectManager.so
lib/qtcreator/plugins/libCVS.so
+lib/qtcreator/plugins/libClangStaticAnalyzer.so
lib/qtcreator/plugins/libClassView.so
lib/qtcreator/plugins/libClearCase.so
lib/qtcreator/plugins/libCodePaster.so
@@ -96,6 +97,7 @@ lib/qtcreator/plugins/libQmlDesigner.so
lib/qtcreator/plugins/libQmlJSEditor.so
lib/qtcreator/plugins/libQmlJSTools.so
lib/qtcreator/plugins/libQmlProfiler.so
+lib/qtcreator/plugins/libQmlProfilerExtension.so
lib/qtcreator/plugins/libQmlProjectManager.so
lib/qtcreator/plugins/libQnx.so
lib/qtcreator/plugins/libQtSupport.so
@@ -118,6 +120,8 @@ libexec/qtcreator/qml2puppet
libexec/qtcreator/qtcreator_process_stub
libexec/qtcreator/qtpromaker
libexec/qtcreator/sdktool
+%%PORTDOCS%%%%DOCSDIR%%/qtcreator-dev.qch
+%%PORTDOCS%%%%DOCSDIR%%/qtcreator.qch
share/icons/hicolor/128x128/apps/QtProject-qtcreator.png
share/icons/hicolor/16x16/apps/QtProject-qtcreator.png
share/icons/hicolor/24x24/apps/QtProject-qtcreator.png
@@ -127,8 +131,7 @@ share/icons/hicolor/48x48/apps/QtProject-qtcreator.png
share/icons/hicolor/512x512/apps/QtProject-qtcreator.png
share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/cplusplus/wrappedQtHeaders/QtCore/qobjectdefs.h
-%%DATADIR%%/debugger/LGPL_EXCEPTION.TXT
-%%DATADIR%%/debugger/LICENSE.LGPL
+%%DATADIR%%/debugger/LICENSE.GPL3-EXCEPT
%%DATADIR%%/debugger/README.txt
%%DATADIR%%/debugger/boosttypes.py
%%DATADIR%%/debugger/creatortypes.py
@@ -197,12 +200,6 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/qml-type-descriptions/qtmobility-systeminfo.qmltypes
%%DATADIR%%/qml-type-descriptions/qtmultimediakit.qmltypes
%%DATADIR%%/qml-type-descriptions/qtwebkit.qmltypes
-%%DATADIR%%/qml/qmldump/LGPL_EXCEPTION.TXT
-%%DATADIR%%/qml/qmldump/LICENSE.LGPL
-%%DATADIR%%/qml/qmldump/main.cpp
-%%DATADIR%%/qml/qmldump/qmldump.pro
-%%DATADIR%%/qml/qmldump/qmlstreamwriter.cpp
-%%DATADIR%%/qml/qmldump/qmlstreamwriter.h
%%DATADIR%%/qml/qmlpuppet/commands/changeauxiliarycommand.cpp
%%DATADIR%%/qml/qmlpuppet/commands/changeauxiliarycommand.h
%%DATADIR%%/qml/qmlpuppet/commands/changebindingscommand.cpp
@@ -424,19 +421,24 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/bold-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/cancel.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/down-arrow.png
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/down-arrow@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/expression.png
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/expression@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/icon_color_gradient.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/icon_color_none.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/icon_color_solid.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/italic-h-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/italic-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/placeholder.png
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/placeholder@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/strikeout-h-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/strikeout-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/submenu.png
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/submenu@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/underline-h-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/underline-icon.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/up-arrow.png
+%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/images/up-arrow@2x.png
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/HelperWidgets/qmldir
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/PropertyTemplates/BooleanEditorTemplate.template
%%DATADIR%%/qmldesigner/propertyEditorQmlSources/PropertyTemplates/ColorEditorTemplate.template
@@ -560,6 +562,15 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/qt4project/widget.ui
%%DATADIR%%/templates/shared/qrcdeployment.pri
%%DATADIR%%/templates/wizards/README.txt
+%%DATADIR%%/templates/wizards/autotest/auto.pro
+%%DATADIR%%/templates/wizards/autotest/autotest_24.png
+%%DATADIR%%/templates/wizards/autotest/main.cpp
+%%DATADIR%%/templates/wizards/autotest/src.pro
+%%DATADIR%%/templates/wizards/autotest/tests.pro
+%%DATADIR%%/templates/wizards/autotest/tmp.pro
+%%DATADIR%%/templates/wizards/autotest/tst.pro
+%%DATADIR%%/templates/wizards/autotest/tst_src.cpp
+%%DATADIR%%/templates/wizards/autotest/wizard.xml
%%DATADIR%%/templates/wizards/classes/cpp/file.cpp
%%DATADIR%%/templates/wizards/classes/cpp/file.h
%%DATADIR%%/templates/wizards/classes/cpp/wizard.json
@@ -596,6 +607,8 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/wizards/files/java/wizard.json
%%DATADIR%%/templates/wizards/files/js/file.js
%%DATADIR%%/templates/wizards/files/js/wizard.json
+%%DATADIR%%/templates/wizards/files/modeling/file.qmodel
+%%DATADIR%%/templates/wizards/files/modeling/wizard.json
%%DATADIR%%/templates/wizards/files/python/file.py
%%DATADIR%%/templates/wizards/files/python/wizard.json
%%DATADIR%%/templates/wizards/files/qrc/file.qrc
@@ -636,6 +649,13 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/wizards/projects/qmake/qtcanvas3dapplication/threejs/3rdparty/three.js
%%DATADIR%%/templates/wizards/projects/qmake/qtcanvas3dapplication/threejs/glcode.js
%%DATADIR%%/templates/wizards/projects/qmake/qtcanvas3dapplication/wizard.json
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/Page1.qml.tpl
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/Page1Form.ui.qml.tpl
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/app.pro
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/main.cpp
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/main.qml.tpl
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/qml.qrc
+%%DATADIR%%/templates/wizards/projects/qmake/qtlabscontrolsapplication/wizard.json
%%DATADIR%%/templates/wizards/projects/qmake/qtquickapplication/MainForm.ui.qml.tpl
%%DATADIR%%/templates/wizards/projects/qmake/qtquickapplication/app.pro
%%DATADIR%%/templates/wizards/projects/qmake/qtquickapplication/main.cpp
@@ -689,6 +709,7 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/templates/wizards/qtquick2-extension/wizard.xml
%%DATADIR%%/themes/dark.creatortheme
%%DATADIR%%/themes/default.creatortheme
+%%DATADIR%%/themes/flat.creatortheme
%%DATADIR%%/translations/qtcreator_cs.qm
%%DATADIR%%/translations/qtcreator_de.qm
%%DATADIR%%/translations/qtcreator_fr.qm
@@ -714,20 +735,15 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/welcomescreen/widgets/Button.qml
%%DATADIR%%/welcomescreen/widgets/ComboBox.qml
%%DATADIR%%/welcomescreen/widgets/CustomFonts.qml
-%%DATADIR%%/welcomescreen/widgets/CustomTab.qml
%%DATADIR%%/welcomescreen/widgets/CustomizedGridView.qml
%%DATADIR%%/welcomescreen/widgets/Delegate.qml
%%DATADIR%%/welcomescreen/widgets/IconAndLink.qml
-%%DATADIR%%/welcomescreen/widgets/LeftSideBar.qml
-%%DATADIR%%/welcomescreen/widgets/LinkedText.qml
-%%DATADIR%%/welcomescreen/widgets/LinksBar.qml
-%%DATADIR%%/welcomescreen/widgets/Logo.qml
%%DATADIR%%/welcomescreen/widgets/NativeText.qml
-%%DATADIR%%/welcomescreen/widgets/PageCaption.qml
%%DATADIR%%/welcomescreen/widgets/PageLoader.qml
%%DATADIR%%/welcomescreen/widgets/ProjectItem.qml
%%DATADIR%%/welcomescreen/widgets/RecentProjects.qml
%%DATADIR%%/welcomescreen/widgets/SearchBar.qml
+%%DATADIR%%/welcomescreen/widgets/SessionActionLabel.qml
%%DATADIR%%/welcomescreen/widgets/SessionItem.qml
%%DATADIR%%/welcomescreen/widgets/Sessions.qml
%%DATADIR%%/welcomescreen/widgets/SideBar.qml
@@ -739,40 +755,20 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/welcomescreen/widgets/dummydata/mockupTags.qml
%%DATADIR%%/welcomescreen/widgets/dummydata/pagesModel.qml
%%DATADIR%%/welcomescreen/widgets/dummydata/tabsModel.qml
-%%DATADIR%%/welcomescreen/widgets/images/arrowBig.png
-%%DATADIR%%/welcomescreen/widgets/images/arrow_down.png
-%%DATADIR%%/welcomescreen/widgets/images/arrow_down@2x.png
-%%DATADIR%%/welcomescreen/widgets/images/arrow_up.png
-%%DATADIR%%/welcomescreen/widgets/images/arrow_up@2x.png
-%%DATADIR%%/welcomescreen/widgets/images/background.png
-%%DATADIR%%/welcomescreen/widgets/images/bullet.png
%%DATADIR%%/welcomescreen/widgets/images/dropshadow.png
%%DATADIR%%/welcomescreen/widgets/images/icons/adressbook.png
%%DATADIR%%/welcomescreen/widgets/images/icons/androidapp.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/blogs.png
%%DATADIR%%/welcomescreen/widgets/images/icons/buildrun.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/clone.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/clone@2x.png
%%DATADIR%%/welcomescreen/widgets/images/icons/components.png
%%DATADIR%%/welcomescreen/widgets/images/icons/ddays13.png
%%DATADIR%%/welcomescreen/widgets/images/icons/ddays14.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/delete.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/delete@2x.png
%%DATADIR%%/welcomescreen/widgets/images/icons/developing_with_qt_creator.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/onlineCommunity.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/qt_account.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/qt_cloud.png
%%DATADIR%%/welcomescreen/widgets/images/icons/qt_sdk.png
%%DATADIR%%/welcomescreen/widgets/images/icons/qtquick.png
%%DATADIR%%/welcomescreen/widgets/images/icons/qwidget.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/rename.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/rename@2x.png
%%DATADIR%%/welcomescreen/widgets/images/icons/tutorialicon.png
-%%DATADIR%%/welcomescreen/widgets/images/icons/userGuide.png
%%DATADIR%%/welcomescreen/widgets/images/icons/videoIcon.png
%%DATADIR%%/welcomescreen/widgets/images/icons/worldsummit15.png
-%%DATADIR%%/welcomescreen/widgets/images/info.png
-%%DATADIR%%/welcomescreen/widgets/images/info@2x.png
%%DATADIR%%/welcomescreen/widgets/images/mockup/designer-examples.png
%%DATADIR%%/welcomescreen/widgets/images/mockup/desktop-examples.png
%%DATADIR%%/welcomescreen/widgets/images/mockup/draganddrop-examples.png
@@ -784,12 +780,4 @@ share/icons/hicolor/64x64/apps/QtProject-qtcreator.png
%%DATADIR%%/welcomescreen/widgets/images/mockup/penguin.png
%%DATADIR%%/welcomescreen/widgets/images/mockup/qtscript-examples.png
%%DATADIR%%/welcomescreen/widgets/images/mockup/thread-examples.png
-%%DATADIR%%/welcomescreen/widgets/images/more.png
-%%DATADIR%%/welcomescreen/widgets/images/new.png
-%%DATADIR%%/welcomescreen/widgets/images/open.png
-%%DATADIR%%/welcomescreen/widgets/images/project.png
-%%DATADIR%%/welcomescreen/widgets/images/project@2x.png
-%%DATADIR%%/welcomescreen/widgets/images/qtcreator.png
-%%DATADIR%%/welcomescreen/widgets/images/sessions.png
-%%DATADIR%%/welcomescreen/widgets/images/tab.png
%%DATADIR%%/welcomescreen/widgets/qmldir