aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-01 05:07:47 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-01 05:07:47 +0800
commitb130364cadb35f62d04a8ae5b6729d23c8494695 (patch)
tree6b434b4c4277be3e0e4424308d9399a88e59e5f9 /devel
parente0273458c1c5729983a3812808a3ea22c6c80063 (diff)
downloadfreebsd-ports-gnome-b130364cadb35f62d04a8ae5b6729d23c8494695.tar.gz
freebsd-ports-gnome-b130364cadb35f62d04a8ae5b6729d23c8494695.tar.zst
freebsd-ports-gnome-b130364cadb35f62d04a8ae5b6729d23c8494695.zip
- Fix shebang
- Merge post-install: to do-install: - Rename patch file - Support STAGEDIR
Diffstat (limited to 'devel')
-rw-r--r--devel/tmake/Makefile13
-rw-r--r--devel/tmake/files/patch-lib-unix-generic.t (renamed from devel/tmake/files/patch-aa)0
2 files changed, 6 insertions, 7 deletions
diff --git a/devel/tmake/Makefile b/devel/tmake/Makefile
index 333dc9cfecf6..bdb264355ebb 100644
--- a/devel/tmake/Makefile
+++ b/devel/tmake/Makefile
@@ -12,9 +12,10 @@ COMMENT= Extremely portable perl-based make utility
NO_BUILD= yes
REINPLACE_ARGS= -i ''
-USES= perl5
+USES= perl5 shebangfix
+
+SHEBANG_FILES= bin/progen bin/tmake
-NO_STAGE= yes
post-patch:
@${RM} -f ${WRKSRC}/bin/tmake.orig ${WRKSRC}/lib/unix/generic.t.orig
@${REINPLACE_CMD} \
@@ -24,11 +25,9 @@ post-patch:
${WRKSRC}/lib/freebsd-g++/tmake.conf
do-install:
- ${MKDIR} ${DATADIR}/
- cd ${WRKSRC}/lib/ && ${COPYTREE_SHARE} . ${DATADIR}/
- cd ${WRKSRC}/bin/ && ${INSTALL_SCRIPT} progen tmake ${PREFIX}/bin/
-
-post-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ cd ${WRKSRC}/bin/ && ${INSTALL_SCRIPT} progen tmake ${STAGEDIR}${PREFIX}/bin/
+ cd ${WRKSRC}/lib/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/
@${ECHO_MSG}
@${ECHO_MSG} "Make sure to set your TMAKEPATH environment variable"
@${ECHO_MSG} "to ${DATADIR}/freebsd-g++."
diff --git a/devel/tmake/files/patch-aa b/devel/tmake/files/patch-lib-unix-generic.t
index 84425603dd5d..84425603dd5d 100644
--- a/devel/tmake/files/patch-aa
+++ b/devel/tmake/files/patch-lib-unix-generic.t