aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2009-08-07 17:50:41 +0800
committerkuriyama <kuriyama@FreeBSD.org>2009-08-07 17:50:41 +0800
commitba042abcdece3a0317307f7d3b71ab7057e33e72 (patch)
tree86d221fe985b52545bcff680a048bee6dc2cb90a /devel
parenta9cc30f2eaf50b2a8e84e696b89d89ac659232e7 (diff)
downloadfreebsd-ports-gnome-ba042abcdece3a0317307f7d3b71ab7057e33e72.tar.gz
freebsd-ports-gnome-ba042abcdece3a0317307f7d3b71ab7057e33e72.tar.zst
freebsd-ports-gnome-ba042abcdece3a0317307f7d3b71ab7057e33e72.zip
This module handles the installing and uninstalling of perl modules,
scripts, man pages, etc... Both install() and uninstall() are specific to the way ExtUtils::MakeMaker handles the installation and deinstallation of perl modules. They are not designed as general purpose tools. WWW: http://search.cpan.org/dist/ExtUtils-Install/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ExtUtils-Install/Makefile23
-rw-r--r--devel/p5-ExtUtils-Install/distinfo3
-rw-r--r--devel/p5-ExtUtils-Install/pkg-descr8
-rw-r--r--devel/p5-ExtUtils-Install/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 572a261983fa..eb42e9524eea 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1368,6 +1368,7 @@
SUBDIR += p5-ExtUtils-Command
SUBDIR += p5-ExtUtils-Constant
SUBDIR += p5-ExtUtils-Depends
+ SUBDIR += p5-ExtUtils-Install
SUBDIR += p5-ExtUtils-MakeMaker
SUBDIR += p5-ExtUtils-MakeMaker-Coverage
SUBDIR += p5-ExtUtils-Manifest
diff --git a/devel/p5-ExtUtils-Install/Makefile b/devel/p5-ExtUtils-Install/Makefile
new file mode 100644
index 000000000000..a3bd5c3b7550
--- /dev/null
+++ b/devel/p5-ExtUtils-Install/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ExtUtils::Install
+# Date created: 07 Aug 2009
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ExtUtils-Install
+PORTVERSION= 1.54
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to install files from here to there
+
+PERL_CONFIGURE= yes
+
+MAN3= ExtUtils::Install.3 \
+ ExtUtils::Installed.3 \
+ ExtUtils::Packlist.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ExtUtils-Install/distinfo b/devel/p5-ExtUtils-Install/distinfo
new file mode 100644
index 000000000000..cd0955e7b800
--- /dev/null
+++ b/devel/p5-ExtUtils-Install/distinfo
@@ -0,0 +1,3 @@
+MD5 (ExtUtils-Install-1.54.tar.gz) = 28d2ab1f23b26f90772d953387f32fe3
+SHA256 (ExtUtils-Install-1.54.tar.gz) = e3e6d19e640c60c8271d6b7cb2adf156778eeaf540a32ab76f72401e098d2fa6
+SIZE (ExtUtils-Install-1.54.tar.gz) = 67337
diff --git a/devel/p5-ExtUtils-Install/pkg-descr b/devel/p5-ExtUtils-Install/pkg-descr
new file mode 100644
index 000000000000..08e987afede0
--- /dev/null
+++ b/devel/p5-ExtUtils-Install/pkg-descr
@@ -0,0 +1,8 @@
+This module handles the installing and uninstalling of perl modules,
+scripts, man pages, etc...
+
+Both install() and uninstall() are specific to the way
+ExtUtils::MakeMaker handles the installation and deinstallation of
+perl modules. They are not designed as general purpose tools.
+
+WWW: http://search.cpan.org/dist/ExtUtils-Install/
diff --git a/devel/p5-ExtUtils-Install/pkg-plist b/devel/p5-ExtUtils-Install/pkg-plist
new file mode 100644
index 000000000000..3155f1fb9bca
--- /dev/null
+++ b/devel/p5-ExtUtils-Install/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Install/.packlist
+%%SITE_PERL%%/ExtUtils/Install.pm
+%%SITE_PERL%%/ExtUtils/Installed.pm
+%%SITE_PERL%%/ExtUtils/Packlist.pm
+@dirrmtry %%SITE_PERL%%/ExtUtils
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils/Install
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ExtUtils