aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
committerlinimon <linimon@FreeBSD.org>2012-10-10 06:12:13 +0800
commitbcc2006e5a05ff46461202f4b3c0a4ac8d86476e (patch)
tree7d9d8595a250c7e5a9a646200945ef2094927620 /devel
parent27befbedb683f9336783ae19591c9b2f5037500d (diff)
downloadfreebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.gz
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.tar.zst
freebsd-ports-gnome-bcc2006e5a05ff46461202f4b3c0a4ac8d86476e.zip
Force numerous ports that fail to build with clang over to instead always
rely on gcc. The patch uses the new USE_GCC=any code in Mk/bsd.gcc.mk to accomplish this. The ports chosen were ports that blocked 2 or more ports from building with clang. (There are several hundred other ports that still fail to build with clang, even with this patch. This is merely one step along the way.) Those interested in fixing these ports with clang, and have clang as their default compiler, can simply set FORCE_BASE_CC_FOR_TESTING=yes. For those who have gcc as their default compiler, this change is believed to cause no change. Hat: portmgr Tested with: multiple runs on amd64-8-exp-bcm and 9-exp-clang, with various combinations of patch/no-patch and flag settings.
Diffstat (limited to 'devel')
-rw-r--r--devel/allegro/Makefile1
-rw-r--r--devel/argp-standalone/Makefile1
-rw-r--r--devel/avr-binutils/Makefile1
-rw-r--r--devel/bullet/Makefile1
-rw-r--r--devel/gdb66/Makefile1
-rw-r--r--devel/libYGP/Makefile1
-rw-r--r--devel/libhid/Makefile1
-rw-r--r--devel/liboil/Makefile1
-rw-r--r--devel/libopensync/Makefile1
-rw-r--r--devel/mingw32-binutils/Makefile1
-rw-r--r--devel/ncurses/Makefile1
-rw-r--r--devel/omniORB/Makefile1
-rw-r--r--devel/p5-EV/Makefile1
-rw-r--r--devel/psptoolchain-binutils/Makefile1
-rw-r--r--devel/py-game/Makefile1
-rw-r--r--devel/simgear/Makefile1
-rw-r--r--devel/skalibs/Makefile2
-rw-r--r--devel/xmltooling/Makefile1
18 files changed, 19 insertions, 0 deletions
diff --git a/devel/allegro/Makefile b/devel/allegro/Makefile
index b48d5cdcd171..186028879cff 100644
--- a/devel/allegro/Makefile
+++ b/devel/allegro/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A cross-platform library for games and multimedia programming
USE_AUTOTOOLS= autoconf
+USE_GCC= any
USE_GMAKE= yes
USE_XORG= x11 xpm xext xcursor xxf86vm xxf86dga
USE_LDCONFIG= yes
diff --git a/devel/argp-standalone/Makefile b/devel/argp-standalone/Makefile
index 8ae7cfffc609..f4ab3b0e590a 100644
--- a/devel/argp-standalone/Makefile
+++ b/devel/argp-standalone/Makefile
@@ -16,6 +16,7 @@ MASTER_SITE_SUBDIR= sem
MAINTAINER= sem@FreeBSD.org
COMMENT= Standalone version of arguments parsing functions from GLIBC
+USE_GCC= any
GNU_CONFIGURE= yes
USE_AUTOTOOLS= aclocal autoconf automake libtool
AUTOMAKE_ARGS= -c -a
diff --git a/devel/avr-binutils/Makefile b/devel/avr-binutils/Makefile
index 008a58d01ac6..6aeffe86b956 100644
--- a/devel/avr-binutils/Makefile
+++ b/devel/avr-binutils/Makefile
@@ -19,6 +19,7 @@ COMMENT= GNU binutils for Atmel AVR 8-bit RISC cross-development
WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
USE_GETTEXT= yes
CONFIGURE_ARGS= --target=avr
diff --git a/devel/bullet/Makefile b/devel/bullet/Makefile
index 2b2589e813db..4552e2cfc2ad 100644
--- a/devel/bullet/Makefile
+++ b/devel/bullet/Makefile
@@ -17,6 +17,7 @@ COMMENT= 3D collision detection and rigid body dynamics library
USE_GL= gl glu glut
USE_XORG= x11
+USE_GCC= any
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 691e67ffc4db..6fd252b355ea 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,6 +27,7 @@ OPTIONS= INSIGHT "Build the Tcl/Tk GUI (experimental!)" off
CONFLICTS?= gdb-[7-9]*
MAKE_JOBS_SAFE= yes
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
USE_GETTEXT= yes
USE_ICONV= yes
diff --git a/devel/libYGP/Makefile b/devel/libYGP/Makefile
index 14dd28b12b2b..4244aa7751e9 100644
--- a/devel/libYGP/Makefile
+++ b/devel/libYGP/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
boost_filesystem:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
+USE_GCC= any
GNU_CONFIGURE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
diff --git a/devel/libhid/Makefile b/devel/libhid/Makefile
index 91c0d033888f..232632d937df 100644
--- a/devel/libhid/Makefile
+++ b/devel/libhid/Makefile
@@ -16,6 +16,7 @@ COMMENT= A user-space HID access library written in C
MAN1= libhid-detach-device.1
MANCOMPRESSED= no
+USE_GCC= any
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_PYTHON= yes
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index ddecd7ea7dd2..f9e4035975b8 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -17,6 +17,7 @@ COMMENT= Library of optimized inner loops
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
+USE_GCC= any
USE_GNOME= pkgconfig gnomehack ltverhack
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
index 3d205fcb84c3..8fa1740ee1ab 100644
--- a/devel/libopensync/Makefile
+++ b/devel/libopensync/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
CONFLICTS= libopensync-0.22*
USE_BZIP2= yes
+USE_GCC= any
USE_CMAKE= yes
CMAKE_ARGS+= -Wno-dev
USE_GNOME= glib20 libxml2
diff --git a/devel/mingw32-binutils/Makefile b/devel/mingw32-binutils/Makefile
index 43bb0f44cb85..01d1bdb30a05 100644
--- a/devel/mingw32-binutils/Makefile
+++ b/devel/mingw32-binutils/Makefile
@@ -21,6 +21,7 @@ COMMENT= GNU Binutils for Windows cross-development
BINUTILVERSION= 2.22
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=${PKGNAMEPREFIX:S/-$//} \
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index 99dfda554f05..bb0aac2ab2e6 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -37,6 +37,7 @@ OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
CONFIGURE_ENV= gnat_exists="no"
+USE_GCC= any
USE_LDCONFIG= yes
WIDEC_WRKSRC= ${WRKSRC}/build.widec
diff --git a/devel/omniORB/Makefile b/devel/omniORB/Makefile
index 360caa0e959f..decd49e8caa9 100644
--- a/devel/omniORB/Makefile
+++ b/devel/omniORB/Makefile
@@ -13,6 +13,7 @@ MAINTAINER= sem@FreeBSD.org
COMMENT= A robust high performance CORBA ORB for C++ and Python
PLIST_SUB+= SONUM=${PORTVERSION:C/.*\.//}
+USE_GCC= any
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/devel/p5-EV/Makefile b/devel/p5-EV/Makefile
index a898f076bde3..da2ced970f5e 100644
--- a/devel/p5-EV/Makefile
+++ b/devel/p5-EV/Makefile
@@ -19,6 +19,7 @@ COMMENT= Perl interface to libev, a high performance full-featured event loop
RUN_DEPENDS= p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
BUILD_DEPENDS= p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
+USE_GCC= any
PERL_CONFIGURE= yes
CONFIGURE_ENV= PERL_MM_USE_DEFAULT="YES"
diff --git a/devel/psptoolchain-binutils/Makefile b/devel/psptoolchain-binutils/Makefile
index 12be2a6aa07b..166a1e0a605e 100644
--- a/devel/psptoolchain-binutils/Makefile
+++ b/devel/psptoolchain-binutils/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= tphilipp@potion-studios.com
COMMENT= PlayStation Portable development toolchain ${PORTNAME}
USE_BZIP2= yes
+USE_GCC= any
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
diff --git a/devel/py-game/Makefile b/devel/py-game/Makefile
index c0029690838c..e3ca44b278e8 100644
--- a/devel/py-game/Makefile
+++ b/devel/py-game/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= smpeg:${PORTSDIR}/multimedia/smpeg
RUN_DEPENDS= ${PYNUMPY}
USE_SDL= ttf image mixer sdl
+USE_GCC= any
USE_PYTHON= yes
USE_PYDISTUTILS=yes
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index ceddb51a09d5..73a3c66160b9 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
osg:${PORTSDIR}/graphics/osg
USE_BZIP2= yes
+USE_GCC= any
USE_XORG= ice sm x11 xext xi xt xmu
USE_OPENAL= al alut
USE_GL= gl glu glut
diff --git a/devel/skalibs/Makefile b/devel/skalibs/Makefile
index f226a6fd473b..46e1cacec11c 100644
--- a/devel/skalibs/Makefile
+++ b/devel/skalibs/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://www.skarnet.org/software/${PORTNAME}/
MAINTAINER= dhn@FreeBSD.org
COMMENT= General purpose C libraries used by skarnet.org software
+USE_GCC= any
+
LDFLAGS?= -s
STRIPFLAGS?= -x
diff --git a/devel/xmltooling/Makefile b/devel/xmltooling/Makefile
index 0da8517c678d..3c3bde1121c7 100644
--- a/devel/xmltooling/Makefile
+++ b/devel/xmltooling/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-log4shib=${LOCALBASE} --with-openssl=${OPENSSLBASE} --with-curl=${LOCALBASE} --disable-doxygen-doc
+USE_GCC= any
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes