aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-12-20 01:18:57 +0800
committerperky <perky@FreeBSD.org>2004-12-20 01:18:57 +0800
commitc6b3db5327c23f305cf59c695e0ba84f52f809e1 (patch)
tree3186a9cc8c17757d7eb155f2ab05b696bcc5a009 /devel
parent32a6c2b4d38ac3e6c6ee58f15e48f96e756f868c (diff)
downloadfreebsd-ports-gnome-c6b3db5327c23f305cf59c695e0ba84f52f809e1.tar.gz
freebsd-ports-gnome-c6b3db5327c23f305cf59c695e0ba84f52f809e1.tar.zst
freebsd-ports-gnome-c6b3db5327c23f305cf59c695e0ba84f52f809e1.zip
- Add missing two constants, MNT_NOWAIT and MNT_WAIT for statfs().
- Bump PORTREVISION. Submitted by: Rui Lopes <rui@ruilopes.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/py-freebsd/Makefile3
-rw-r--r--devel/py-freebsd/files/patch-src::statfs.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/devel/py-freebsd/Makefile b/devel/py-freebsd/Makefile
index dd65b9e001fb..a6d8ea5c3a2f 100644
--- a/devel/py-freebsd/Makefile
+++ b/devel/py-freebsd/Makefile
@@ -1,12 +1,13 @@
# Ports collection makefile for: py-freebsd
# Date created: 14 June 2002
-# Whom: Hye-Shik Chang <perky@fallin.lv>
+# Whom: Hye-Shik Chang
#
# $FreeBSD$
#
PORTNAME= freebsd
PORTVERSION= 0.2
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= perky
diff --git a/devel/py-freebsd/files/patch-src::statfs.c b/devel/py-freebsd/files/patch-src::statfs.c
new file mode 100644
index 000000000000..de8a9b6dee69
--- /dev/null
+++ b/devel/py-freebsd/files/patch-src::statfs.c
@@ -0,0 +1,11 @@
+--- src/statfs.c.orig Sat Dec 11 07:04:56 2004
++++ src/statfs.c Sat Dec 11 07:05:34 2004
+@@ -30,6 +30,8 @@
+ CONST_INT (MNT_DEFEXPORTED)
+ CONST_INT (MNT_EXPORTANON)
+ CONST_INT (MNT_EXKERB)
++CONST_INT (MNT_WAIT)
++CONST_INT (MNT_NOWAIT)
+
+
+ /*