aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-06-14 06:36:29 +0800
committermiwi <miwi@FreeBSD.org>2009-06-14 06:36:29 +0800
commitd8b81b584e51f10147a0700d6d14b05ee0b2ae56 (patch)
tree7a97385a82d8d8f7155768d0dbc6590791773620 /devel
parent8b368ee78d5e15d7a8ea1caa33db1bd24e413558 (diff)
downloadfreebsd-ports-gnome-d8b81b584e51f10147a0700d6d14b05ee0b2ae56.tar.gz
freebsd-ports-gnome-d8b81b584e51f10147a0700d6d14b05ee0b2ae56.tar.zst
freebsd-ports-gnome-d8b81b584e51f10147a0700d6d14b05ee0b2ae56.zip
p5-SUPER is a perl module provides three different ways
to control superclass method dispatch. WWW: http://search.cpan.org/dist/SUPER/ PR: ports/135499 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SUPER/Makefile25
-rw-r--r--devel/p5-SUPER/distinfo3
-rw-r--r--devel/p5-SUPER/pkg-descr4
-rw-r--r--devel/p5-SUPER/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dbadc3c16382..275b6c6031e4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1756,6 +1756,7 @@
SUBDIR += p5-SOAP-WSDL
SUBDIR += p5-SPOPS
SUBDIR += p5-SSN-Validate
+ SUBDIR += p5-SUPER
SUBDIR += p5-SVN-ACL
SUBDIR += p5-SVN-Access
SUBDIR += p5-SVN-Agent
diff --git a/devel/p5-SUPER/Makefile b/devel/p5-SUPER/Makefile
new file mode 100644
index 000000000000..0741501b1c41
--- /dev/null
+++ b/devel/p5-SUPER/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-SUPER
+# Date created: 12 June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SUPER
+PORTVERSION= 1.16
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl module control superclass method dispatch
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Sub-Identify>=0.04:${PORTSDIR}/devel/p5-Sub-Identify
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SUPER.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-SUPER/distinfo b/devel/p5-SUPER/distinfo
new file mode 100644
index 000000000000..242c22d502ac
--- /dev/null
+++ b/devel/p5-SUPER/distinfo
@@ -0,0 +1,3 @@
+MD5 (SUPER-1.16.tar.gz) = 3a0584598514f471f5df9480e12573c0
+SHA256 (SUPER-1.16.tar.gz) = a66e368694e5a38edf870fd8cd188c827171395ef98775b3bbed621a3feb5dba
+SIZE (SUPER-1.16.tar.gz) = 7749
diff --git a/devel/p5-SUPER/pkg-descr b/devel/p5-SUPER/pkg-descr
new file mode 100644
index 000000000000..c636ec2eba43
--- /dev/null
+++ b/devel/p5-SUPER/pkg-descr
@@ -0,0 +1,4 @@
+p5-SUPER is a perl module provides three different ways
+to control superclass method dispatch.
+
+WWW: http://search.cpan.org/dist/SUPER/
diff --git a/devel/p5-SUPER/pkg-plist b/devel/p5-SUPER/pkg-plist
new file mode 100644
index 000000000000..183f31d05131
--- /dev/null
+++ b/devel/p5-SUPER/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/SUPER.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SUPER/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SUPER