aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2012-10-23 01:36:37 +0800
committerjhale <jhale@FreeBSD.org>2012-10-23 01:36:37 +0800
commitf23eb3914017528493ae6cbc0bb0fad96ed604e4 (patch)
tree2be0bbaec2d37fccbac641d7ba56377627cce61b /devel
parent046490d1f1ec3dc6a01d9ec9866486f07ad7057a (diff)
downloadfreebsd-ports-gnome-f23eb3914017528493ae6cbc0bb0fad96ed604e4.tar.gz
freebsd-ports-gnome-f23eb3914017528493ae6cbc0bb0fad96ed604e4.tar.zst
freebsd-ports-gnome-f23eb3914017528493ae6cbc0bb0fad96ed604e4.zip
- Convert to new options framework
- Generate plist for DOXYGEN option independent of the PORTDOCS macro to avoid problems if NOPORTDOCS is defined - Remove indefinite article from COMMENT - Remove LICENSE_FILE, LGPL21 is in Templates/Licenses - Drop ABI version numbers from LIB_DEPENDS - Trim Makefile header Approved by: makc (mentor) Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/libchipcard/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
index 61824dda70e5..0450a6071c27 100644
--- a/devel/libchipcard/Makefile
+++ b/devel/libchipcard/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: LibChipCard
-# Date created: 19 January 2003
-# Whom: Martin Preuss <martin@libchipcard.de>
-#
+# Created by: Martin Preuss <martin@libchipcard.de>
# $FreeBSD$
-#
PORTNAME= libchipcard
PORTVERSION= 5.0.2
@@ -12,20 +8,20 @@ CATEGORIES= devel
MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=02&release=26&file=01&dummy=/
MAINTAINER= jhale@FreeBSD.org
-COMMENT= A library for easy access to chipcards
+COMMENT= Library for easy access to chipcards
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite \
- gwenhywfar.63:${PORTSDIR}/devel/gwenhywfar
+LIB_DEPENDS= pcsclite:${PORTSDIR}/devel/pcsc-lite \
+ gwenhywfar:${PORTSDIR}/devel/gwenhywfar
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_OPENSSL= yes
-OPTIONS= APIDOC "Full API documentation (requires Doxygen)" off \
- MEMDEBUG "Enable memory debugger statistic" off
+OPTIONS_DEFINE= DOXYGEN MEMDEBUG
+
+MEMDEBUG_DESC= Enable memory debugger statistic
GNU_CONFIGURE= yes
CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}" aq_distrib_name="FreeBSD"
@@ -43,14 +39,13 @@ GWEN_SHLIB_VER= 60
.include <bsd.port.options.mk>
-.if defined(WITH_APIDOC)
+.if ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz
CONFIGURE_ARGS+=--enable-full-doc
-PORTDOCS= apidoc
.endif
-.if defined(WITH_MEMDEBUG)
+.if ${PORT_OPTIONS:MMEMDEBUG}
CONFIGURE_ARGS+=--enable-memtrace
.endif
@@ -61,15 +56,19 @@ post-patch:
${WRKSRC}/Makefile.in
post-build:
-.if defined(WITH_APIDOC)
+.if ${PORT_OPTIONS:MDOXYGEN}
@cd ${WRKSRC} && ${GMAKE} srcdoc
.endif
post-install:
-.if defined(WITH_APIDOC)
+.if ${PORT_OPTIONS:MDOXYGEN}
${MKDIR} ${DOCSDIR}/apidoc
cd ${WRKSRC}/apidoc && \
${COPYTREE_SHARE} \* ${DOCSDIR}/apidoc
+ @${FIND} -P ${DOCSDIR} -type f 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ @${FIND} -P -d ${DOCSDIR} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
.endif
.include <bsd.port.mk>