aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-04-30 04:52:08 +0800
committerkrion <krion@FreeBSD.org>2004-04-30 04:52:08 +0800
commitf3f75f7e7fb4392f82c6f5be7fc0e859f239b7e6 (patch)
tree8736665520dfd62fa455890962540f8a33bf6870 /devel
parent828e5013f4f06c37cf6b19223605f55ab167c0d5 (diff)
downloadfreebsd-ports-gnome-f3f75f7e7fb4392f82c6f5be7fc0e859f239b7e6.tar.gz
freebsd-ports-gnome-f3f75f7e7fb4392f82c6f5be7fc0e859f239b7e6.tar.zst
freebsd-ports-gnome-f3f75f7e7fb4392f82c6f5be7fc0e859f239b7e6.zip
- Update to 0.2.0
PR: ports/66093 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/libopendaap/Makefile13
-rw-r--r--devel/libopendaap/distinfo4
-rw-r--r--devel/libopendaap/files/patch-ltmain.sh26
-rw-r--r--devel/libopendaap/pkg-plist2
4 files changed, 36 insertions, 9 deletions
diff --git a/devel/libopendaap/Makefile b/devel/libopendaap/Makefile
index 770527c00249..8c98f422336c 100644
--- a/devel/libopendaap/Makefile
+++ b/devel/libopendaap/Makefile
@@ -6,29 +6,30 @@
#
PORTNAME= libopendaap
-PORTVERSION= 0.1.3
+PORTVERSION= 0.2.0
CATEGORIES= devel net
MASTER_SITES= http://crazney.net/programs/itunes/files/
MAINTAINER= ahze@ahze.net
COMMENT= C lib used to connect to iTunes(R) music shares
+SHLIB_VER= 1
USE_BZIP2= yes
USE_REINPLACE= yes
-USE_GNOME= gnomehack pkgconfig lthack
-USE_LIBTOOL_VER=13
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_LIBTOOL_VER=15
USE_GCC= 3.3
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}"
INSTALLS_SHLIB= yes
-pre-everything::
- @${ECHO_MSG} "This version does NOT work with iTunes 4.5"
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/Makefile.am \
${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|%%SHLIB_VER%%|.${SHLIB_VER}|' \
+ ${WRKSRC}/ltmain.sh
.include <bsd.port.mk>
diff --git a/devel/libopendaap/distinfo b/devel/libopendaap/distinfo
index 0159c9f74bee..360ca8cf6576 100644
--- a/devel/libopendaap/distinfo
+++ b/devel/libopendaap/distinfo
@@ -1,2 +1,2 @@
-MD5 (libopendaap-0.1.3.tar.bz2) = 72bdf1e6ef9ed0150923bd2f1debf4eb
-SIZE (libopendaap-0.1.3.tar.bz2) = 337980
+MD5 (libopendaap-0.2.0.tar.bz2) = 7d5085ae1f7173760b69dbbfe6112b02
+SIZE (libopendaap-0.2.0.tar.bz2) = 338569
diff --git a/devel/libopendaap/files/patch-ltmain.sh b/devel/libopendaap/files/patch-ltmain.sh
new file mode 100644
index 000000000000..3824af448152
--- /dev/null
+++ b/devel/libopendaap/files/patch-ltmain.sh
@@ -0,0 +1,26 @@
+--- ltmain.sh.orig Tue Apr 13 09:05:11 2004
++++ ltmain.sh Thu Apr 29 22:49:03 2004
+@@ -2980,8 +2980,8 @@
+ ;;
+
+ freebsd-elf)
+- major=".$current"
+- versuffix=".$current";
++ major=".1"
++ versuffix=".1";
+ ;;
+
+ irix | nonstopux)
+@@ -5528,10 +5528,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libopendaap/pkg-plist b/devel/libopendaap/pkg-plist
index 56f2d07cd212..399b97358a29 100644
--- a/devel/libopendaap/pkg-plist
+++ b/devel/libopendaap/pkg-plist
@@ -1,6 +1,6 @@
include/daap/client.h
lib/libopendaap.a
lib/libopendaap.so
-lib/libopendaap.so.0
+lib/libopendaap.so.%%SHLIB_VER%%
libdata/pkgconfig/opendaap.pc
@dirrm include/daap