aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind8/Makefile
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2002-07-12 17:25:47 +0800
committerdougb <dougb@FreeBSD.org>2002-07-12 17:25:47 +0800
commit68fc9b30a7f3960c64ea0b349b893376284857c1 (patch)
treee6ee16733fd0b2816b162f605e887aa721b6a4c8 /dns/bind8/Makefile
parent94dc696595892c69d736bb214ad74287c1560040 (diff)
downloadfreebsd-ports-gnome-68fc9b30a7f3960c64ea0b349b893376284857c1.tar.gz
freebsd-ports-gnome-68fc9b30a7f3960c64ea0b349b893376284857c1.tar.zst
freebsd-ports-gnome-68fc9b30a7f3960c64ea0b349b893376284857c1.zip
* Further improve the lot of those who use this port to replace the
base BIND by correcting the path to named.conf in the man pages, and adding -base as a PKGNAMESUFFIX to make things really obvious. * Remove man page install from under NOPORTDOCS. Thanks to mi@ for this one. * Finally beat the CFLAGS issue into submission in a manner that's not terribly elegant, but does survive the "creative" sub-make architecture that they use to build stuff. This method will (hopefully) have the pleasant side effect of not forcing patch-aa to be regenerated quite so often.
Diffstat (limited to 'dns/bind8/Makefile')
-rw-r--r--dns/bind8/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/dns/bind8/Makefile b/dns/bind8/Makefile
index 3221c410c700..8ca3dfb78ff2 100644
--- a/dns/bind8/Makefile
+++ b/dns/bind8/Makefile
@@ -24,7 +24,11 @@ DIST_SUBDIR= bind-${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
.if defined(PORT_REPLACES_BASE_BIND8)
+PKGNAMESUFFIX= -base
PREFIX= /usr
+BIND_DESTETC= /etc/namedb
+.else
+BIND_DESTETC= ${PREFIX}/etc
.endif
WRKSRC= ${WRKDIR}/src
@@ -42,18 +46,22 @@ PATCH_ARGS= -s -d ${WRKDIR}
PATCH_DIST_ARGS= -s -d ${WRKDIR}
post-patch:
-.if defined(PORT_REPLACES_BASE_BIND8)
- @${SED} -e "s#\'DESTETC=.*#'DESTETC=/etc/namedb'#" \
+ @${SED} -e "s#\'DESTETC=.*#'DESTETC=${BIND_DESTETC}'#" \
+ -e "s#-O2 -g#${CFLAGS}#" \
${WRKSRC}/port/freebsd/Makefile.set > \
${WRKSRC}/port/freebsd/Makefile.set.sed
@${MV} ${WRKSRC}/port/freebsd/Makefile.set.sed \
${WRKSRC}/port/freebsd/Makefile.set
-.endif
+.for file in named.conf.5 named.8
+ @${SED} -e "s#/etc/named.conf#${BIND_DESTETC}/named.conf#g" \
+ ${WRKDIR}/doc/man/${file} > ${WRKDIR}/doc/man/${file}.sed
+ @${MV} ${WRKDIR}/doc/man/${file}.sed ${WRKDIR}/doc/man/${file}
+.endfor
post-install:
+ cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} clean all ${INSTALL_TARGET}
.if !defined(NOPORTDOCS)
- @(cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
- ${MAKEFILE} clean all ${INSTALL_TARGET})
@${MKDIR} ${PREFIX}/share/doc/bind8/html
${INSTALL_DATA} ${WRKDIR}/doc/html/*.html ${PREFIX}/share/doc/bind8/html
${CP} -Rp ${WRKDIR}/src/conf ${PREFIX}/share/doc/bind8/