aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind8/Makefile
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2003-06-07 19:28:51 +0800
committerdougb <dougb@FreeBSD.org>2003-06-07 19:28:51 +0800
commitf7c1ad0d27a6362d3a63f5d704b0a1df6e5e494f (patch)
tree6c16759916a88fd0acd45cb2d30d19fcba48cd74 /dns/bind8/Makefile
parent7d8db8acd56a80885582c351cf76a152d3c32ad7 (diff)
downloadfreebsd-ports-gnome-f7c1ad0d27a6362d3a63f5d704b0a1df6e5e494f.tar.gz
freebsd-ports-gnome-f7c1ad0d27a6362d3a63f5d704b0a1df6e5e494f.tar.zst
freebsd-ports-gnome-f7c1ad0d27a6362d3a63f5d704b0a1df6e5e494f.zip
Upgrade to version 8.3.5, the latest from ISC. Several bugfixes are
included, as well as a few minor enhancements. Check CHANGES for details. Improve greatly the PORT_REPLACES_BASE option, which now truly replaces everything, including re-positioning nslookup and nsupdate in sbin, and writing over the includes, instead of installing them in include/bind. Unconditionally install dnskeygen in bin, since that's where the base puts it, and it's only confusing to users if they can't find it after an installation. Install isc/ctl.h by hand in the appropriate include directory, since we install it in the base, and the distribution Makefile does not.
Diffstat (limited to 'dns/bind8/Makefile')
-rw-r--r--dns/bind8/Makefile32
1 files changed, 30 insertions, 2 deletions
diff --git a/dns/bind8/Makefile b/dns/bind8/Makefile
index 4e616d0e67d8..57149418f0ec 100644
--- a/dns/bind8/Makefile
+++ b/dns/bind8/Makefile
@@ -11,7 +11,7 @@
# you can generally build it cleanly from the source. - Doug
PORTNAME= bind
-PORTVERSION= 8.3.4
+PORTVERSION= 8.3.5
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind/src/${PORTVERSION}
@@ -20,14 +20,18 @@ DISTFILES= bind-src.tar.gz bind-doc.tar.gz
DIST_SUBDIR= bind-${PORTVERSION}
MAINTAINER= DougB@FreeBSD.org
-COMMENT= The Berkeley Internet Name Daemon, an implementation of DNS
+COMMENT= The Berkeley Internet Name Domain, an implementation of DNS
.if defined(PORT_REPLACES_BASE_BIND8)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
+INCLUDE_PATH= include
+PLIST_SUB= INCLUDE_PATH=${INCLUDE_PATH} FAKE_SBIN=sbin
.else
BIND_DESTETC= ${PREFIX}/etc
+INCLUDE_PATH= include/bind
+PLIST_SUB= INCLUDE_PATH=${INCLUDE_PATH} FAKE_SBIN=bin
.endif
WRKSRC= ${WRKDIR}/src
@@ -51,6 +55,26 @@ post-patch:
${WRKSRC}/port/freebsd/Makefile.set.sed
@${MV} ${WRKSRC}/port/freebsd/Makefile.set.sed \
${WRKSRC}/port/freebsd/Makefile.set
+
+ @${SED} -e "s#{DESTEXEC}#{DESTBIN}#g" \
+ ${WRKSRC}/bin/dnskeygen/Makefile > \
+ ${WRKSRC}/bin/dnskeygen/Makefile.sed
+ @${MV} ${WRKSRC}/bin/dnskeygen/Makefile.sed \
+ ${WRKSRC}/bin/dnskeygen/Makefile
+
+.if defined(PORT_REPLACES_BASE_BIND8)
+ @${SED} -e "s#\'DESTINC=.*#'DESTINC=${PREFIX}/include'#" \
+ ${WRKSRC}/port/freebsd/Makefile.set > \
+ ${WRKSRC}/port/freebsd/Makefile.set.sed
+ @${MV} ${WRKSRC}/port/freebsd/Makefile.set.sed \
+ ${WRKSRC}/port/freebsd/Makefile.set
+.for dir in nslookup nsupdate
+ @${SED} -e "s#{DESTBIN}#{DESTSBIN}#g" \
+ ${WRKSRC}/bin/${dir}/Makefile > ${WRKSRC}/bin/${dir}/Makefile.sed
+ @${MV} ${WRKSRC}/bin/${dir}/Makefile.sed ${WRKSRC}/bin/${dir}/Makefile
+.endfor
+.endif
+
.for file in named.conf.5 named.8
@${SED} -e "s#/etc/named.conf#${BIND_DESTETC}/named.conf#g" \
${WRKDIR}/doc/man/${file} > ${WRKDIR}/doc/man/${file}.sed
@@ -60,6 +84,10 @@ post-patch:
post-install:
cd ${WRKDIR}/doc/man && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
${MAKEFILE} clean all ${INSTALL_TARGET}
+
+ ${INSTALL_DATA} ${WRKSRC}/include/isc/ctl.h \
+ ${PREFIX}/${INCLUDE_PATH}/isc
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/html ${DOCSDIR}/misc
${INSTALL_DATA} ${WRKDIR}/doc/html/*.html ${DOCSDIR}/html