aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind9-devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-09-04 22:29:55 +0800
committermat <mat@FreeBSD.org>2017-09-04 22:29:55 +0800
commit66e5b17903d352472c1c0520d549ed9d2c1c0db8 (patch)
treed04c7ee16dc2c1b9c01eb5c2c131f75ae6da6828 /dns/bind9-devel
parentff3ed7121bd5e476c73778c8220147b0474870a8 (diff)
downloadfreebsd-ports-gnome-66e5b17903d352472c1c0520d549ed9d2c1c0db8.tar.gz
freebsd-ports-gnome-66e5b17903d352472c1c0520d549ed9d2c1c0db8.tar.zst
freebsd-ports-gnome-66e5b17903d352472c1c0520d549ed9d2c1c0db8.zip
Update to latest commit.
Sponsored by: Absolight
Diffstat (limited to 'dns/bind9-devel')
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl40
3 files changed, 28 insertions, 22 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index f9e6d60f082e..ed66c61c0f23 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -31,8 +31,8 @@ LICENSE= MPL
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0a.2017.08.26
-HASH= 503223b
+ISCVERSION= 9.12.0a.2017.09.04
+HASH= 1007623
USES= cpe libedit
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 4708324d2696..d396065b9eed 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1503923142
-SHA256 (bind9-503223b.tar.gz) = ba4bc8ac9afa73cc6f0ae29066b929ff034fd555ebb4da23239a47dbc0812090
-SIZE (bind9-503223b.tar.gz) = 11901720
+TIMESTAMP = 1504530859
+SHA256 (bind9-1007623.tar.gz) = 8bd1cbde1ae534398eae50c6e1199215c608fabea328e64e91025a59d2ebeb2d
+SIZE (bind9-1007623.tar.gz) = 11908264
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 815421f454a6..9197458abe57 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,15 +1,21 @@
---- bin/named/config.c.orig 2017-08-21 08:20:10 UTC
+--- bin/named/config.c.orig 2017-09-04 08:22:52 UTC
+++ bin/named/config.c
-@@ -156,6 +156,8 @@ options {\n\
- lame-ttl 600;\n\
- servfail-ttl 1;\n\
- max-ncache-ttl 10800; /* 3 hours */\n\
-+ override-cache-ttl 0; /* do not override */\n\
-+ min-cache-ttl 0; /* no minimal, zero is allowed */\n\
- max-cache-ttl 604800; /* 1 week */\n\
- transfer-format many-answers;\n\
- max-cache-size 90%;\n\
---- bin/named/server.c.orig 2017-08-21 08:20:10 UTC
+@@ -176,12 +176,14 @@ options {\n\
+ max-recursion-depth 7;\n\
+ max-recursion-queries 75;\n\
+ message-compression yes;\n\
++ min-cache-ttl 0; /* no minimal, zero is allowed */\n\
+ # min-roots <obsolete>;\n\
+ minimal-any false;\n\
+ minimal-responses true;\n\
+ notify-source *;\n\
+ notify-source-v6 *;\n\
+ nsec3-test-zone no;\n\
++ override-cache-ttl 0; /* do not override */\n\
+ provide-ixfr true;\n\
+ query-source address *;\n\
+ query-source-v6 address *;\n\
+--- bin/named/server.c.orig 2017-09-04 08:22:52 UTC
+++ bin/named/server.c
@@ -3722,6 +3722,16 @@ configure_view(dns_view_t *view, dns_vie
}
@@ -28,9 +34,9 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2017-08-21 08:20:10 UTC
+--- lib/dns/include/dns/view.h.orig 2017-09-04 08:22:52 UTC
+++ lib/dns/include/dns/view.h
-@@ -144,6 +144,8 @@ struct dns_view {
+@@ -145,6 +145,8 @@ struct dns_view {
isc_boolean_t requestnsid;
isc_boolean_t sendcookie;
dns_ttl_t maxcachettl;
@@ -39,9 +45,9 @@
dns_ttl_t maxncachettl;
isc_uint32_t nta_lifetime;
isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2017-08-21 08:20:10 UTC
+--- lib/dns/resolver.c.orig 2017-09-04 08:22:52 UTC
+++ lib/dns/resolver.c
-@@ -5687,6 +5687,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5723,6 +5723,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -60,9 +66,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2017-08-21 08:20:10 UTC
+--- lib/isccfg/namedconf.c.orig 2017-09-04 08:22:52 UTC
+++ lib/isccfg/namedconf.c
-@@ -1896,6 +1896,8 @@ view_clauses[] = {
+@@ -1894,6 +1894,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
CFG_CLAUSEFLAG_OBSOLETE },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },