aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind910
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-09-16 16:12:05 +0800
committermat <mat@FreeBSD.org>2015-09-16 16:12:05 +0800
commit0fdf37c9da152a83e3f3fbafad84909f358db8e2 (patch)
tree2a52b5baeab9f9a3a253c28edb557d89fb9bcb0f /dns/bind910
parent1f070a59e7935e66460f1f397b982d7fa4f40e9b (diff)
downloadfreebsd-ports-gnome-0fdf37c9da152a83e3f3fbafad84909f358db8e2.tar.gz
freebsd-ports-gnome-0fdf37c9da152a83e3f3fbafad84909f358db8e2.tar.zst
freebsd-ports-gnome-0fdf37c9da152a83e3f3fbafad84909f358db8e2.zip
Update to bind99 to 9.9.8 & bind910 to 9.10.3.
- Add new QUERYTRACE & FETCHLIMIT. Note that QUERYTRACE is for debug purposes, and will eat your performances. - Don't do the PORTREVISION patch if PORTREVISION is 0. - Regen some patches Changes: https://lists.isc.org/pipermail/bind-announce/2015-September/000961.html Changes: https://lists.isc.org/pipermail/bind-announce/2015-September/000962.html Sponsored by: Absolight
Diffstat (limited to 'dns/bind910')
-rw-r--r--dns/bind910/Makefile12
-rw-r--r--dns/bind910/distinfo4
-rw-r--r--dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in6
-rw-r--r--dns/bind910/files/patch-configure6
4 files changed, 17 insertions, 11 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 7b918ead17ee..12963fae332a 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -21,11 +21,11 @@ COMMENT?= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= ISCL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.10.2-P4
+ISCVERSION= 9.10.3
MAKE_JOBS_UNSAFE= yes
-USES= cpe
+USES= cpe libedit
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
@@ -59,7 +59,7 @@ OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFAULT+= RRL
OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS NEWSTATS GEOIP \
- MINCACHE PORTREVISION
+ MINCACHE PORTREVISION FETCHLIMIT QUERYTRACE
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
DLZ_LDAP DLZ_FILESYSTEM DLZ_STUB
@@ -84,6 +84,8 @@ PYTHON_DESC= Build with Python utilities
START_LATE_DESC= Start BIND late in the boot process
MINCACHE_DESC= Use the mincachettl patch
PORTREVISION_DESC= Show PORTREVISION in the version string
+FETCHLIMIT_DESC= Enable the query quotas for resolvers
+QUERYTRACE_DESC= Enable the very verbose query tracelogging
LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
@@ -102,6 +104,8 @@ GSSAPI_HEIMDAL_DESC= Using security/heimdal
GSSAPI_MIT_DESC= Using security/krb5
GSSAPI_NONE_DESC= Disable
MINCACHE_EXTRA_PATCHES= ${FILESDIR}/extrapatch-bind-min-override-ttl
+FETCHLIMIT_CONFIGURE_ENABLE= fetchlimit
+QUERYTRACE_CONFIGURE_ENABLE= querytrace
.if !defined(BIND_TOOLS_SLAVE)
CONFLICTS+= bind-tools-9.*
@@ -227,9 +231,11 @@ post-patch:
${WRKSRC}/bin/${FILE}
.endfor
+.if ${PORTREVISION:N0}
post-patch-PORTREVISION-on:
@${REINPLACE_CMD} -e '/EXTENSIONS/s#=$$#=_${PORTREVISION}#' \
${WRKSRC}/version
+.endif
post-install:
.if ${PORT_OPTIONS:MDOCS}
diff --git a/dns/bind910/distinfo b/dns/bind910/distinfo
index 64dfc411f8d2..68952c1e1291 100644
--- a/dns/bind910/distinfo
+++ b/dns/bind910/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bind-9.10.2-P4.tar.gz) = c00b21ec1def212957f28efe9d10aac52d6ec515e84fbf2c42143f5d71429cb8
-SIZE (bind-9.10.2-P4.tar.gz) = 8471531
+SHA256 (bind-9.10.3.tar.gz) = 9ac33bd8754ab4b6ee449b1b2aa88e09f51cda088486f4ab1585acd920b98ff0
+SIZE (bind-9.10.3.tar.gz) = 8552545
diff --git a/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in b/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in
index a86155aeaf74..a63be7ce0466 100644
--- a/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in
+++ b/dns/bind910/files/patch-bin__tests__system__dlzexternal__Makefile.in
@@ -1,6 +1,6 @@
---- ./bin/tests/system/dlzexternal/Makefile.in.orig 2014-04-08 00:02:19.000000000 +0200
-+++ ./bin/tests/system/dlzexternal/Makefile.in 2014-04-10 15:49:49.000000000 +0200
-@@ -43,7 +43,7 @@
+--- bin/tests/system/dlzexternal/Makefile.in.orig 2015-09-09 02:23:40 UTC
++++ bin/tests/system/dlzexternal/Makefile.in
+@@ -43,7 +43,7 @@ OBJS = ${DLOPENOBJS}
@BIND9_MAKE_RULES@
CFLAGS = @CFLAGS@ @SO_CFLAGS@
diff --git a/dns/bind910/files/patch-configure b/dns/bind910/files/patch-configure
index e4a1689912cf..01e870150ec6 100644
--- a/dns/bind910/files/patch-configure
+++ b/dns/bind910/files/patch-configure
@@ -1,6 +1,6 @@
---- ./configure.orig 2014-05-27 06:45:53.000000000 +0200
-+++ ./configure 2014-06-16 13:05:38.000000000 +0200
-@@ -13899,6 +13899,7 @@
+--- configure.orig 2015-09-09 02:23:40 UTC
++++ configure
+@@ -14105,6 +14105,7 @@ done
"-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lresolv" \
"-lgssapi" \
"-lgssapi -lkrb5 -ldes -lcrypt -lasn1 -lroken -lcom_err" \