aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind910
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-04-18 00:43:48 +0800
committermat <mat@FreeBSD.org>2014-04-18 00:43:48 +0800
commit4a11c1c3e231e6aac1aaa46ba4959a638a5ccdc2 (patch)
tree9006b92c39c42569632b1e84602968418d1a37bb /dns/bind910
parentc6d9e30ed85f8198dffb43a015cb990655e9baf6 (diff)
downloadfreebsd-ports-gnome-4a11c1c3e231e6aac1aaa46ba4959a638a5ccdc2.tar.gz
freebsd-ports-gnome-4a11c1c3e231e6aac1aaa46ba4959a638a5ccdc2.tar.zst
freebsd-ports-gnome-4a11c1c3e231e6aac1aaa46ba4959a638a5ccdc2.zip
Fix the rc script reload command.
Noticed by: David Samms Sponsored by: Absolight
Diffstat (limited to 'dns/bind910')
-rw-r--r--dns/bind910/Makefile2
-rw-r--r--dns/bind910/files/named.in9
2 files changed, 9 insertions, 2 deletions
diff --git a/dns/bind910/Makefile b/dns/bind910/Makefile
index 9e77fc0fe48b..5ec60754ce84 100644
--- a/dns/bind910/Makefile
+++ b/dns/bind910/Makefile
@@ -2,7 +2,7 @@
PORTNAME= bind
PORTVERSION= 9.10.0rc1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
diff --git a/dns/bind910/files/named.in b/dns/bind910/files/named.in
index 7dc9329dcd4b..3207d3005f42 100644
--- a/dns/bind910/files/named.in
+++ b/dns/bind910/files/named.in
@@ -19,7 +19,7 @@ extra_commands=reload
start_precmd=named_prestart
start_postcmd=named_poststart
-reload_cmd="${command%/named}/rndc reload"
+reload_cmd=named_reload
stop_cmd=named_stop
named_enable=${named_enable:-"NO"} # Run named, the DNS server (or NO).
@@ -44,6 +44,13 @@ named_poststart()
fi
}
+named_reload()
+{
+ # This is a one line function, but ${command} is not defined early
+ # enough to be there when the reload_cmd variable is defined up there.
+ ${command%/named}/rndc reload
+}
+
find_pidfile()
{
if get_pidfile_from_conf pid-file $named_conf; then