aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind99
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-01-12 16:15:41 +0800
committermat <mat@FreeBSD.org>2017-01-12 16:15:41 +0800
commit70e2222e8c0c871f4147b1bbf3538ac5fc987a10 (patch)
tree7363d9267e12af1dc54f46b88d157faf61364460 /dns/bind99
parent10206ed408a20bc1e7fc36ef8c8dabbcac5938a3 (diff)
downloadfreebsd-ports-gnome-70e2222e8c0c871f4147b1bbf3538ac5fc987a10.tar.gz
freebsd-ports-gnome-70e2222e8c0c871f4147b1bbf3538ac5fc987a10.tar.zst
freebsd-ports-gnome-70e2222e8c0c871f4147b1bbf3538ac5fc987a10.zip
Commit the cleanups that should have gone in with the pervious update.
Sponsored by: Absolight
Diffstat (limited to 'dns/bind99')
-rw-r--r--dns/bind99/Makefile30
-rw-r--r--dns/bind99/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind99/files/pkg-message.in9
-rw-r--r--dns/bind99/pkg-install32
-rw-r--r--dns/bind99/pkg-plist26
5 files changed, 26 insertions, 85 deletions
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 0dfb8eb40499..de4c1e1cc4bb 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -3,6 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 99
@@ -38,13 +39,13 @@ ETCDIR= ${PREFIX}/etc/namedb
CONFLICTS= bind-tools bind9-devel bind910 bind911
-SUB_FILES= pkg-message
+SUB_FILES= pkg-message named.conf
OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE RRL DLZ_FILESYSTEM \
RPZ_NSIP RPZ_NSDNAME
-OPTIONS_DEFINE= SSL IDN REPLACE_BASE LARGE_FILE FIXED_RRSET SIGCHASE \
+OPTIONS_DEFINE= SSL IDN LARGE_FILE FIXED_RRSET SIGCHASE \
IPV6 THREADS FILTER_AAAA GOST PYTHON START_LATE MINCACHE \
- LINKS RPZ_NSIP RPZ_NSDNAME RRL DOCS RPZ_PATCH NEWSTATS \
+ RPZ_NSIP RPZ_NSDNAME RRL DOCS RPZ_PATCH NEWSTATS \
PORTREVISION FETCHLIMIT QUERYTRACE
OPTIONS_GROUP= DLZ
OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
@@ -55,7 +56,6 @@ OPTIONS_SINGLE_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT GSSAPI_NONE
OPTIONS_SUB= yes
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
-REPLACE_BASE_DESC= EOL, no longer supported
LARGE_FILE_DESC= 64-bit file support
FIXED_RRSET_DESC= Enable fixed rrset ordering
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
@@ -68,7 +68,6 @@ PORTREVISION_DESC= Show PORTREVISION in the version string
FETCHLIMIT_DESC= Enable the query quotas for resolvers
QUERYTRACE_DESC= Enable the very verbose query tracelogging
-LINKS_DESC= Create conf file symlinks in ${PREFIX}
NEWSTATS_DESC= Enable alternate xml statistics channel format
RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
RPZ_NSDNAME_DESC= Enable RPZ NSDNAME policy records
@@ -158,32 +157,13 @@ GSSAPI_NONE_CONFIGURE_ON= --without-gssapi
.include <bsd.port.options.mk>
-.if !${PORT_OPTIONS:MLINKS}
-PKGINSTALL=${NONEXISTENT}
-.endif
-
.if ${PORT_OPTIONS:MTHREADS} && !${PORT_OPTIONS:MDLZ_MYSQL}
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if ${PORT_OPTIONS:MREPLACE_BASE}
-IGNORE= REPLACE_BASE is no longer supported
-.endif # REPLACE_BASE
-
-.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
-PKGINSTALL= ${NONEXISTENT}
-PLIST_SUB+= NOBASE="" BASE="@comment "
-SUB_LIST+= NOBASE="" BASE="@comment "
-USE_RC_SUBR+= named
-SUB_FILES+= named.conf
-.else
-PLIST_SUB+= NOBASE="@comment " BASE=""
-SUB_LIST+= NOBASE="@comment " BASE=""
-.endif
-
-PKGDEINSTALL= ${PKGINSTALL}
+USE_RC_SUBR= named
MAKE_JOBS_UNSAFE= yes
diff --git a/dns/bind99/files/extrapatch-bind-min-override-ttl b/dns/bind99/files/extrapatch-bind-min-override-ttl
index 49055112cff5..afbea8306df5 100644
--- a/dns/bind99/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind99/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2016-10-21 05:12:02 UTC
+--- bin/named/config.c.orig 2016-12-11 22:02:39 UTC
+++ bin/named/config.c
@@ -141,6 +141,8 @@ options {\n\
min-roots 2;\n\
@@ -9,9 +9,9 @@
max-cache-ttl 604800; /* 1 week */\n\
transfer-format many-answers;\n\
max-cache-size 0;\n\
---- bin/named/server.c.orig 2016-10-21 05:12:02 UTC
+--- bin/named/server.c.orig 2017-01-11 11:22:46 UTC
+++ bin/named/server.c
-@@ -2559,6 +2559,16 @@ configure_view(dns_view_t *view, cfg_obj
+@@ -2683,6 +2683,16 @@ configure_view(dns_view_t *view, cfg_obj
}
obj = NULL;
@@ -28,7 +28,7 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2016-10-21 05:12:02 UTC
+--- lib/dns/include/dns/view.h.orig 2017-01-11 11:22:46 UTC
+++ lib/dns/include/dns/view.h
@@ -148,6 +148,8 @@ struct dns_view {
isc_boolean_t provideixfr;
@@ -39,7 +39,7 @@
dns_ttl_t maxncachettl;
in_port_t dstport;
dns_aclenv_t aclenv;
---- lib/dns/resolver.c.orig 2016-10-21 05:12:02 UTC
+--- lib/dns/resolver.c.orig 2016-12-11 22:02:39 UTC
+++ lib/dns/resolver.c
@@ -5116,6 +5116,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
@@ -60,9 +60,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl)
---- lib/isccfg/namedconf.c.orig 2016-10-21 05:12:02 UTC
+--- lib/isccfg/namedconf.c.orig 2017-01-11 11:22:46 UTC
+++ lib/isccfg/namedconf.c
-@@ -1459,6 +1459,8 @@ view_clauses[] = {
+@@ -1464,6 +1464,8 @@ view_clauses[] = {
{ "lame-ttl", &cfg_type_uint32, 0 },
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizenodefault, 0 },
diff --git a/dns/bind99/files/pkg-message.in b/dns/bind99/files/pkg-message.in
index 8a62d5c244a3..eb26dbbe1413 100644
--- a/dns/bind99/files/pkg-message.in
+++ b/dns/bind99/files/pkg-message.in
@@ -10,13 +10,6 @@
* 'rndc-confgen -a' to generate the proper conf file, with a new *
* random key, and appropriate file permissions. *
* *
-%%NOBASE%%* The %%PREFIX%%/etc/rc.d/named script will do that for you. *
-%%BASE%%* The /etc/rc.d/named script in the base will do that for you. *
-%%BASE%%* *
-%%BASE%%* You will need to make sure that you have the following line *
-%%BASE%%* in your /etc/rc.conf in order to have the startup script *
-%%BASE%%* run the named version from the port: *
-%%BASE%%* *
-%%BASE%%* named_program="%%PREFIX%%/sbin/named" *
+* The %%PREFIX%%/etc/rc.d/named script will do that for you. *
* *
**********************************************************************
diff --git a/dns/bind99/pkg-install b/dns/bind99/pkg-install
deleted file mode 100644
index 12b2f98aaf25..000000000000
--- a/dns/bind99/pkg-install
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-# ex:sw=8 sts=8
-
-if [ "$2" = 'POST-INSTALL' ]
-then
- /bin/mkdir -p /var/named${PKG_PREFIX}/etc/namedb
-fi
-
-for DIR in ${PKG_PREFIX}/etc/namedb /var/named${PKG_PREFIX}/etc/namedb; do
- for FILE in named.conf rndc.conf rndc.key; do
- if [ "$2" = 'POST-INSTALL' ]
- then
- if [ -e ${PKG_PREFIX}/etc/${FILE} ]
- then
- /bin/cp -a ${PKG_PREFIX}/etc/${FILE} ${DIR}/${FILE}
- else
- /bin/ln -sf /etc/namedb/${FILE} ${DIR}/${FILE}
- fi
- fi
- if [ "$2" = 'POST-DEINSTALL' ]
- then
- [ -L ${DIR}/${FILE} ] && rm -f ${DIR}/${FILE}
- fi
- done
-done
-
-if [ "$2" = 'POST-DEINSTALL' ]
-then
- cd /var/named && /bin/rmdir -p ./${PKG_PREFIX}/etc/namedb > /dev/null 2>&1 || :
-fi
-
-exit 0
diff --git a/dns/bind99/pkg-plist b/dns/bind99/pkg-plist
index d1ad4402058b..5db4c7ee64de 100644
--- a/dns/bind99/pkg-plist
+++ b/dns/bind99/pkg-plist
@@ -4,6 +4,15 @@ bin/host
bin/isc-config.sh
bin/nslookup
bin/nsupdate
+etc/mtree/BIND.chroot.dist
+etc/mtree/BIND.chroot.local.dist
+%%ETCDIR%%/bind.keys
+%%ETCDIR%%/master/empty.db
+%%ETCDIR%%/master/localhost-forward.db
+%%ETCDIR%%/master/localhost-reverse.db
+@sample %%ETCDIR%%/named.conf.sample
+%%ETCDIR%%/named.root
+%%ETCDIR%%/rndc.conf.sample
include/bind9/check.h
include/bind9/getaddresses.h
include/bind9/version.h
@@ -375,16 +384,7 @@ sbin/named-journalprint
sbin/nsec3hash
sbin/rndc
sbin/rndc-confgen
-%%ETCDIR%%/rndc.conf.sample
-%%ETCDIR%%/bind.keys
-%%NOBASE%%etc/mtree/BIND.chroot.dist
-%%NOBASE%%etc/mtree/BIND.chroot.local.dist
-%%NOBASE%%@sample %%ETCDIR%%/named.conf.sample
-%%NOBASE%%%%ETCDIR%%/named.root
-%%NOBASE%%%%ETCDIR%%/master/empty.db
-%%NOBASE%%%%ETCDIR%%/master/localhost-forward.db
-%%NOBASE%%%%ETCDIR%%/master/localhost-reverse.db
-%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/dynamic
-%%NOBASE%%@dir %%ETCDIR%%/master
-%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/slave
-%%NOBASE%%@dir(bind,bind,) %%ETCDIR%%/working
+@dir(bind,bind,) %%ETCDIR%%/dynamic
+@dir %%ETCDIR%%/master
+@dir(bind,bind,) %%ETCDIR%%/slave
+@dir(bind,bind,) %%ETCDIR%%/working