aboutsummaryrefslogtreecommitdiffstats
path: root/dns/curvedns
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2014-07-05 06:19:17 +0800
committervsevolod <vsevolod@FreeBSD.org>2014-07-05 06:19:17 +0800
commit5ba125c98f099d12e805f0ebb2446700e533512d (patch)
treeb72143d5c017ca8497e54eb8de4e9d8a5b4c7415 /dns/curvedns
parent1e799b49b34fabe0cd0da0b7ef418215a1164419 (diff)
downloadfreebsd-ports-gnome-5ba125c98f099d12e805f0ebb2446700e533512d.tar.gz
freebsd-ports-gnome-5ba125c98f099d12e805f0ebb2446700e533512d.tar.zst
freebsd-ports-gnome-5ba125c98f099d12e805f0ebb2446700e533512d.zip
- Support staging
- Use portable libsodium - Use my local github fork for this port to decouple from nacl - Take maintainership
Diffstat (limited to 'dns/curvedns')
-rw-r--r--dns/curvedns/Makefile58
-rw-r--r--dns/curvedns/distinfo4
-rw-r--r--dns/curvedns/files/freebsd.patch25
-rw-r--r--dns/curvedns/pkg-plist12
4 files changed, 29 insertions, 70 deletions
diff --git a/dns/curvedns/Makefile b/dns/curvedns/Makefile
index b8c97341e7af..24f7056639e4 100644
--- a/dns/curvedns/Makefile
+++ b/dns/curvedns/Makefile
@@ -3,21 +3,27 @@
PORTNAME= curvedns
PORTVERSION= 0.88.b
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns
-MASTER_SITES= http://curvedns.on2it.net/releases/
DISTNAME= curvedns-0.88-unstable
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= vsevolod@FreeBSD.org
COMMENT= Forwarder adding DNSCurve to an authoritative nameserver
-LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
+USE_GITHUB= yes
+GH_ACCOUNT= vstakhov
+GH_TAGNAME= 0.87
+GH_COMMIT= a88e27e
+
+ALL_TARGET= targets
+
+LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev \
+ libsodium.so:${PORTSDIR}/security/libsodium
RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= configure.nacl
-ALL_TARGET= # yes, an empty target.
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USERS= bind
GROUPS= bind
@@ -26,37 +32,15 @@ CURVE_GID= 53
SUB_FILES= pkg-message
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64
-.endif
-
-post-patch:
- @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/freebsd.patch
-
-pre-configure:
- @${ECHO_MSG} "===> configuring may take a couple of minutes"
-
-post-configure:
-.if ${ARCH} == "amd64"
- @cd ${WRKSRC} && ./configure.curvedns amd64
-.else
- @cd ${WRKSRC} && ./configure.curvedns
-.endif
-
-post-install:
- ${CP} ${WRKSRC}/curvedns ${WRKSRC}/curvedns-keygen ${PREFIX}/bin/
- ${MKDIR} ${PREFIX}/etc/curvedns/log ${PREFIX}/etc/curvedns/env
- ${CP} ${WRKSRC}/contrib/curvedns-run ${PREFIX}/etc/curvedns/run.sample
- ${CP} ${WRKSRC}/contrib/curvedns-log-run ${PREFIX}/etc/curvedns/log/run.sample
- ${ECHO_CMD} ${CURVE_UID} > ${PREFIX}/etc/curvedns/env/UID
- ${ECHO_CMD} ${CURVE_GID} > ${PREFIX}/etc/curvedns/env/GID
- ${CHOWN} -R ${CURVE_UID}:${CURVE_GID} ${PREFIX}/etc/curvedns
- ${CHMOD} 755 ${PREFIX}/etc/curvedns/run.sample \
- ${PREFIX}/etc/curvedns/log/run.sample
- ${CHMOD} 0700 ${PREFIX}/etc/curvedns/env
- @${CAT} ${PKGMESSAGE}
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/curvedns ${WRKSRC}/curvedns-keygen ${STAGEDIR}${PREFIX}/bin/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/curvedns/log ${STAGEDIR}${PREFIX}/etc/curvedns/env
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/curvedns-run ${STAGEDIR}${PREFIX}/etc/curvedns/run.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/curvedns-log-run ${STAGEDIR}${PREFIX}/etc/curvedns/log/run.sample
+ ${ECHO_CMD} ${CURVE_UID} > ${STAGEDIR}${PREFIX}/etc/curvedns/env/UID
+ ${ECHO_CMD} ${CURVE_GID} > ${STAGEDIR}${PREFIX}/etc/curvedns/env/GID
+ ${CHMOD} 0700 ${STAGEDIR}${PREFIX}/etc/curvedns/env
.include <bsd.port.post.mk>
diff --git a/dns/curvedns/distinfo b/dns/curvedns/distinfo
index 46bace857a1f..87d04e48bcc3 100644
--- a/dns/curvedns/distinfo
+++ b/dns/curvedns/distinfo
@@ -1,2 +1,2 @@
-SHA256 (curvedns-0.88-unstable.tar.gz) = d43e068d2710cc3fc4bf3e7e46d3fac79c0ff66d28cb04148adec2237d339d49
-SIZE (curvedns-0.88-unstable.tar.gz) = 330546
+SHA256 (curvedns-0.88-unstable.tar.gz) = f2eab452177db925fc8e05d327bb18c4a4ac50645a75be68d7a293c128717ae6
+SIZE (curvedns-0.88-unstable.tar.gz) = 28703
diff --git a/dns/curvedns/files/freebsd.patch b/dns/curvedns/files/freebsd.patch
deleted file mode 100644
index 52d9299d6d07..000000000000
--- a/dns/curvedns/files/freebsd.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -rupN curvedns-0.88-unstable.orig/Makefile.in curvedns-0.88-unstable/Makefile.in
---- curvedns-0.88-unstable/.orig/Makefile.in 2011-01-10 21:15:14.000000000 +0000
-+++ curvedns-0.88-unstable/Makefile.in 2011-01-10 23:12:35.000000000 +0000
-@@ -8,9 +8,9 @@ NACLINC=nacl/build/include/$(ABI)
- CDNSCFLAGS=-Wall -fno-strict-aliasing -O3 -I$(NACLINC)
-
- # If you have libev at a non-standard place, specify that here:
--#EV=
--#EVCFLAGS=-I$(EV)/include
--#EVLDFLAGS=-L$(EV)/lib
-+EV=$(PREFIX)
-+EVCFLAGS=-I$(EV)/include
-+EVLDFLAGS=-L$(EV)/lib
-
- CC=@CC@
- CFLAGS=@CFLAGS@ $(CDNSCFLAGS) $(EVCFLAGS)
-@@ -33,7 +33,7 @@ distclean: clean
- rm -f Makefile
-
- install:
-- @echo Sorry, no automated install. Copy the following binaries to your preferred destination path:
-+ @echo Copieng the following binaries to /usr/local/bin
- @echo " $(TARGETS)"
-
- debug.o: debug.c debug.h
diff --git a/dns/curvedns/pkg-plist b/dns/curvedns/pkg-plist
index 8f2d0a50edbb..4ead953d39b0 100644
--- a/dns/curvedns/pkg-plist
+++ b/dns/curvedns/pkg-plist
@@ -1,13 +1,13 @@
bin/curvedns
bin/curvedns-keygen
+@owner %%CURVE_UID%%
+@group %%CURVE_GID%%
%%ETCDIR%%/env/UID
%%ETCDIR%%/env/GID
-@unexec cmp -s %B/%F %B/run && rm -f %B/run || true
-%%ETCDIR%%/run.sample
-@exec [ -f %%ETCDIR%%/run ] || cp -p %%ETCDIR%%/run.sample %%ETCDIR%%/run
-@unexec cmp -s %B/%F %B/run && rm -f %B/run || true
-%%ETCDIR%%/log/run.sample
-@exec [ -f %%ETCDIR%%/log/run ] || cp -p %%ETCDIR%%/log/run.sample %%ETCDIR%%/log/run
+@sample %%ETCDIR%%/run.sample
+@sample %%ETCDIR%%/log/run.sample
+@mode 0700
@dirrmtry %%ETCDIR%%/env
+@mode
@dirrmtry %%ETCDIR%%/log
@dirrmtry %%ETCDIR%%