aboutsummaryrefslogtreecommitdiffstats
path: root/dns/ddclient/Makefile
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-08-27 00:07:09 +0800
committerdirk <dirk@FreeBSD.org>2001-08-27 00:07:09 +0800
commit34504510c8c16901f86625a1936171d8f191937a (patch)
treefd37ce72914d44c1ba57ab6d5e1f7a745fa33d09 /dns/ddclient/Makefile
parentde151258a0922571f32a3bbd428314e7856c6c5f (diff)
downloadfreebsd-ports-gnome-34504510c8c16901f86625a1936171d8f191937a.tar.gz
freebsd-ports-gnome-34504510c8c16901f86625a1936171d8f191937a.tar.zst
freebsd-ports-gnome-34504510c8c16901f86625a1936171d8f191937a.zip
Add ddclient - a perl client used to update dynamic DNS entries for
accounts on many dynamic DNS services. WWW: http://burry.ca:4141/ddclient/
Diffstat (limited to 'dns/ddclient/Makefile')
-rw-r--r--dns/ddclient/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
new file mode 100644
index 000000000000..369c4fd3ea2d
--- /dev/null
+++ b/dns/ddclient/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ddclient
+# Date created: Sun Aug 26 14:45:12 CEST 2001
+# Whom: Dirk Froemberg <dirk@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ddclient
+PORTVERSION= 3.4.5
+CATEGORIES= net
+MASTER_SITES= http://burry.ca:4141/ddclient/
+
+MAINTAINER= dirk@FreeBSD.org
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+do-install:
+ @/usr/bin/perl -pi -e 's|%%PREFIX%%|${PREFIX}|g; s|%%PERL%%|${PERL}|g' ${WRKSRC}/ddclient
+ @${INSTALL_SCRIPT} ${WRKSRC}/ddclient ${PREFIX}/sbin
+ @${INSTALL_DATA} ${WRKSRC}/sample-etc_ddclient.conf ${PREFIX}/etc/ddclient.conf.sample
+ @${MKDIR} ${PREFIX}/share/ddclient
+.for i in COPYING COPYRIGHT README README.cisco sample-etc_cron.d_ddclient \
+ sample-etc_dhclient-enter-hooks sample-etc_dhcpc_dhcpcd-eth0.exe \
+ sample-etc_ppp_ip-up.local
+ @${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/share/ddclient
+.endfor
+ @/usr/bin/perl -pe 's|%%PREFIX%%|${PREFIX}|g' < ${FILESDIR}/ddclient.sh.sample > ${WRKDIR}/ddclient.sh.sample
+ @${INSTALL_SCRIPT} ${WRKDIR}/ddclient.sh.sample ${PREFIX}/etc/rc.d
+
+ @/usr/bin/perl -pe 's|/usr/local|${PREFIX}|g' < ${PKGMESSAGE}
+
+.include <bsd.port.mk>