aboutsummaryrefslogtreecommitdiffstats
path: root/dns/djbdns
diff options
context:
space:
mode:
authorlx <lx@FreeBSD.org>2013-07-24 04:48:13 +0800
committerlx <lx@FreeBSD.org>2013-07-24 04:48:13 +0800
commit591f3eff394484f65855343c13120d085f5bf563 (patch)
tree68d24a9e4426dbcd9bd45c299a6fa06fd66bb0aa /dns/djbdns
parent987657acc00593c078212dfb7255cadeb9078a16 (diff)
downloadfreebsd-ports-gnome-591f3eff394484f65855343c13120d085f5bf563.tar.gz
freebsd-ports-gnome-591f3eff394484f65855343c13120d085f5bf563.tar.zst
freebsd-ports-gnome-591f3eff394484f65855343c13120d085f5bf563.zip
Add option to auto-add users for dnscache, tinydns and dnslog.
PR: ports/180069 Submitted by: Alexandre Biancalana <ale@biancalanas.net>
Diffstat (limited to 'dns/djbdns')
-rw-r--r--dns/djbdns/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
index 0598523759d9..35abab2cac80 100644
--- a/dns/djbdns/Makefile
+++ b/dns/djbdns/Makefile
@@ -16,7 +16,7 @@ COMMENT?= A collection of secure and reliable DNS tools
RUN_DEPENDS= setuidgid:${PORTSDIR}/sysutils/daemontools \
tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
-OPTIONS_DEFINE= DUMPCACHE IP6 IGNOREIP JUMBO MAN PERSISTENT_MMAP SRV DNSCURVE
+OPTIONS_DEFINE= DUMPCACHE IP6 IGNOREIP JUMBO MAN PERSISTENT_MMAP SRV DNSCURVE ADD_USERS
OPTIONS_DEFAULT= MAN
DUMPCACHE_DESC= persistent cache for dnscache
IP6_DESC= IPv6 support by Felix von Leitner
@@ -26,9 +26,15 @@ MAN_DESC= manual pages by Gerritt Pape
PERSISTENT_MMAP_DESC= persistent mmap patch by Lennert Buytenhek
SRV_DESC= SRV record patch by Michael Handler
DNSCURVE_DESC= DNSCurve support by Matthew Dempsky
+ADD_USERS_DESC= Add dnscache, tinydns and dnslog users/groups
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MADD_USERS}
+USERS?= dnscache tinydns dnslog
+GROUPS?=dnscache tinydns dnslog
+.endif
+
.if ${PORT_OPTIONS:MJUMBO}
.if ${PORT_OPTIONS:MIP6} || ${PORT_OPTIONS:MIGNOREIP} || ${PORT_OPTIONS:MSRV} || \
${PORT_OPTIONS:MDNSCURVE}