aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnscheck
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-09-26 02:05:48 +0800
committermnag <mnag@FreeBSD.org>2005-09-26 02:05:48 +0800
commita6376cf2c5c7f6d46cf21b3c18fd50b3bb03ad8c (patch)
tree4bb81a19014977fab381a8660daa66b6f6621d45 /dns/dnscheck
parent3e2da708aefc9210f72443375ee581e5f514ffb9 (diff)
downloadfreebsd-ports-gnome-a6376cf2c5c7f6d46cf21b3c18fd50b3bb03ad8c.tar.gz
freebsd-ports-gnome-a6376cf2c5c7f6d46cf21b3c18fd50b3bb03ad8c.tar.zst
freebsd-ports-gnome-a6376cf2c5c7f6d46cf21b3c18fd50b3bb03ad8c.zip
New port
dnscheck is a simple to use DNS zone sanity checker, comparing name server records and serial numbers with both the parent zone and the zone itself. It allows you to find lame, leaked or stale name servers which have the potential to cause disruption. PR: 86542 Submitted by: arrod Sayers <jarrod@netleader.com.au> Approved by: pav (mentor)
Diffstat (limited to 'dns/dnscheck')
-rw-r--r--dns/dnscheck/Makefile27
-rw-r--r--dns/dnscheck/distinfo2
-rw-r--r--dns/dnscheck/pkg-descr6
3 files changed, 35 insertions, 0 deletions
diff --git a/dns/dnscheck/Makefile b/dns/dnscheck/Makefile
new file mode 100644
index 000000000000..61a4e3b173bf
--- /dev/null
+++ b/dns/dnscheck/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: dnscheck
+# Date created: 25 September 2005
+# Whom: Jarrod Sayers <jarrod@netleader.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnscheck
+PORTVERSION= 1.1
+CATEGORIES= dns
+MASTER_SITES= http://www.netleader.com.au/projects/dnscheck/download/
+
+MAINTAINER= jarrod@netleader.com.au
+COMMENT= DNS zone sanity checker
+
+USE_PERL= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/dnscheck
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^#!/usr/bin/perl |#!${PERL} |' ${WRKSRC}/dnscheck.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dnscheck.pl ${PREFIX}/bin/dnscheck
+
+.include <bsd.port.mk>
diff --git a/dns/dnscheck/distinfo b/dns/dnscheck/distinfo
new file mode 100644
index 000000000000..59e4bb23688e
--- /dev/null
+++ b/dns/dnscheck/distinfo
@@ -0,0 +1,2 @@
+MD5 (dnscheck-1.1.tar.gz) = d1ea687a0a2b0693567b52248b7a7bc6
+SIZE (dnscheck-1.1.tar.gz) = 4989
diff --git a/dns/dnscheck/pkg-descr b/dns/dnscheck/pkg-descr
new file mode 100644
index 000000000000..1a090af586e6
--- /dev/null
+++ b/dns/dnscheck/pkg-descr
@@ -0,0 +1,6 @@
+dnscheck is a simple to use DNS zone sanity checker, comparing name server
+records and serial numbers with both the parent zone and the zone itself.
+It allows you to find lame, leaked or stale name servers which have the
+potential to cause disruption.
+
+WWW: http://www.netleader.com.au/projects/dnscheck/