aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnsmasq-devel
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-02-05 09:49:52 +0800
committermandree <mandree@FreeBSD.org>2014-02-05 09:49:52 +0800
commitea7fb73547e82ee894ebcff9c26fc939674665bb (patch)
tree4e2b71e30a5595989893c42e40a601f8568ef93c /dns/dnsmasq-devel
parentadbfceb7456096b8630143653f059a33dc738d85 (diff)
downloadfreebsd-ports-gnome-ea7fb73547e82ee894ebcff9c26fc939674665bb.tar.gz
freebsd-ports-gnome-ea7fb73547e82ee894ebcff9c26fc939674665bb.tar.zst
freebsd-ports-gnome-ea7fb73547e82ee894ebcff9c26fc939674665bb.zip
Upgrade to test6, which adds DNSSEC validation and caching support.
Note that this requires configuration (see dnsmasq.conf.example for hints) and has a few rough edges with regard to caching.
Diffstat (limited to 'dns/dnsmasq-devel')
-rw-r--r--dns/dnsmasq-devel/Makefile18
-rw-r--r--dns/dnsmasq-devel/distinfo4
-rw-r--r--dns/dnsmasq-devel/files/patch-dnsmasq.conf.example13
-rw-r--r--dns/dnsmasq-devel/pkg-plist2
4 files changed, 31 insertions, 6 deletions
diff --git a/dns/dnsmasq-devel/Makefile b/dns/dnsmasq-devel/Makefile
index eec188b6e9a0..07bf370ec204 100644
--- a/dns/dnsmasq-devel/Makefile
+++ b/dns/dnsmasq-devel/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= dnsmasq
-PORTVERSION= 2.69.0test3
-DISTVERSION= 2.69test3
+PORTVERSION= 2.69.0test6
+DISTVERSION= 2.69test6
CATEGORIES= dns ipv6
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/test-releases/
PKGNAMESUFFIX= -devel
@@ -24,12 +24,13 @@ USE_XZ= yes
CFLAGS+= -Wall -Wno-unused-value
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" COPTS="${CFLAGS}" LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
-OPTIONS_DEFINE= IPV6 DBUS NLS IDN LUA
-OPTIONS_DEFAULT= IPV6 NLS
+OPTIONS_DEFINE= IPV6 DBUS NLS IDN LUA DNSSEC
+OPTIONS_DEFAULT= IPV6 NLS DNSSEC
OPTIONS_EXCLUDE+= EXAMPLES
NLS_DESC= National Language Support (NLS, enables IDN)
IDN_DESC= International Domain Names (IDN) WITHOUT NLS
LUA_DESC= Support lease-change scripts in LUA
+DNSSEC_DESC= Enable DNSSEC caching and validation
USES= shebangfix
SHEBANG_FILES= contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl \
contrib/dnslist/dnslist.pl
@@ -65,6 +66,12 @@ CFLAGS+= -DHAVE_LUASCRIPT
USE_LUA= 5.1
.endif
+.if ${PORT_OPTIONS:MDNSSEC}
+CFLAGS+= -DHAVE_DNSSEC
+LIB_DEPENDS+= libnettle.so:${PORTSDIR}/security/nettle
+LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
+.endif
+
USE_RC_SUBR= dnsmasq
.include <bsd.port.pre.mk>
@@ -89,7 +96,10 @@ pre-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${STAGEDIR}${PREFIX}/sbin
${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${STAGEDIR}${PREFIX}/etc
+ ${REINPLACE_CMD} -i '' 's}%%PREFIX%%}${PREFIX}}' ${STAGEDIR}${PREFIX}/etc/dnsmasq.conf.example
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 ${STAGEDIR}${PREFIX}/man/man8
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/trust-anchors.conf ${STAGEDIR}${DATADIR}/
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/dns/dnsmasq-devel/distinfo b/dns/dnsmasq-devel/distinfo
index 1dd3f3da6320..25301241df44 100644
--- a/dns/dnsmasq-devel/distinfo
+++ b/dns/dnsmasq-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dnsmasq-2.69test3.tar.xz) = 9d5cd1242c26b42664ec392b0a84506b2f3a3e0b8604861d5727f116080b41d8
-SIZE (dnsmasq-2.69test3.tar.xz) = 436760
+SHA256 (dnsmasq-2.69test6.tar.xz) = 36d753a913bdfad658dfd558ffd2dca59defb0d1ea3df3a423d7af436bfdff2e
+SIZE (dnsmasq-2.69test6.tar.xz) = 453140
diff --git a/dns/dnsmasq-devel/files/patch-dnsmasq.conf.example b/dns/dnsmasq-devel/files/patch-dnsmasq.conf.example
new file mode 100644
index 000000000000..84f9185d8bcf
--- /dev/null
+++ b/dns/dnsmasq-devel/files/patch-dnsmasq.conf.example
@@ -0,0 +1,13 @@
+--- ./dnsmasq.conf.example.orig 2014-02-04 21:20:35.000000000 +0100
++++ ./dnsmasq.conf.example 2014-02-05 02:04:00.000000000 +0100
+@@ -20,6 +20,10 @@
+ # Never forward addresses in the non-routed address spaces.
+ #bogus-priv
+
++# Uncomment these to enable DNSSEC validation and caching:
++# (Requires dnsmasq to be built with DNSSEC option.)
++#conf-file=%%PREFIX%%/share/dnsmasq/trust-anchors.conf
++#dnssec
+
+ # Uncomment this to filter useless windows-originated DNS requests
+ # which can trigger dial-on-demand links needlessly.
diff --git a/dns/dnsmasq-devel/pkg-plist b/dns/dnsmasq-devel/pkg-plist
index d5ae548e866b..a3d1749eeb50 100644
--- a/dns/dnsmasq-devel/pkg-plist
+++ b/dns/dnsmasq-devel/pkg-plist
@@ -3,10 +3,12 @@ sbin/dnsmasq
etc/dnsmasq.conf.example
@exec if [ ! -f %D/etc/dnsmasq.conf ]; then cp -p %D/%F %B/dnsmasq.conf; fi
man/man8/dnsmasq.8.gz
+share/dnsmasq/trust-anchors.conf
%%EXAMPLESDIR%%/dnslist/dhcp.css
%%EXAMPLESDIR%%/dnslist/dnslist.pl
%%EXAMPLESDIR%%/dnslist/dnslist.tt2
%%EXAMPLESDIR%%/dynamic-dnsmasq/dynamic-dnsmasq.pl
+@dirrm share/dnsmasq
@dirrm %%EXAMPLESDIR%%/dnslist
@dirrm %%EXAMPLESDIR%%/dynamic-dnsmasq
@dirrm %%EXAMPLESDIR%%