aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnsmasq/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-01-30 22:01:34 +0800
committerarved <arved@FreeBSD.org>2004-01-30 22:01:34 +0800
commit57b6ef8e00ce48366cba0918822b38ddcce74da0 (patch)
treed879ee1524fa29d7c017814da0fd62e8070f15c0 /dns/dnsmasq/Makefile
parent362c5f36ab81e6d90668190b1482ed3b44c7a38f (diff)
downloadfreebsd-ports-gnome-57b6ef8e00ce48366cba0918822b38ddcce74da0.tar.gz
freebsd-ports-gnome-57b6ef8e00ce48366cba0918822b38ddcce74da0.tar.zst
freebsd-ports-gnome-57b6ef8e00ce48366cba0918822b38ddcce74da0.zip
Update to 2.1
PR: 62083 Submitted by: Steven Honson <steven@honson.org>
Diffstat (limited to 'dns/dnsmasq/Makefile')
-rw-r--r--dns/dnsmasq/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index df3b37bddb09..7edc77b9af53 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -1,16 +1,16 @@
# New ports collection makefile for: dnsmasq
# Date created: 1 June 2003
-# Whom: Steven Honson <shonson@isoproplex.net>
+# Whom: Steven Honson <steven@honson.org>
#
# $FreeBSD$
#
PORTNAME= dnsmasq
-PORTVERSION= 1.18
+PORTVERSION= 2.1
CATEGORIES= dns
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/
-MAINTAINER= shonson@isoproplex.net
+MAINTAINER= steven@honson.org
COMMENT= A caching DNS forwarder
USE_REINPLACE= yes
@@ -21,9 +21,13 @@ post-patch:
@${REINPLACE_CMD} -e \
's|^CC = gcc|CC?=cc|g ; \
s|^CFLAGS = -O2|CFLAGS+=-O2|g' ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e \
+ "s,\/etc\/dnsmasq.conf,${PREFIX}\/etc\/dnsmasq.conf,g" \
+ ${WRKSRC}/src/config.h ${WRKSRC}/dnsmasq.8
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc/dnsmasq.conf.example
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${PREFIX}/man/man8
.include <bsd.port.mk>