aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnstop
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2002-11-01 02:59:02 +0800
committerfenner <fenner@FreeBSD.org>2002-11-01 02:59:02 +0800
commit87cf47bf781e54aadcea7c8e2b3faf0dfdbd4124 (patch)
tree76591418ac7727d0cb1848d42d3d6a08bc50d011 /dns/dnstop
parent1935258b9a53a31816a4418bf5fd58727191c76b (diff)
downloadfreebsd-ports-gnome-87cf47bf781e54aadcea7c8e2b3faf0dfdbd4124.tar.gz
freebsd-ports-gnome-87cf47bf781e54aadcea7c8e2b3faf0dfdbd4124.tar.zst
freebsd-ports-gnome-87cf47bf781e54aadcea7c8e2b3faf0dfdbd4124.zip
Add "dnstop", a libpcap application (ala tcpdump) that displays various
tables of DNS traffic on your network. Cribbed from itojun's NetBSD pkg.
Diffstat (limited to 'dns/dnstop')
-rw-r--r--dns/dnstop/Makefile24
-rw-r--r--dns/dnstop/distinfo2
-rw-r--r--dns/dnstop/pkg-comment1
-rw-r--r--dns/dnstop/pkg-descr11
-rw-r--r--dns/dnstop/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/dns/dnstop/Makefile b/dns/dnstop/Makefile
new file mode 100644
index 000000000000..9f2c75213518
--- /dev/null
+++ b/dns/dnstop/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: dnstop
+# Date created: 31 October 2002
+# Whom: fenner
+#
+# $FreeBSD$
+
+PORTNAME= dnstop
+PORTVERSION= 20021030
+CATEGORIES= net
+MASTER_SITES= http://dnstop.measurement-factory.com/src/
+DISTFILES= dnstop.c Makefile
+DIST_SUBDIR= dnstop
+
+MAINTAINER= fenner@FreeBSD.Org
+
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= .
+NO_WRKSUBDIR= true
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dnstop ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/dns/dnstop/distinfo b/dns/dnstop/distinfo
new file mode 100644
index 000000000000..8b9c65bc6348
--- /dev/null
+++ b/dns/dnstop/distinfo
@@ -0,0 +1,2 @@
+MD5 (dnstop/dnstop.c) = 1a73655fc92c1225ff10d845e12fbf25
+MD5 (dnstop/Makefile) = 24b84612e2acf9465c5c33e76960b05b
diff --git a/dns/dnstop/pkg-comment b/dns/dnstop/pkg-comment
new file mode 100644
index 000000000000..fdc7e34782dd
--- /dev/null
+++ b/dns/dnstop/pkg-comment
@@ -0,0 +1 @@
+Captures and analyzes DNS traffic (or analyzes libpcap dump)
diff --git a/dns/dnstop/pkg-descr b/dns/dnstop/pkg-descr
new file mode 100644
index 000000000000..9af1f119445c
--- /dev/null
+++ b/dns/dnstop/pkg-descr
@@ -0,0 +1,11 @@
+dnstop is a libpcap application (ala tcpdump) that displays various
+tables of DNS traffic on your network. Currently dnstop displays
+tables of:
+
+ * Source IP addresses
+ * Destination IP addresses
+ * Query types
+ * Top level domains
+ * Second level domains
+
+WWW: http://dnstop.measurement-factory.com/
diff --git a/dns/dnstop/pkg-plist b/dns/dnstop/pkg-plist
new file mode 100644
index 000000000000..9fc7274c6803
--- /dev/null
+++ b/dns/dnstop/pkg-plist
@@ -0,0 +1 @@
+bin/dnstop