aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnstracer/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-02-11 09:27:48 +0800
committeredwin <edwin@FreeBSD.org>2006-02-11 09:27:48 +0800
commit58a0317275baa11f7d924274b5f476bc293e26d1 (patch)
tree2e2695d7748c329e2ecbb56e6f64fa9b5d570263 /dns/dnstracer/Makefile
parent80b8741aff74dc11daff44c4123fed512cc1632f (diff)
downloadfreebsd-ports-gnome-58a0317275baa11f7d924274b5f476bc293e26d1.tar.gz
freebsd-ports-gnome-58a0317275baa11f7d924274b5f476bc293e26d1.tar.zst
freebsd-ports-gnome-58a0317275baa11f7d924274b5f476bc293e26d1.zip
[PATCH] dns/dnstracer: disable IPv6 support optionally
- disable IPv6 support optionally PR: ports/92872 Submitted by: Yen-Ming Lee <leeym@freebsd.org>
Diffstat (limited to 'dns/dnstracer/Makefile')
-rw-r--r--dns/dnstracer/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/dns/dnstracer/Makefile b/dns/dnstracer/Makefile
index 04dd920b645d..f1a1fd0ca244 100644
--- a/dns/dnstracer/Makefile
+++ b/dns/dnstracer/Makefile
@@ -20,4 +20,12 @@ USE_GMAKE= yes
MAN8= dnstracer.8
PLIST_FILES= bin/dnstracer
-.include <bsd.port.mk>
+OPTIONS= IPV6 "With IPv6 support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+=--disable-ipv6
+.endif
+
+.include <bsd.port.post.mk>