aboutsummaryrefslogtreecommitdiffstats
path: root/dns/dnswall
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2008-01-29 03:38:44 +0800
committerehaupt <ehaupt@FreeBSD.org>2008-01-29 03:38:44 +0800
commit4d9c893b9d28c7a35711dfa7181ca21ab35fb676 (patch)
treef9c16cc3d4f15d53b371404e5b1742ae1db24f6b /dns/dnswall
parentb51749a078f231056638d8e97bb5faba44244749 (diff)
downloadfreebsd-ports-gnome-4d9c893b9d28c7a35711dfa7181ca21ab35fb676.tar.gz
freebsd-ports-gnome-4d9c893b9d28c7a35711dfa7181ca21ab35fb676.tar.zst
freebsd-ports-gnome-4d9c893b9d28c7a35711dfa7181ca21ab35fb676.zip
Add dnswall 0.1.4, a daemon that filters out private IP addresses in DNS
responses. It is designed to be used in conjunction with an existing recursive DNS resolver in order to protect networks against DNS rebinding attacks.
Diffstat (limited to 'dns/dnswall')
-rw-r--r--dns/dnswall/Makefile34
-rw-r--r--dns/dnswall/distinfo3
-rw-r--r--dns/dnswall/files/patch-Makefile.am10
-rw-r--r--dns/dnswall/pkg-descr5
4 files changed, 52 insertions, 0 deletions
diff --git a/dns/dnswall/Makefile b/dns/dnswall/Makefile
new file mode 100644
index 000000000000..cbcc74431fdb
--- /dev/null
+++ b/dns/dnswall/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dnswall
+# Date created: 28 Jan 2008
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnswall
+PORTVERSION= 0.1.4
+CATEGORIES= dns security
+MASTER_SITES= http://google-dnswall.googlecode.com/files/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= A daemon that filters out private IP addresses in DNS responses
+
+USE_AUTOTOOLS= automake:110
+USE_DOS2UNIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+AUTOFILES= depcomp install-sh missing
+
+PORTDOCS= README
+PLIST_FILES= bin/dnswall
+
+pre-configure:
+.for f in ${AUTOFILES}
+ @${RM} ${WRKSRC}/${f}
+ @${LN} ${AUTOMAKE_DIR}/${f} ${WRKSRC}/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/dns/dnswall/distinfo b/dns/dnswall/distinfo
new file mode 100644
index 000000000000..3a28bb97252b
--- /dev/null
+++ b/dns/dnswall/distinfo
@@ -0,0 +1,3 @@
+MD5 (dnswall-0.1.4.tar.gz) = 5a16a99bf50b3451c65626cd4aaeafb6
+SHA256 (dnswall-0.1.4.tar.gz) = 8197c99e69ea389735dad0ffc9b76ee2ae0a293c13e4c4e548497c106cfce895
+SIZE (dnswall-0.1.4.tar.gz) = 67735
diff --git a/dns/dnswall/files/patch-Makefile.am b/dns/dnswall/files/patch-Makefile.am
new file mode 100644
index 000000000000..c9160882b96f
--- /dev/null
+++ b/dns/dnswall/files/patch-Makefile.am
@@ -0,0 +1,10 @@
+--- ./Makefile.am.orig 2008-01-28 20:28:44.000000000 +0100
++++ ./Makefile.am 2008-01-28 20:28:59.000000000 +0100
+@@ -2,5 +2,5 @@
+
+ SUBDIRS = src
+
+-docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
+-dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README
++docdir = $(prefix)/share/doc/$(PACKAGE)
++dist_doc_DATA = README
diff --git a/dns/dnswall/pkg-descr b/dns/dnswall/pkg-descr
new file mode 100644
index 000000000000..01d63cb34e95
--- /dev/null
+++ b/dns/dnswall/pkg-descr
@@ -0,0 +1,5 @@
+dnswall is a daemon that filters out private IP addresses in DNS responses. It
+is designed to be used in conjunction with an existing recursive DNS resolver
+in order to protect networks against DNS rebinding attacks.
+
+WWW: http://code.google.com/p/google-dnswall/