aboutsummaryrefslogtreecommitdiffstats
path: root/dns/fastresolve/files
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-07-15 19:36:32 +0800
committerijliao <ijliao@FreeBSD.org>2002-07-15 19:36:32 +0800
commitf27f75dcfbc34ce4929755aad32e8ed9c3a1fb20 (patch)
treeaec11568f59a627a648511aac885b17d0a382030 /dns/fastresolve/files
parent079cf3fdbbf927a7eeb352f9ae85b7598d53f49a (diff)
downloadfreebsd-ports-gnome-f27f75dcfbc34ce4929755aad32e8ed9c3a1fb20.tar.gz
freebsd-ports-gnome-f27f75dcfbc34ce4929755aad32e8ed9c3a1fb20.tar.zst
freebsd-ports-gnome-f27f75dcfbc34ce4929755aad32e8ed9c3a1fb20.zip
add fastresolve 2.8
Programs that process web logs to get DNS and domain ownership info PR: 40587 Submitted by: Amar Takhar <verm@drunkmonk.net>
Diffstat (limited to 'dns/fastresolve/files')
-rw-r--r--dns/fastresolve/files/patch-configure.in43
1 files changed, 43 insertions, 0 deletions
diff --git a/dns/fastresolve/files/patch-configure.in b/dns/fastresolve/files/patch-configure.in
new file mode 100644
index 000000000000..04094e1eb987
--- /dev/null
+++ b/dns/fastresolve/files/patch-configure.in
@@ -0,0 +1,43 @@
+--- configure.in.orig Wed Nov 15 14:50:37 2000
++++ configure.in Tue Jun 11 06:16:24 2002
+@@ -27,26 +27,26 @@
+ [dnl Check for a C++ interface, either version.
+
+ dnl 2.x.
+-AC_CACHE_CHECK([for Db::open in -ldb], djm_cv_lib_db_Dbopen,
++AC_CACHE_CHECK([for Db::open in -ldb3], djm_cv_lib_db_Dbopen,
+ [AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ djm_save_LIBS="$LIBS"
+-LIBS="$LIBS -ldb"
++LIBS="$LIBS -ldb3"
+ AC_TRY_LINK([#include <db_cxx.h>], [Db::open(NULL, DB_BTREE, DB_CREATE, 0, NULL, NULL, NULL);],
+ djm_cv_lib_db_Dbopen=yes, djm_cv_lib_db_Dbopen=no)
+ LIBS="$djm_save_LIBS"
+ AC_LANG_RESTORE])
+
+ if test $djm_cv_lib_db_Dbopen = yes; then
+- LIBS="$LIBS -ldb"
++ LIBS="$LIBS -ldb3"
+ else
+
+ dnl 3.x.
+-AC_CACHE_CHECK([for Db::open in -ldb_cxx], djm_cv_lib_db_cxx_Dbopen,
++AC_CACHE_CHECK([for Db::open in -ldb3_cxx], djm_cv_lib_db_cxx_Dbopen,
+ [AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ djm_save_LIBS="$LIBS"
+-LIBS="$LIBS -ldb -ldb_cxx"
++LIBS="$LIBS -ldb3 -ldb3_cxx"
+ AC_TRY_LINK([#include <db_cxx.h>], [Db *d = new Db(NULL, 0);
+ d->open(NULL, NULL, DB_BTREE, DB_CREATE, 0);],
+ djm_cv_lib_db_cxx_Dbopen=yes, djm_cv_lib_db_cxx_Dbopen=no)
+@@ -54,7 +54,7 @@
+ AC_LANG_RESTORE])
+
+ if test $djm_cv_lib_db_cxx_Dbopen = yes; then
+- LIBS="$LIBS -ldb -ldb_cxx"
++ LIBS="$LIBS -ldb3 -ldb3_cxx"
+ else
+ AC_MSG_ERROR([Berkeley DB library 2.x or 3.x configured with --enable-cxx is required])
+ fi