aboutsummaryrefslogtreecommitdiffstats
path: root/dns/fpdns
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2005-09-12 11:18:16 +0800
committerdougb <dougb@FreeBSD.org>2005-09-12 11:18:16 +0800
commitea5f3d6be579a511d8819f7f75accdee61cae649 (patch)
treeb88938e7cc98fce22296e37232cce408dc3e42dd /dns/fpdns
parent811f2075300c297e1fa0bf28492e17da933e13a6 (diff)
downloadfreebsd-ports-gnome-ea5f3d6be579a511d8819f7f75accdee61cae649.tar.gz
freebsd-ports-gnome-ea5f3d6be579a511d8819f7f75accdee61cae649.tar.zst
freebsd-ports-gnome-ea5f3d6be579a511d8819f7f75accdee61cae649.zip
Take over maintainership, approved by edwin (old maintainer).
Update to the latest, 0.9.3. This version moves to a more typical Perl-style Makefile.PL structure, and splits the functionality into a library and a binary. This necessitates changes to the port structure, including re-adding the pkg-plist file. While I'm here, make portlint happy with the IGNORE statement.
Diffstat (limited to 'dns/fpdns')
-rw-r--r--dns/fpdns/Makefile31
-rw-r--r--dns/fpdns/distinfo8
-rw-r--r--dns/fpdns/pkg-plist4
3 files changed, 21 insertions, 22 deletions
diff --git a/dns/fpdns/Makefile b/dns/fpdns/Makefile
index 1f95881a4fcc..8792a0b42e67 100644
--- a/dns/fpdns/Makefile
+++ b/dns/fpdns/Makefile
@@ -6,40 +6,35 @@
#
PORTNAME= fpdns
-PORTVERSION= 0.9.1
-CATEGORIES= dns
+PORTVERSION= 0.9.3
+CATEGORIES= dns net perl5
MASTER_SITES= http://www.rfc.se/fpdns/distfiles/
+DISTNAME= Net-DNS-Fingerprint-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= edwin@mavetju.org
+MAINTAINER= DougB@FreeBSD.org
COMMENT= FPDNS - Fingerprinting DNS servers
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
-WRKSRC= ${WRKDIR}
-NO_BUILD= yes
-USE_PERL5_RUN= yes
-MAN1= fpdns.1
+PERL_CONFIGURE= yes
-PLIST_FILES= bin/fpdns
+MAN1= fpdns.1
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= "Requires at least Perl version 5.6.0"
+IGNORE= Requires at least Perl version 5.6.0
.endif
-pre-extract:
- @${MKDIR} ${WRKDIR}
-
-post-patch:
+file= ${WRKSRC}/blib/man1/fpdns.1
+post-build:
@${SED} -e 's#\\&\\fIperl\\fR\\|(1), \\fINet::DNS\\fR\\|(1)#&, http://www.rfc.se/fpdns/#' \
- ${WRKDIR}/fpdns.1 > ${WRKDIR}/fpdns.1.sed
- @${MV} ${WRKDIR}/fpdns.1.sed ${WRKDIR}/fpdns.1
+ ${file} > ${file}.sed
+ @${MV} ${file}.sed ${file}
-do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/fpdns.pl ${PREFIX}/bin/fpdns
- ${INSTALL_MAN} ${WRKDIR}/fpdns.1 ${PREFIX}/man/man1
+post-install:
+ ${RM} ${SITE_PERL}/${PERL_ARCH}/auto/Net/DNS/Fingerprint/.packlist
.include <bsd.port.post.mk>
diff --git a/dns/fpdns/distinfo b/dns/fpdns/distinfo
index 9d6406bdd651..4db955b72a59 100644
--- a/dns/fpdns/distinfo
+++ b/dns/fpdns/distinfo
@@ -1,4 +1,4 @@
-MD5 (fpdns-0.9.1.tar.gz) = 731498ff6f2aab274b414ca60a22aacb
-SIZE (fpdns-0.9.1.tar.gz) = 8583
-MD5 (fpdns-0.9.1.tar.gz.sig) = 9991d049d2f710d61207f62bd866e846
-SIZE (fpdns-0.9.1.tar.gz.sig) = 72
+MD5 (Net-DNS-Fingerprint-0.9.3.tar.gz) = 16f1fbc9e5c8b935a0a48a509dc58899
+SIZE (Net-DNS-Fingerprint-0.9.3.tar.gz) = 10476
+MD5 (Net-DNS-Fingerprint-0.9.3.tar.gz.sig) = 421b0b767b2a343229e184549f0da19d
+SIZE (Net-DNS-Fingerprint-0.9.3.tar.gz.sig) = 65
diff --git a/dns/fpdns/pkg-plist b/dns/fpdns/pkg-plist
new file mode 100644
index 000000000000..646cf9f71f09
--- /dev/null
+++ b/dns/fpdns/pkg-plist
@@ -0,0 +1,4 @@
+bin/fpdns
+%%SITE_PERL%%/Net/DNS/Fingerprint.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/DNS/Fingerprint
+@dirrm %%SITE_PERL%%/Net/DNS