aboutsummaryrefslogtreecommitdiffstats
path: root/dns/idnkit2
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
commit41290677b018da2819144b0188ac8bd1b91a88e4 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /dns/idnkit2
parent02239bfdfc92a832c32cc57d07d3a1a4b3fc4ad9 (diff)
downloadfreebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.gz
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.zst
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Diffstat (limited to 'dns/idnkit2')
-rw-r--r--dns/idnkit2/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/dns/idnkit2/Makefile b/dns/idnkit2/Makefile
index d73faffe0dcf..9b27efe4ae79 100644
--- a/dns/idnkit2/Makefile
+++ b/dns/idnkit2/Makefile
@@ -20,7 +20,6 @@ USE_AUTOTOOLS= libtool
USES= iconv
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
USE_LDCONFIG= yes
@@ -33,4 +32,16 @@ MAN3= idn_checkname.3 idn_comparenames.3 idn_comparenames2.3 \
MAN5= idn2.conf.5 idn2rc.5 idnalias.conf.5 idnlang.conf.5
MANCOMPRESSED= no
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS= --with-libiconv=/usr
+.else
+CONFIGURE_ARGS= --with-libiconv=${LOCALBASE}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-liconv|${ICONV_LIB}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>