aboutsummaryrefslogtreecommitdiffstats
path: root/dns/knot2/Makefile
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
committerrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
commitabe85598b76e65884f63f5d35b14a7a5837c77ee (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /dns/knot2/Makefile
parenta6ebb885ab3952f319e4a2e650eba1580d82a26e (diff)
downloadfreebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.gz
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.zst
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Diffstat (limited to 'dns/knot2/Makefile')
-rw-r--r--dns/knot2/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index 8aa3fecb4ce5..c3854eaff1bb 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -14,6 +14,9 @@ COMMENT= High performance authoritative-only DNS server
LICENSE= GPLv3
+NOT_FOR_ARCHS= i386
+NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386 on FreeBSD >= 11.2
+
LIB_DEPENDS= libgnutls.so:security/gnutls \
libidn2.so:dns/libidn2 \
liblmdb.so:databases/lmdb \
@@ -60,13 +63,6 @@ FASTPARSER_CONFIGURE_ENABLE= fastparser
IDN_CONFIGURE_WITH= libidn
IDN_LIB_DEPENDS= libidn.so:dns/libidn
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1120000
-NOT_FOR_ARCHS= i386
-NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386 on FreeBSD >= 11.2
-.endif
-
post-patch:
@${REINPLACE_CMD} 's|$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|#$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|' \
${WRKSRC}/src/Makefile.in