aboutsummaryrefslogtreecommitdiffstats
path: root/dns/knot2
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-06-07 16:00:17 +0800
committerpi <pi@FreeBSD.org>2016-06-07 16:00:17 +0800
commitce0baffd1cc77d954a25014f7fe3fe79eb7b50a7 (patch)
treeaa96bf1be4b7b60f39d74a0ccf40828ccf02ac17 /dns/knot2
parente788458e31db4ba3b7137d0c018cf376b1fc1e5c (diff)
downloadfreebsd-ports-gnome-ce0baffd1cc77d954a25014f7fe3fe79eb7b50a7.tar.gz
freebsd-ports-gnome-ce0baffd1cc77d954a25014f7fe3fe79eb7b50a7.tar.zst
freebsd-ports-gnome-ce0baffd1cc77d954a25014f7fe3fe79eb7b50a7.zip
dns/knot2: Fix rc script
- knotc now takes "conf-check" not "checkconf" argument. PR: 210080 Submitted by: Andris Raugulis <moo@arthepsy.eu> Approved by: Leo Vandewoestijne <freebsd@dns-lab.com> (maintainer)
Diffstat (limited to 'dns/knot2')
-rw-r--r--dns/knot2/Makefile1
-rw-r--r--dns/knot2/files/knot.in2
2 files changed, 2 insertions, 1 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index aad3c1813d40..8bd7dd344953 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= knot
PORTVERSION= 2.2.1
+PORTREVISION?= 1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://dns-lab.com/downloads/knot-dns/
diff --git a/dns/knot2/files/knot.in b/dns/knot2/files/knot.in
index 0942d3711367..d502f6a313df 100644
--- a/dns/knot2/files/knot.in
+++ b/dns/knot2/files/knot.in
@@ -90,7 +90,7 @@ knot_prestart()
if [ ! -d /var/db/${name} ]; then
install -d -o ${diruser} -g ${dirgroup} /var/db/${name}
fi
- ${control} -c ${configfile} checkconf
+ ${control} -c ${configfile} conf-check
}
knot_reload()