aboutsummaryrefslogtreecommitdiffstats
path: root/dns/ldns
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-07-11 20:40:54 +0800
committermat <mat@FreeBSD.org>2013-07-11 20:40:54 +0800
commitcbaa6ff09de5d9b5ceadf7c3c21bdfe844c4d6ab (patch)
tree5732c6d9dcd3819c6dac1d4f4a2e78f8ec3bcb05 /dns/ldns
parente8ffab8cb0459b1ec692d98434bb5c359b64c457 (diff)
downloadfreebsd-ports-gnome-cbaa6ff09de5d9b5ceadf7c3c21bdfe844c4d6ab.tar.gz
freebsd-ports-gnome-cbaa6ff09de5d9b5ceadf7c3c21bdfe844c4d6ab.tar.zst
freebsd-ports-gnome-cbaa6ff09de5d9b5ceadf7c3c21bdfe844c4d6ab.zip
Have dns/py-ldns only install the Python bits.
PR: ports/179812 Submitted by: mat Approved by: maintainer
Diffstat (limited to 'dns/ldns')
-rw-r--r--dns/ldns/Makefile47
-rw-r--r--dns/ldns/pkg-plist6
2 files changed, 27 insertions, 26 deletions
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index 49711978b215..3d6a587ee101 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ldns
PORTVERSION= 1.6.16
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://www.nlnetlabs.nl/downloads/ldns/ \
CRITICAL
@@ -17,23 +18,32 @@ USE_GMAKE= yes
USE_OPENSSL= yes
USE_LDCONFIG= yes
-OPTIONS_DEFINE= DOXYGEN EXAMPLES DRILL GOST PYLDNS
+.if !defined(BUILD_PYLDNS)
+OPTIONS_DEFINE= DOXYGEN EXAMPLES DRILL
OPTIONS_DEFAULT= EXAMPLES DRILL
DRILL_DESC= With drill program
+.endif
+
+OPTIONS_DEFINE+= GOST
+
GOST_DESC= GOST signatures enabled, requires openssl >= 1.0.0
-PYLDNS_DESC= ${PYTHON_DESC}
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPYLDNS}
+.if defined(BUILD_PYLDNS)
USE_PYTHON= yes
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-CONFLICTS= ldns-[0-9]*
-.else
-CONFLICTS= py*-ldns-[0-9]*
-.endif
+ALL_TARGET= pyldns
+INSTALL_TARGET= install-pyldns
+CONFIGURE_ARGS+=--with-pyldns
+LIB_DEPENDS+= ldns:${PORTSDIR}/dns/ldns
+BUILD_DEPENDS+= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+
+post-patch:
+ @${SED} -i '' -e 's=-I./include/ldns=-I${LOCALBASE}/include/ldns=' ${WRKSRC}/Makefile.in
+.else
ALL_TARGET= all
INSTALL_TARGET= install-lib install-h install-config
@@ -233,13 +243,6 @@ MAN3= ldns_bget_token.3 ldns_bgetc.3 ldns_bskipcs.3 ldns_buffer.3 \
MAN1+= ldns-config.1
.endif
-.if ${PORT_OPTIONS:MGOST}
-BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
-.else
-NO_GOST= --disable-gost
-CONFIGURE_ARGS+=${NO_GOST}
-.endif
-
.if ${PORT_OPTIONS:MDRILL}
PLIST_SUB+= DRILLPROG=""
MAN1+= drill.1
@@ -262,15 +265,17 @@ MAN1+= ldns-chaos.1 ldns-compare-zones.1 ldns-dpa.1 \
PLIST_SUB+= EXAMPLES="@comment "
.endif
-.if ${PORT_OPTIONS:MPYLDNS}
-CONFIGURE_ARGS+=--with-pyldns
-BUILD_DEPENDS+= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
-INSTALL_TARGET+=install-pyldns
-PLIST_SUB+= PYLDNS=""
+.endif # BUILD_PYLDNS
+
+.if ${PORT_OPTIONS:MGOST}
+BUILD_DEPENDS+= openssl>=1.0:${PORTSDIR}/security/openssl
.else
-PLIST_SUB+= PYLDNS="@comment "
+NO_GOST= --disable-gost
+CONFIGURE_ARGS+=${NO_GOST}
.endif
+.if !defined(BUILD_PYLDNS)
+
post-configure:
.if ${PORT_OPTIONS:MEXAMPLES}
@(cd ${WRKSRC}/examples; ./configure --prefix=${PREFIX} \
@@ -299,4 +304,6 @@ post-install:
@(cd ${WRKSRC}/drill; ${GMAKE} install)
.endif
+.endif # BUILD_PYLDNS
+
.include <bsd.port.mk>
diff --git a/dns/ldns/pkg-plist b/dns/ldns/pkg-plist
index 583dd17c3a49..c85955a9f567 100644
--- a/dns/ldns/pkg-plist
+++ b/dns/ldns/pkg-plist
@@ -60,10 +60,4 @@ lib/libldns.a
lib/libldns.la
lib/libldns.so
lib/libldns.so.1
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.so.1
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/ldns.py
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.so
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.la
-%%PYLDNS%%%%PYTHON_SITELIBDIR%%/_ldns.a
-%%PYLDNS%%@dirrm %%PYTHON_SITELIBDIR%%/ldns
@dirrm include/ldns