aboutsummaryrefslogtreecommitdiffstats
path: root/dns/libbind
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2009-08-10 14:44:32 +0800
committerdougb <dougb@FreeBSD.org>2009-08-10 14:44:32 +0800
commitf804629177599a8a8496f3d493fdfe45d014dffa (patch)
treec66bdbf6cb8993c83240fa8e5144e97a6a8daeb2 /dns/libbind
parent4993a3ecf79f96a2e34e76c3c54fd55bc0ffef1c (diff)
downloadfreebsd-ports-gnome-f804629177599a8a8496f3d493fdfe45d014dffa.tar.gz
freebsd-ports-gnome-f804629177599a8a8496f3d493fdfe45d014dffa.tar.zst
freebsd-ports-gnome-f804629177599a8a8496f3d493fdfe45d014dffa.zip
The libbind functions have been separated from the BIND suite as of
BIND 9.6.0. Originally from older versions of BIND, they have been continually maintained and improved but not installed by default with BIND 9. This standard resolver library contains the same historical functions and headers included with many Unix operating systems. In fact, most implementations are based on the same original code. ISC's libbind provides the standard resolver library, along with header files and documentation, for communicating with domain name servers, retrieving network host entries from /etc/hosts or via DNS, converting CIDR network addresses, performing Hesiod information lookups, retrieving network entries from /etc/networks, implementing TSIG transaction/request security of DNS messages, performing name-to-address and address-to-name translations, and utilizing /etc/resolv.conf for resolver configuration. WWW: https://www.isc.org/software/libbind - Doug Barton DougB@FreeBSD.org
Diffstat (limited to 'dns/libbind')
-rw-r--r--dns/libbind/Makefile50
-rw-r--r--dns/libbind/distinfo6
-rw-r--r--dns/libbind/pkg-descr19
-rw-r--r--dns/libbind/pkg-plist29
4 files changed, 104 insertions, 0 deletions
diff --git a/dns/libbind/Makefile b/dns/libbind/Makefile
new file mode 100644
index 000000000000..2d61f69a1965
--- /dev/null
+++ b/dns/libbind/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: libbind
+# Date created: 9 August 2009
+# Whom: dougb
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbind
+PORTVERSION= 6.0
+CATEGORIES= dns net ipv6
+MASTER_SITES= ${MASTER_SITE_ISC} \
+ http://dougbarton.us/Downloads/%SUBDIR%/
+MASTER_SITE_SUBDIR= libbind/${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= DougB@FreeBSD.org
+COMMENT= Standard C resolver library
+
+MAKE_JOBS_UNSAFE= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var --with-randomdev=/dev/random
+
+OPTIONS= IPV6 "Compile with IPv6 support" on \
+ THREADS "Compile with thread support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.if !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-threads
+.else
+CONFIGURE_ARGS+= --disable-threads
+.endif
+
+MAN3= getaddrinfo.3 gethostbyname.3 getipnodebyname.3 getnameinfo.3 \
+ getnetent.3 hesiod.3 inet_cidr.3 resolver.3 tsig.3
+MAN5= resolver.5 irs.conf.5
+MAN7= hostname.7
+
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
+.include <bsd.port.post.mk>
diff --git a/dns/libbind/distinfo b/dns/libbind/distinfo
new file mode 100644
index 000000000000..6b141afb5f1f
--- /dev/null
+++ b/dns/libbind/distinfo
@@ -0,0 +1,6 @@
+MD5 (libbind-6.0.tar.gz) = 3e4e36fa39d0275ef97f74b737f30f0b
+SHA256 (libbind-6.0.tar.gz) = b98b6aa6e7c403f5a6522ffb68325785a87ea8b13377ada8ba87953a3e8cb29d
+SIZE (libbind-6.0.tar.gz) = 757162
+MD5 (libbind-6.0.tar.gz.asc) = 12398935b048f4d4722ee6d9cad59619
+SHA256 (libbind-6.0.tar.gz.asc) = 979a3346f8231e5918c1fc7a87f8da5677f4ccc87ca8c28b630d6c36d00e49fe
+SIZE (libbind-6.0.tar.gz.asc) = 475
diff --git a/dns/libbind/pkg-descr b/dns/libbind/pkg-descr
new file mode 100644
index 000000000000..cb0ea294d9fc
--- /dev/null
+++ b/dns/libbind/pkg-descr
@@ -0,0 +1,19 @@
+The libbind functions have been separated from the BIND suite as of
+BIND 9.6.0. Originally from older versions of BIND, they have been
+continually maintained and improved but not installed by default with
+BIND 9. This standard resolver library contains the same historical
+functions and headers included with many Unix operating systems.
+In fact, most implementations are based on the same original code.
+
+ISC's libbind provides the standard resolver library, along with header
+files and documentation, for communicating with domain name servers,
+retrieving network host entries from /etc/hosts or via DNS, converting
+CIDR network addresses, performing Hesiod information lookups, retrieving
+network entries from /etc/networks, implementing TSIG transaction/request
+security of DNS messages, performing name-to-address and address-to-name
+translations, and utilizing /etc/resolv.conf for resolver configuration.
+
+WWW: https://www.isc.org/software/libbind
+
+- Doug Barton
+DougB@FreeBSD.org
diff --git a/dns/libbind/pkg-plist b/dns/libbind/pkg-plist
new file mode 100644
index 000000000000..acb4cd3ad2cc
--- /dev/null
+++ b/dns/libbind/pkg-plist
@@ -0,0 +1,29 @@
+include/bind/arpa/inet.h
+include/bind/arpa/nameser.h
+include/bind/arpa/nameser_compat.h
+include/bind/isc/assertions.h
+include/bind/isc/ctl.h
+include/bind/isc/dst.h
+include/bind/isc/eventlib.h
+include/bind/isc/heap.h
+include/bind/isc/irpmarshall.h
+include/bind/isc/list.h
+include/bind/isc/logging.h
+include/bind/isc/memcluster.h
+include/bind/isc/misc.h
+include/bind/isc/tree.h
+include/bind/isc/platform.h
+include/bind/fd_setsize.h
+include/bind/hesiod.h
+include/bind/irp.h
+include/bind/irs.h
+include/bind/netdb.h
+include/bind/netgroup.h
+include/bind/res_update.h
+include/bind/resolv.h
+include/bind/sys/bitypes.h
+lib/libbind.a
+@dirrm include/bind/arpa
+@dirrm include/bind/isc
+@dirrm include/bind/sys
+@dirrm include/bind