aboutsummaryrefslogtreecommitdiffstats
path: root/dns/mydns-ng
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-10-17 14:19:06 +0800
committerale <ale@FreeBSD.org>2005-10-17 14:19:06 +0800
commit221c9a671340984f2267c4815b15f89e3a48c239 (patch)
treeee0ee681a1056a281ed307e7dff4b94d151ba0e0 /dns/mydns-ng
parent960abb9bd58e38f046a88011bec4b7e28d921f0c (diff)
downloadfreebsd-ports-gnome-221c9a671340984f2267c4815b15f89e3a48c239.tar.gz
freebsd-ports-gnome-221c9a671340984f2267c4815b15f89e3a48c239.tar.zst
freebsd-ports-gnome-221c9a671340984f2267c4815b15f89e3a48c239.zip
Make LOCALBASE clean.
Spotted by: kris
Diffstat (limited to 'dns/mydns-ng')
-rw-r--r--dns/mydns-ng/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index 8191d0cf1c05..90632e6a13e8 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -36,15 +36,21 @@ CONFIGURE_ARGS+=--enable-alias
.if defined(WITH_OPENSSL)
USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl
+CONFIGURE_ARGS+=--with-openssl \
+ --with-openssl-include=${OPENSSLINC} \
+ --with-openssl-lib=${OPENSSLLIB}
.endif
.if defined(WITH_PGSQL)
USE_PGSQL= yes
-CONFIGURE_ARGS+=--without-mysql
+CONFIGURE_ARGS+=--without-mysql \
+ --with-pgsql-include=${LOCALBASE}/include \
+ --with-pgsql-lib=${LOCALBASE}/lib
PKGNAMESUFFIX= -pg
.else
-CONFIGURE_ARGS+=--without-pgsql
+CONFIGURE_ARGS+=--without-pgsql \
+ --with-mysql-include=${LOCALBASE}/include/mysql \
+ --with-mysql-lib=${LOCALBASE}/lib/mysql
PKGNAMESUFFIX= -mysql
USE_MYSQL= yes
.endif